Question about Vacuums

1 Answer

I have been trying to register on line and can't get in. I am having problems with my WindTunnel powered nozzle it doesn't want to run and I just got this as a gift May 1st. The power hand tool works but not the other one and I know all the connectins are good

Posted by on

  • Patrick Michaels
    Patrick Michaels May 11, 2010

    perhaps a note on what model you are using will assist us to fixya?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

It will have a years warranty on it. Take it in to a warranty repair shop and tell them that yo got it as a gift and when.

Posted on May 15, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My hoover windtunnel upright self-propelled..seems the rollers are turned off. where is switch to turn them on?


The switch to turn the brush roll on and off is on the top cover of the nozzle housing

Jul 22, 2014 | Hoover Vacuums

1 Answer

Hoover S3765


If you light and nozzle motor both go off at the same time, you might have a bad power cord. Mine had this problem which I could verify by jiggling/twisting the cord near the strain relief on the nozzle. It would go on and off as I did this. The cord is cheap to replace, around $13 for the part shipped. Part number is 59134072.

May 30, 2012 | Hoover S3765-040 WindTunnel Bagless...

1 Answer

How do I switch the vacuum from floor to accessory suction


It automatically switches over when you disconnect the hose from the power nozzle. No suction it getting to the power nozzle, so the suction is only through the attachments. If there is no suction through the hose, check for clogs in the hose and in the tank where the hose plugs in. Also, check the screen at the bottom of the tank. If there is a clog in the hose or tank, then there also will be no suction to the power nozzle.
Remove all clogs and you should get suction.

Dec 19, 2010 | Hoover U5721-900 WindTunnel Upright Vacuum

1 Answer

The electric motor in the Power Nozzle does not work when the turned on.


There could be several issues with this. First determine if the problem is in the nozzle, hose or wand. This can be done by turning the unit on and wiggling the connections. One known issue with canisters is the cord that sticks out the back of the power nozzle goes bad, due to movement and normal use. There are also 2 electronic control boards inside the canister that give some problems. If you are unsure about looking at it, take it to a qualified repair shop.

Apr 13, 2010 | Hoover S3765-040 WindTunnel Bagless...

1 Answer

Hoover s3765 windtunnel power head does not run


I have the exact same problem as you have. Have you found a solution since you posted on Mar. 18, 2009? Thank you.

Mar 18, 2009 | Hoover S3765-040 WindTunnel Bagless...

2 Answers

I NEED A MOTOR FOR MY HOOVER POWER NOZZLE MOD. NO. S5682 WHERE CAN I CHECK FOR PRICES?


Part number is 43177062 and will sell for around $80. You will have to just call around to your repair shops, or maybe find one on line.

Mar 29, 2008 | Hoover U5453-900 WindTunnel Supreme Bagged...

1 Answer

Hoover WindTunnel Canister: Roller brush motor not turning


These motors have a fuse incorporated in the field winding and it sounds like that blew. These motors sometimes overheat at the front bearing and the bearing will melt into the plastic housing. This will cause the fuse to blow. It sounds like that's your problem. You can remove the motor by removing the three screws on the bottom of the powerhead and then check the front bearing for any bubbling or blistering in the plastic housing. The shaft of the motor should turn easily.

Jan 26, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

3 Answers

Hoover s3755 bagless windtunnel canister


Very likely it's the cord at the nozzle neck. These cords flex when you vacuum and they often break internally where the cord goes into the neck. Turn the vacuum on and wiggle the cord at the powerhead and see if the powerhead comes on and off. If this happens, then you will have to replace the cord.
On some of the early models, the receptacle in the hose, where it plugs into the top of the wands, will break away from the plastic pins it sits in, and the receptacle will slide back into the handle, which means that it will not plug into the powerhead connection when you connect the hose. You can check this by looking at the end of the hose and observing if the receptacle is sitting flush with the opening it sits in. If it is pushed back, it will not make a complete connection with the powerhead cord that is sitting at the top of the wands.

Jan 18, 2008 | Hoover S3755 WindTunnel Bagless Canister...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

45 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18299 Answers

Roger Potts

Level 3 Expert

694 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...