Question about Audio Players & Recorders

1 Answer

My digitech rp 250 guitar processor seems to be frozen. everything is all lit up and its all zeros in the display screen.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,137 Answers

Here is a link you will need to the latest firmware update:http://www.digitech.com/software_support/RP250Windows.php Make sure you follow all directions carefully. Look in your owners manual at how to reset the pedal. If all this fails contact support at their website. Also you didn't mention if you were using a Mac or a P.C. so I gave you the P.C. link. The Mac link can also be found there. Hope this helps.

Posted on Sep 01, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The Digitech Trio seems to be frozen, when I start it the red light blinks slow, after pressing the pedal it starts to blink fast but will do nothing after that


This is almost always due to the guitar signal not getting to the TRIO guitar input. The fast blinking LED should go solid red on the first strum. Make sure your guitar volume is turned up and that if you have a volume pedal or tuner or any other effect between the TRIO and the guitar, that it is passing the signal.

Aug 22, 2015 | Music

1 Answer

The lights are on but nothing is coming out,, no voice no guitar nothing???


Double check all your settings, then do a reset. If that doesn't work it will need to go to the shop. Here is the Digitech contact page to ask them or to find a service center-
Support DigiTech Guitar Effects

Apr 01, 2015 | DIGITECH Vocalist Live 5 Vocal Harmony and...

1 Answer

My Wawa pedal went out on my Digitech RP 500 how could I make it work again


This might work - Hold the bypass switch for five seconds and follow the on screen instructions to calibrate the expression pedal. If that doesn't work you could also try doing a back up and then a factory reset. You may also consider a separate wah pedal. There are many recommendations at:
What Is The Best Wah Pedal For The Money Our Answer For You

Jan 07, 2015 | DIGITECH RP500 Guitar Multi-Effects Pedal

1 Answer

Bought a digitech rp355 went to set it up but i have no sound


If the unit is in bypass mode, the display will indicate "BYPASS" That would bypass the RP355. You might try that to see if the problem is with the 355.

You might also have issue with the output being essentially low Z out if it is plugged into a High Z input.

Are you using the unbalanced 1/4 inch guitar jacks or the XLR? Is the XLR wired correctly? If not it may be grounding out the input.

If your eurozone power pack is the correct polarity on the coaxial power plug, the unit should light up. If it is not even doing that- check the polarity as it may be reversed from what you need. As long as the the output voltage and current is close to what the American power supply output current is- molded into the power pack, there should be no issue there if polarity of coaxial plug is correct. It should behave and respond to the various setting displyed on the RP unit.

Is it plugged into a computer? Did the computer recognize the driver? Is there a software conflict? If you have a windows machine, you can open the device manager and see if there is a yellow X or yellow question mark on the device- if so the driver either did not install, or there is a software conflict. you may need to to enable the audio for that input in "Audio Properties" in the control panel of the PC. If a mac- make sure it is selected under "Chooser".

In short- you should be able to plug your guitar into the unbalanced input of the RP, and then you can run a cable from the RP unbalanced output to the guitar amp. There are 5 different lengths of 1/4 inch jack in use- make sure yours are the right length for the amp, and the RP.

in bypass mode, the guitar should be heard, you can put the unit in bypass mode by pressing the up and down keys at the same time. Also make sure the amp is not in standby or muted either. These things can happen. It should work, it shoudl light up, it should give you visual indication something is or should be happening.

Apr 01, 2012 | DIGITECH Music

1 Answer

RP 100


I am assuming you are referring to the tuning aspect of the processor. Factory default is "A" but you should be able to change that via the Parameter1 knob. Or someone did change it and saved that alternate, if you bought it used.

If you do not have a manual, here is a link to the US version, which was designated as 100 A
http://www.digitech.com/en-US/products/rp100a

Mar 29, 2012 | Music

1 Answer

My digitech rp 500 has power supply but it won't


Make sure you have the OFFICIAL Digitech power adapter. Universal adapters or those for MOST other pedals will NOT work... things may light up but you will NOT get audio. This unit requires an adapter supplying 9 VAC (not DC) at about 1 amp. These AC output adapters are not very common and people get the units without an adapter and try using universal adapters and they do not work. An AC adapter is used by Digitech so they can generate both plus and minus voltages internally. I don't know what your utility power voltage is in Cebu, so you need to get an adapter for your voltage that will give 9 VAC output and fit the power jack on the unit.

Sep 15, 2011 | Digidesign Digitech Control 2 pedal for...

1 Answer

Hi I have a Digitech RP 300 Modeling Guitar Processor that lights up and will play the metronome tik but will not output the guitar, the guitar input is dead or semes to be. can any one help. thanks...


The metronome is built in software, but it proves that your output is working fine. That's good.
Try changing your patch cable from guitar>pedal. if that doesn't fix it, grab a screwdriver.
Open the pedal and check the input port - is there any bent pieces or blockages preventing the cable from contacting what it needs to? Is the solder broken, cracked, or missing? Are both contact points firm and in place?

May 11, 2011 | Music

1 Answer

Need printable manual for digitech rp50 multi effects guitar processor


ftp://ftp.digitech.com/pub/PDFs/Manuals/RP50%20Manual%2018-1396V-A.pdf

Aug 18, 2010 | DIGITECH Audio Players & Recorders

2 Answers

Digitech RP250


you can download an instruction manual for free from here... I am sure that it will help you. http://www.devicemanuals.com/guide/Musical%20Instruments/DigiTech/DigiTech-RP250-English-User-Guide-TmpVeE16WT.html

or ask your question of this forum... i am sure they can help :)
http://www.digitech.com/soundcomm/new_account.asp

Dec 26, 2007 | Audio Players & Recorders

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

228 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5011 Answers

The Knight
The Knight

Level 3 Expert

73619 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...