Question about Windsor SR12 Sensor Bagged Upright Vacuum

1 Answer

Our Winsdor Sensor XP12 does not show any power or lights, I did check the handle connection, it was fine. The power cord has been repaired with duct tape 3-4 x where someone has sucked up the cord, this may be the cause yet it ran fine last time it was used! so I am at a loss, please help if possible.08/31/2010 Steve

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 694 Answers

Any time the cord has been damaged badly enough to require taping, the possibility or intermittent "opens" exist. This means the wires are in contact much of the time, but will losed contact periodically. Even if it worked fine seconds ago, jiggling just right may cause this. This also presents a shock hazard.
I strongly recommend replacing the cord as soon as possible. If you are unable to do this, then please take it to a shop to be done.

Posted on Sep 01, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Where is vacuum chamber on a Windsor sensor xp12


it comes up from the back,it is probably plugged or the sensor is dirty

Apr 21, 2015 | Windsor Vacuums

1 Answer

Electrolux power head not working no power


There are four points of connection to get power to the nozzle, any one of which can cause this condition, or an on/off condition. They are the connections in the neck of the machine itself where the hose is inserted in front. The second is underneath the hose handle, where it connects to the two pronged sheath cord. The third is at the lower end of the sheath cord where the power nozzle cord connects. The last is the reset itself. That's what I check first when one of them is brought into my shop, because, believe it or not, most people don't know that there's even a reset there. If the little red button is sticking up push it down firmly but not hard. It's possible to push the bottom right out of the reset unit itself. If the nozzle doesn't activate after pressing the reset, start by disconnecting the power cord that goes to the wands. Check for blackened, enlarged connection openings, or charged, blackened prongs. If no problems found there, continue on up the handle checking each connection point for these conditions. If you find the problem at any of the connection points both parts must be replaced, the male and the female ends. That usually means replacing the cords themselves, as the ends are not available separately. If the power nozzle still refuses to run you or a qualified repair person will need to open it up to check the motor itself to see if it's any good. Once the faulty part,(s) are found and replaced it should start right back up and run normally.

Jun 15, 2014 | Electrolux Vacuums

1 Answer

My Kirby G5 has stopped working, last few times it was used it kept cutting out everytime the handle was moved??????????


Hi,

This definitely sounds like your cord is bad. The reason that I specifically think that it's your cord is because the cord is actually connected into the handle, and is attached to the handle in the back. This would make sense why the machine was cutting off every time the handle was moved.

Also the cords are notorious on Kirby's for going bad, and are usually the only thing that goes bad on a constant basis.

Here's how you can check to see if your cord is bad or not:

Greetings from GoVacuum.com,

Unfortunately there is no fuse on a Kirby Generation model. In my 10 years of repairing Kirby's as well as other vacuums2_bing.gif I will tell you that 9 times out of 10, when a Kirby Generation doesn't turn on, it's the cord that needs to be replaced. This is by far the most common problem that we see on Kirby repairs.
The Kirby motor is very well built, and usually has a life of 30+ years (G3 is about 12-15 years now). The only other problem it could be on the Kirby would be carbon brushes, or the switch assembly.

I would first try testing the power cord, I think this will solve the problem for you. To test a cord on a Kirby Generation (all Generation models are the same machines, just different colors) first follow where the cord goes into the Kirby at the bottom. To access this cover easier, first remove the "boot" at the bottom of the outer bag. This is the plastic part at the bottom of the outer bag that connects onto the Kirby. You will see that there is a plastic cover over the cord. You will need to remove the screw that holds this cover on.
f4cbc02.jpg
24851b4.jpg

Now after you have removed the cover, pull the plug out of the machine. Once you have the cord disconnected from the machine, you can now test it to see if there is a short somewhere in the cord. You will need to purchase an inexpensive continuity tester from Home Depot, Radio Shack or most other electronic stores. This will tell you if there is power running through the cord, or if the cord is bad. With the continuity tester, plug the cord into the wall outlet, then put the positive, and negative testing rods into the female end of the cord that plugs into the machine. You will then be able to tell if the cord has continuity going through it. The tester will indicate if there's continuity or not.
ececc51.jpg

The picture here shows that the cord is good. If your tester does not light up, or indicate that there is continuity, you'll simply just need to purchase a new cord. As I stated earlier, this is the most common reason that a Kirby won't turn on.

If however your cord tests OK, this indicates that the machine either needs a new motor (or carbon brushes in the motor) or it needs a new switch.



Chris Jones
GoVacuum.com

Apr 14, 2010 | Kirby G5 Bagged Upright Vacuum

1 Answer

Sebo Automatic X1 Stopped. Yesterday my Sebo stopped working. I know this can happen if it gets blocked and overheated so I checked for blockages, none. And left it too cool down. Tried it again but it was...


Hello,

Ok, thanks for the clarification. Even though the cord doesn't have any external damage, it's still very possible that it has gone bad. When a Sebo upright doesn't even start, this can mean one of several things. The parts that could go bad that would cause the machine not to turn on would be the cord (most common on a Sebo), the on/off switch, the PC board that's on top of the motor, or the actual motor. In the 7 years that I've been selling Sebo, I have only changed out one PC board, and I've never had to replace a single motor on a Sebo yet. I have had to replace several cords over the years, some showing external damage, others didn't show any damage.

The cord and the switch are going to be the easiest parts to test, and also happen to be the most common, so this is a great place to start.


Here's how you can test the switch and the cord on the vacuum cleaner. You'll need to have a simply Electrical tester that will test if current is going through the cord. Here's a link to a similar one that is very inexpensive that I used in this repair solution:
http://www.homedepot.com/h_d1/N-5yc1vZ1xh7/R-100183054/h_d2/ProductDisplay?langId=-1&storeId=10051&catalogId=10053


Step 1. Unwrap the electrical cord from the vacuum cleaner, and set the entire cord aside. Also remove the on-board wand that rests directly behind the bag housing. After the wand has been taken out, you should see on the left side of the vacuum where the handle goes into the body of the vacuum a little gray lever (my picture this lever is yellow as I only had a Sebo X5 on the floor, but the repair is identical). This is what the lever looks like:


80f63f9.jpg
Step 2. As you'll see if you look closely, the lever says "closed". Turn the lever towards the front of the vacuum so the lever reads "open".


8d9a86b.jpg
Step 3. Once the lever is moved to open, lift straight up on the entire handle assembly to remove it from the vacuum cleaner.


3c3c9cb.jpg
Step 4. Once you have the handle assembly out of the vacuum cleaner, turn the handle upside down. You'll be able to see two small metal electrical terminals that connect into the base of the vacuum where the handle meets the vacuum cleaner. Make sure that both terminals are visible. I have seen a few Sebo's where the handle has come loose, and these terminals no longer make connection to the rest of the vacuum, causing the vacuum not to turn on. You can re-attach the handle into the vacuum cleaner, turn the lever on the side from open back to closed, and test the vacuum to see if it comes on.

Step 5. If the vacuum failed to come on after reinstalling the handle, take the handle back out of the vacuum. Put one of the wires from your electrical tester into each terminal in the bottom of the handle assembly. Make sure that the tester is actually making contact with the metal terminals. It should look like this:


614747f.jpg
Step 6. With each of the electrical tester wires pushed down into the handle and making sure they are making contact, plug the cord into a standard wall outlet. If current is present, the electrical tester will light up. If not light comes on, try flipping the on/off switch and see if this has an effect on if the tester lights up or not:


1fdc3c7.jpg
As you can see in the picture above, the cord and switch on this vacuum are good. If your tester lights up when you put it into the handle, then this means that your cord and switch are good. This means that either your motor, or PC board have gone bad.

If the tester signals that you don't have any power at the bottom of the handle, then this means that either your switch or your cord is bad.

If you will please let me know the results of the electrical test here on the bottom of the handle, I will then go into the next steps of the repair, and explain how to open up the machine and either replace the cord / switch, or if you did have power here, the pc board or the motor.

Please just use the clarification request form that you used last time. I hope this was helpful in diagnosing your machine. If this helped you, please be kind and rate the repair as helpful by clicking the thumbs up icons in the top of the repair.

I look forward to helping you fix your Sebo.

Chris J.
GoVacuum

Apr 06, 2010 | Sebo Automatic X1 Bagged Upright Vacuum

3 Answers

No Power to Windsor Sensor XP12


The Windsor Sensor vacs all have a removable handle.

The handle is inserted into a "socket" which has contacts to complete the electrical circuit.

The handle is held in place by a gray plastic lever.

If the lever is not pressed down completely, the handle is able to slide within the socket during regular use.

If the handle slides out far enough, the electrical connection within will be disconnected and the vac will have no power.

Simply lift the lever, pull up to remove the handle, and re-insert the handle fully, then press down firmly on the lever to lock the handle securely in place.

This is the first step to solve your problem and hopefully this is all that need to be done.

If this does not work, please repost here and I will help you all I can.

Note: I am a big fan of the Windsor Sensor vacs and find them to be easy to work on and a great vac all around!

Aug 12, 2009 | Windsor SR12 Sensor Bagged Upright Vacuum

1 Answer

Power cut off after handle was dropped on floor while vacuuming


connections inside the handle came loose. happens to me all the time. take the handle apart and connect the wires back.

May 16, 2009 | Oreck XL Ultra Bagged Upright Vacuum

2 Answers

My orek has no power it won't turn on


the spade connections are loose, take the handle apart and check them

Jan 10, 2009 | Oreck XL Ultra Bagged Upright Vacuum

1 Answer

Was vacuuming fine and suddenly the thing won't turn on. Tried another plug.


Same thing happened to my Wertheim 4030. It turned out to be a broken connection in the retractable cord plug, no doubt due to continual shock upon retraction. How did I find it? By pulling the top off and first checking the internal switch was working with an ohmmeter (definitely no power for this test) Then plugged in, powered up & checked if any power to switch with AC voltage tester(be careful and have unit RCD protected for your safety) None showing, so checked if power at internal reel. None, so switched off power and checked continuity of cord for active and neutral continuity. None in one so cut off plug and checked again OK so new plug fitted and reassembled. If I had power to the switch originally, the motherboard/rheostat or motor may have been the problem. Hot wiring the motor would have determined which(unlikely to be both but a possibility) Repair or replace faulty item, obviously checking motor brushes first. Electrical is simply a matter of isolation and elimination.
rjjs

May 16, 2008 | Hoover Vacuums

2 Answers

Losing power to stick/floor vacuum


if you have an extension wand, the replacement will cost about $100.00. there is a way to repair both the pwr-cord on the brush assemble and the wand, but it depends on how much damage there is. also you need to check the contacts where the wand connects with the handle,and the prongs on the handle.

let me know if you still need help

Jan 11, 2008 | Kenmore 25614 / 25615 Progressive Bagged...

Not finding what you are looking for?
Windsor SR12 Sensor Bagged Upright Vacuum Logo

Related Topics:

235 people viewed this question

Ask a Question

Usually answered in minutes!

Top Windsor Vacuums Experts

Mike

Level 3 Expert

4340 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18410 Answers

Thatvacguy.com

Level 3 Expert

1335 Answers

Are you a Windsor Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...