Question about Hitachi 42EDT41 42 in. HD-Ready Plasma Television

5 Answers

Good sound, no picture

I have sound but no picture. This happened last month, and I unplugged and then plugged back in after a couple minutes. That doesn't work now. I unplugged all components and plugged directly to cable, still nothing. I read some of the solutions, but they are all 1-3 years old. Anything new out there for this problem? I can't see spending $1500 to fix it, since the prices are so low for new ones...Thanks.

Posted by on

  • 3 more comments 
  • AjeetG May 11, 2008

    YEs. Same problem, same day. Sound OK.. No picture.. Even Menu doesnot come. the screen does not light up . Pl let us know of any solution

  • AjeetG May 11, 2008

    My Model is 55HDT52 Plasme. Screen does not light up, sound fine. Only sound no pic.

    Pl l let me know

  • kcbudman May 11, 2008

    OK, I had a TV repairman come out and take a look. He said it would cost $760 to fix. He said there are 2 boards, one is a power supply and that he could fix it. The other had to be replaced. I don't know what that one is (makes me wonder...???) but that is the expensive one. He seemed to know over the phone what it was, like it is common, but he came out to make sure, for only $49. The board is supposed to cost $550 and then $210 labor to fix the power supply and install the new part. I am not sure why the power supply board is bad, the power works fine. It is just the lack of picture.



    I have read many, many problems with plasma TV's in the past week. Seems like a common problem. I guess it is not Hitachi, it is all of them. I DID call Hitachi, good luck, you better speak some form of Asian dialect.....



    I figure for now, I will buy a new LCD. I don' t think I will buy another Plasma. And even if I do, they are only about double the repair cost of this one...Good luck everyone. If I can figure out what the part is, I will add it here.



    The TV repair guy used my computer to price the part, and used www.repairworld.com just so you know. It is a subscription based website, $9.00 per month. I did not get on yet, since I don't know the part he was looking for to sell me. I might get on though, if I can figure out the part, to see if he was adding on to the price.

  • Anonymous Jul 13, 2008

    I have the same TV and same problem. Its just over 3 yrs old. It happened a few times and I always thought it was the cable, because the picture always came back on in a few minutes. It just happened the other day, but wouldn't come back on. We disconnected the cable, found it was the TV, and resorted to hooking up an old TV we had in the other room. A few hours later, we tried rehooking up the Plasma TV and it is working again. For now anyway. Of course the maintenance ran out in Jan. 08. When the came out to service the TV we didn't know their was a problem, so they only came out for a preventive maintenace check. All the service guy did was play with the remote, made sure the color was adjusted properly and off he went.

    I always knew the problems would occur after the warranty expired. To extend the warranty for a year they wanted $1000. I told them it wasn't worth it.

    It definitely sounds like something that should be addressed with this model and it should be covered. But if their is a recall I'd love to know about it in the future.

    I think when it blacks out for the final time, I'm going to buy an LCD. Plasma isn't worth it........

  • Anonymous Jan 26, 2009

    Hitachi 42EDT41A---Same problem no picture. does have sound. i have had tv 4 year 6 days. Called hitachi they said the gas had leaked out of tv. Hitachi said it was just trash. Could buy new one cheaper than fix this one. So I bought another one Hitachi P50A402. Still have old tv if some knows what is wrong please let me know. Thanks everyone, NO TV

×

5 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Hitachi Master
  • 8,457 Answers

Not the power supply board,it the backlight inverter video board,is dead replace that board only.Servicemanuals vstore.ca-product.Have alot these board pretty cheap.

Posted on Sep 27, 2009

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 62 Answers

Replace your y-sustain and z-sustain boards. I had the same problem with my 42edt41a and the new boards fixed the problem.

Posted on Sep 25, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Just had my Plasma Samsung 42" repaired by the Approved samsung shop in my local area. Same issue no picture only sound. They replaced the 2 power boards referred above. My final cost was $550. Not happy, but that is whay I kind of saved on the warranty. They told me a power surge could have damaged my boards, but that was dicarded after I told them I have a voltage regulator box to keep safe my tv. So the only other reson left for failure was bad luck and bad quality!

Conclusion: Will not buy another Samsung tv on the future (i'll go panasonic or Pioneer most likely) and will consider a bit more the extended warranty option.

Posted on Jun 12, 2008

Same problem here... suddenly picture went out and didn't come back... sound is good, switching on/off, cables and all don't work...

Posted on May 15, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Same problem by many people. Should we 2/3 people call Hitachi in a conf call????? They might listen if we team up and call them

Posted on May 11, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I HAVE ONLY HAD THIS TV A FEW MONTHS, I MOVED IT TO MY NEW PLACE LAST WEEK AND NOW IT WONT SWITCH ON


make sure the power outlet is working
unplug for a couple minutes plug back in see if it works
if it doesn't work and it's under warranty have them fix it
might be something simple like a fuse. hope it helps

Jun 24, 2015 | Flat Panel Televisions

2 Answers

Sony Bravia LCD 40" XBR2- Sound, but no picture; solid bright green screen


Sorry about your issue, however, LCD's do not have a lamp, they have a back light but the chances that is bad is a million to one. I strongly recommend taking it in for an evaluation. I understand your feelings that it should last 5 years or so, however I see every brand, a year or two old with these types of issues. The day's of no problems for 5 yrs up to 20 are definitely over. This is technology at it's finest.

May 23, 2009 | Sony Flat Panel Televisions

2 Answers

Wesitinghouse 37" all of a sudden wont work with hdmi cables plugged in. only picture with component cables in. ps3 wont work individually either currently have it directly into cable source and everything...


Same problem I had... My problem was with any HD input from PS3 (only HD device I have), the PS3 was fine on other televisions so I determined that it must be a problem with the TV in question. I fixed this problem by unplugging the TV, letting it sit for about a minute and then plugging back in.

Apr 13, 2009 | Westinghouse LTV-37w2 HDTV

1 Answer

Samsung LN46B550 no picture only sound 3 days old


hey Adam i have a samsung that has been doing that.it would come on then after a few minutes the picture would go ou but the sound still worked.i found that one of the connectors that plugs into the LCD board had a broken solder joint were it connects to the back lighting .just unplug your lcd connections if its bad you'll know it because it will come out.

Apr 05, 2009 | Samsung LN-S4692D 46 in. LCD HDTV

7 Answers

No sound on my Sanyo LCD 32" flat screen tv


I had this same problem this morning. Luckily, when I reset the whole thing and did the channel search again the sound returned. I have no idea why it fixed it but it did. Hope this helps you.

Feb 12, 2009 | Sanyo DP32746 32 in. LCD Television

1 Answer

Hitachi 50V500, no picture ,sounds for about 15 sec.then goes off


Hello,

I would try to re-seat the lamp. Pull the lamp out, check it to see if it may have gone bad again, then put it back in to make sure the contacts are connected. Before applying power, unplug the TV for 5 minute, and then plug in/turn it on.

Most lamps, if bad from the factory, will go out within 3 months of use. It does happen, and happens more often than you would think.

Try this, and see what happens. Good luck.

Jan 05, 2009 | Hitachi 50V500 50 in. HD-Ready LCD...

1 Answer

Hi Sense 26'' LCD2629 No Picture No Sound Just Black/White Lines


Unplug the TV to let the memory clear. Wait 1 minute, replug, see if that works.

Sep 03, 2008 | Hisense TL2620 26 in. LCD Television

2 Answers

Power button is green - no blinks / no picture / no sound


Unplug it from the wall, wait 2 minutes and plug it back in. if problem still exists, its probably the main pcb.

Jun 19, 2008 | Dynex 32 in. LCD Flat-Panel HDTV

1 Answer

Viewsonic w3250n no sound, no picture, beeping


Hi, Any other indicators aside from the beeping sound like blinking leds/lights? For the time being try to do a hard reset, unplug the LCD TV from the mains for a couple of hours and thereafter try again with a known good outlet.. If still a no go, post back, Good luck and kind regards.

Aug 26, 2007 | ViewSonic NextVision N3200w 32 in....

Not finding what you are looking for?
Hitachi 42EDT41 42 in. HD-Ready Plasma Television Logo

295 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hitachi Flat Panel Televisions Experts

The Knight
The Knight

Level 3 Expert

68323 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Paul

Level 2 Expert

223 Answers

Are you a Hitachi Flat Panel Television Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...