Question about Vacuums

Open Question

I have the Electrolux Velocity Pet Lover 1800w which has lost all suction from the pipe. I have checked for blockages and cleaned the filter but still no joy. Would changing the HEPA filter resolve the problem? Your help is much appreciated

Posted by on

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

#1 Taper
  • 1040 Answers

SOURCE: I have a velocity pet lover 1900 only 2 months old

You have broken the rubber belt that drives the brush. Flip over and remove the old belt and replace it with a new one.

Jim

Posted on Jun 11, 2009

  • 1 Answer

SOURCE: Electrolux velocity pet lover 1800

we had the same problem and replaced the driver belt. The only problem is that we seem to have to replace the belt everytime we hoover!

Posted on Jul 21, 2009

  • 175 Answers

SOURCE: hi,my vacumm is blowing air out of the vents .it

Those are the exhaust vents from the motor. It is designed that way to help keep the motor running cool.

Posted on Jan 01, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Electrolux Velocity pet lover 1800W Drive belts keep on breaking...


Dear Judy, there are several things that can cause the problem you are having but I can give you a few things to look at. First is that you are getting the correct belt for your machine. Second is the motor and brush roll moving freely after you install a new belt & before you start vacuuming?. Third is the machine set at it's lowest setting(try a higher setting to start) finally is the belt an after-market made in china one. Quality in Chinese rubber products can suck at times. If all this is ok than it maybe best to take to your local vacuum repair shop. Good Luck-Jack of all trades bob
http://www.habitacionesparalationos.org/

Jan 02, 2017 | Electrolux Vacuums

1 Answer

My vax pet Hoover has lost its suction I've emptied it there's no blockages and Iv cleaned the filter


first, if it has a hose check for being plugged, you may have to take the vacuum apart further till you reach the fan on motor which may have hair,lint,etc wrapped around it which can cause low suction.
Checking for Blockages in Your Vax Upright Vacuum Cleaner
press helpful button

Jan 09, 2016 | Hoover Vacuums

1 Answer

My electrolux vitesse pet lover 1800w has stopped working


Is the flex all right? Check it with a voltmeter or a continuity meter (available for a small sum in your local hardware or electrical shop).

Jan 19, 2015 | Electrolux Vacuums

1 Answer

Electrolux Vitesse Pet Lover 1800w. I was given this vacuum today. It works fine but is really loud. It's hardly had any use. Is this normal? I just put in ear protection.



Should not be that loud. Check all the filters and see if they are ok. Check to see what the suction level is. This is kind of subjective. IT might have a bad bearing in the motor.

Nov 18, 2013 | Vacuums

1 Answer

Electrolux pet lover loss of suction through the hose


I would use a snake for plumbing (sinks) and feed it down the hose to find and clear this blockage if you can remove the hose compressed air may also work.

Dec 18, 2012 | Vacuums

1 Answer

Eureka pet expert vacuum lost suction


I had the same problem with exact same vacuum, was working great and the one day just lost almost all suction in the hose and in very very poor suction on base when vacuuming carpet, also when vacuuming the carpet everything I vacuum shoots out the bottom and hits my feet, never happened b4, checked all hoses and tor apart every thing to see if their war dust in motor, clogging anywere but nothing everthing looked great, NEED HELP CANT AFFORD TO BUY ANOTHER VACUUM OR TO TAKE TO REPAIR MAN TO B CHRGED AN ARM AND LEG, SOMEONE PLEASE HELPPPP!!!!!!!!!!

Jun 05, 2012 | Eureka 3276AZ Pet Lover Bagless Upright...

1 Answer

I have a velocity pet lover 1900 only 2 months old


You have broken the rubber belt that drives the brush. Flip over and remove the old belt and replace it with a new one.

Jim

Jun 10, 2009 | Electrolux EL1000A2 Pronto Bagless Stick...

1 Answer

NO SUCTION


If you have no suction, there are only a couple of things that could cause it. As you have checked for blockage, and changed your filters, you may have a vacuum motor with bad bearings, or broken fan blades (inside/on the vacuum motor). Either symptom points towards a vacuum motor being bad and needing replaced.

Jan 21, 2009 | Electrolux Central Vacuum

1 Answer

Electrolux velocity pet lover 1800


we had the same problem and replaced the driver belt. The only problem is that we seem to have to replace the belt everytime we hoover!

Sep 07, 2008 | Electrolux EL1000A2 Pronto Bagless Stick...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

192 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18389 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...