Question about Invacare Health & Beauty

1 Answer

I have a Invacare 3G Storm Arrow with GB motors. The left motor acts like a wheelbearing is bad. I lifted it and shook the wheel and to my surprise the 4 bolts that hold the hub on shook with the hud but the center bolt stayed soled ? What is the anti-rattle kit under the center bolt ? Could this be the problam ?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 692 Answers

Norm, the wheel is held on the axle by the center bolt. The 4 bolts that rattle hold the rim together (it is a split rim to remove the tire easier) these bolts should not be loose. Remove the center bolt and slide the tire off the axle (make sure the keyway stays on the axle or in the hub) tighten the 4 bolts and reinstall on your axle this should fix your problem. Hope this helps

Posted on Sep 01, 2010

Testimonial: "Whin I removed the hub from the axel the problem was obvious. The hub pin was striped and the axle was worn. You were in the wright area, Thanks"

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Runs ok but is noises. Makes sort of a grinding noise. Seems to be coming from motor or trans.


hi Richard, that noise is normally cause by one of the axle's bearing , by safely lifting the wheels off the floor, you should run the scooter and feel next to where axle goes into the gearbox around that area with care. you will be able to confirm what bearing it is, now if the whole gearbox sounds noisy and grinding when you touch it , that means at best it needs urgent lubrication or at worse the worm gears inside or badly worn..

If you remove the motor from the gearbox , i have seen where the coupler has broken and is rubbing, once again do this with gear..

Regards
Rob

Dec 08, 2015 | Invacare Lynx L3 3-Wheel

1 Answer

Left wheel will not move when engaged how can this be fixed


This could be a few things. You may have a bad motor, a bad cable, a bad brake unit that will not release, a bad controller.
Try the easy stuff first:
1. I would make sure the motor is plugged into the controller first. sometimes a bad connection will do this.
2. Check all the wiring to see if there is any damage to the motor and the brake (4 wires - the brake will have 2 black or white wires and the motor will usually have a red and black)
3. Listen for a clicking sound from the brake - if no click then it is very likely that it is bad.
4. Check the brushes - if they are less than 3/4 inch long, they are worn badly and need to be replaced. Usually if they are this worn the motor is going to run very rough - replacing the brushes will only be a temporary fix - you will need to replace the motors.
5.You can switch the motor leads and see if you get the same results - be careful - switching the motor leads makes everything run the opposite way (right would be left) - if the problem goes away, you had a bad connection.
6. If you still have problems, it would be best to get a tech to look at it.

I don't really think you have a bad controller. from what I understand, the chair runs, but only with 1 motor - if the controller was bad, it would not work at all.

Apr 23, 2015 | Invacare Pronto M51 Power Wheelchair

1 Answer

My motor on the right side is not working


should be simple enough, either the right motor has a problem (maybe worn out brushes) connector from motor to controller loose or apart, controller electronics for right motor on circuit board faulty, or power switching relays for motor have bad or worn contacts, or a fault from the control stick to the logic supply board.
best of luck.

Aug 15, 2013 | UPG Invacare Wheelchairs ARROW XT...

1 Answer

Has left motor error (3 blinks) checked


Hi. Your problem will be either the free-wheel lever is in the wrong position, or the motor has a stuck or worn carbon brush.
Good luck. Neil.

Jul 03, 2010 | Invacare Pronto M51 Power Wheelchair

1 Answer

Invacare storm series arrow model 3gar-cq seriel 091E000044 the tilt in space function is not being recognized after changing the tilt mechanism. When the switch is turned on it indicates a need to...


Hello :

Check this website please : http://www.ehow.com/about_4826562_invacare-wheelchairs.html

or this : http://www.invacare.com/cgi-bin/imhqprd/index.jsp

or this : http://www.invacare.com/cgi-bin/imhqprd/inv_catalog/prod_cat.jsp?s=0&catOID=-536885218

or this : http://www.invacare.com/cgi-bin/imhqprd/inv_catalog/literature_search.jsp?s=0&doSearch=true&searchType=KeySearch&keywords=STORM%20SERIES%20ARROW%20MODEL%203GAR#SHOWRESULTS

I hope that will help .

or simply contact INVACARE

Feb 21, 2010 | Invacare Health & Beauty

1 Answer

I have a invacare wheelchair pronto91 wont move 2 red lights flash 3 times


The three light flash indicates a short circuit between the left motor(as you are sitting in the chair)and the battery. Check all the wiring from the control box to the motor and make sure it is not damaged in any way. If it is okay, you have most likely fried the left side motor. A new motor-gearbox assembly for this chair runs in the neighborhood of $1,400.00, or you can take the motor off and take it in for a full rebuild for about $250 or so. Unplug the joystick and remove the seat and cowl. Jack up the left side with both motors in gear. Remove the center nut cover and take off the nut holding on the wheel taking care to retain the key that slides into the groove on the axle. Disconnect the wiring plug to the motor and remove the six bolts holding the motor to the frame. Separate the gearbox from the motor and take the motor to a rewind shop for repairs. Reinstall and it should be good to go.

Jan 03, 2010 | Invacare Supply Group Invacare Pronto M91...

1 Answer

My laft wheel hancs up. mostly when turning left and feels like the brake is sticking. It will hang up bad enpugh that the chair will not move and the safety lights are blinking when I try to move. After I...


Sounds like you need to replace the left electric brake. The brake is on the opposite end of the motor-gear assembly from the motor. Remove the screws holding the brake on to the gear assembly, unplug it and replace with new brake.

Dec 19, 2009 | Invacare Pronto M51 Power Wheelchair

1 Answer

M1V R11 Joy stick blinks 5 times


I believe this fault code indicates a left parking brake fault. Check all the connections from the motor/gear/brake assembly on BOTH motors (sometimes the controller gets confused). Follow the wires from the motor to the controller and reconnect them all. Make sure the free-wheel lever is in gear by taking out of gear, and placing back into gear firmly.

Good luck.

Jul 11, 2009 | Invacare Supply Group Health & Beauty

2 Answers

I have an arrow storm ,,,replaced motors with 4 pole motors , stronger, as well as a joystick , now it runs a few days and kills the joystick


UpGrading the Motors is your problem, they are stronger which is why your joy stick is being killed. Your joy stick is only rated for so much amps, ie voltage. By upgrading your motors you put an Incrediable strain on the joy stick, it tries to compensate for the newly added motors but fails.

Jun 09, 2009 | Health & Beauty

1 Answer

Reverse is slow 5 lightes flashing


Your right brake and or motor is bad or going bad.

Apr 27, 2009 | Invacare Supply Group Invacare Pronto M51...

Not finding what you are looking for?
Health & Beauty Logo

Related Topics:

335 people viewed this question

Ask a Question

Usually answered in minutes!

Top Invacare Health & Beauty Experts

wcdoc1953
wcdoc1953

Level 2 Expert

278 Answers

Colin Taylor

Level 2 Expert

346 Answers

MobilityRepairSpecia...
MobilityRepairSpecia...

Level 1 Expert

61 Answers

Are you an Invacare Health and Beauty Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...