Question about Dynamo MartinLogan Subwoofer Speaker

1 Answer

I own a used Martin Logan Dynamo (older series) and just today found out there is no sound coming out/no led light (at the back) either. I opened up the back and saw the 110V power is getting in but no power from power board into the others! Possibly the power supply unit is fried ;-( Any option of fixing this? Does ML sell these boards? Thanks for your help, Sudipto.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Did you get the sub fixed? I know someone with the same problem - won't turn on, fuse is fine. May be due to different underlying problem, but wondered if you discovered what it was and if you got it fixed.
Mike

Posted on Oct 29, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

WiFi with my Samsung TV. Today I get wireless connection; next 3 days no wifi. It comes back and then goes away again. I use wired connection, I get internet. I disconnect the wire and no wifi.


Sounds like your wifi signal strength is marginal, or you have interference.

How far are you from your router/access point?

Are there cordless phones, microwaves, fluorescent lights, large motors nearby?

I would just the wired connection. It will be far fewer problems!

May 31, 2016 | Samsung UN65ES8000FXZA - Slim Led/es8000...

1 Answer

LG LED tv with sound but no picture


Back - light problem. Check and replace damaged component/s at its back-light inverter board, or replace this board as card basis. If you wish to get some details; check the site linked here. Surf the site with patience. Pull up older posts. It will be best to replace the inverter board as card basis.
http://electronicshelponline.blogspot.com/
To some model sets; especially LED back-lighted types; the back-light inverter circuit will be part of the main power supply board [SMPS]. In such cases, the power supply board might need replacement.

Oct 19, 2015 | LG 50" 5400 Series LED HDTV - 50LN5400

1 Answer

I have a LG LED television that has no picture but does have sound. I have narrowed the problem down to 3 circuit boards. I'm trying to find out which one is faulty.


Back - light problem. Check and replace damaged component/s at its back-light inverter board, or replace this board as card basis. If you wish to get some details; check the site linked here. Surf the site with patience. Pull up older posts. It will be best to replace the inverter board as card basis.
www.electro-medical.blogspot.com
To some model sets; especially LED back-lighted types; the back-light inverter circuit will be part of the main power supply board [SMPS]. In such cases, the power supply board might need replacement
also check the video

Oct 09, 2015 | LG 47" 5700 Series LED HDTV - 47LN5700

1 Answer

How can i connect my dynamo 700 w using martin and logan transmitter to my marantz sr5008


You just need one of these though all the sockets would need to be male:

fc155ffe-19b1-48b3-b1c6-614c58679ff7.jpg

Jul 06, 2014 | Audio Players & Recorders

1 Answer

My battie light came in and didnt go off for a while it finally went off no the lights went dim and i had it busted and them started it up this morning then it dies again and now want start back


the battery light on the dash board turns on only if the battery is not charging
witch is means the problem basically on the (dynamo) itself and it probably affected your car`s battery as well
so you need to check the dynamo first check the dynamo belt
if not then you are facing a problem you`ll have to tail your car then have it`s dynamo checked at the work shop
the dynamo could have a bad regulators witch is something like ic or semiconductor thing
or the dynamo itself got melted cooper coils and it means you need to replace the whole dynamo
battery to be recharged and checked at the workshop and after the recharging completed if it found to be stop charging you will have to replace it also

May 22, 2011 | Pontiac Sunfire Cars & Trucks

1 Answer

I have the 1911 and Martin Logan Motion 10 speakers. Why do I have to turn the volume up so hi to get sound?


are the ohms on the speakers and the receiver rated the same, if not theres the problem

Mar 14, 2011 | Denon Audio Players & Recorders

2 Answers

1985 700 vulcan , the bike starts , runs , everything works but the headlight , fuses look good , what am i missing?


Try taking off the switch. use a jumper wire across the leads. if your headlight comes on, replace the switch.

Aug 29, 2010 | Clymer Kawasaki Vulcan 700 Vulcan 750...

2 Answers

Bought a used Martin Logan Dynamo subwoofer a couple days ago and have a very loud hum when the ac cord is plugged in, even if the speaker is not connected to an audio source. The "hum" can be heard in any...


Neither the amp or the sub have grounded power cords.

I have discovered the ML Dynamo takes about 30 minutes to switch to standby in auto mode.

With speaker level inputs connected to the Onkyo A807 amp, both units powered from the same wall outlet, Dynamo sub on Auto, the sub hums for about half an hour after the Onkyo is switched off, then the sub goes quiet. Not so good.

I connected a bonding wire between the two units on 3_7_09. If I smoked some old audio gear I could just look at that as an opportunity, right?

Works fine. Now I have the ML powered from the wall and working normally.

Jun 30, 2009 | Dynamo MartinLogan Subwoofer Speaker

1 Answer

Bought phone EX18560 Series yesterday. floolowed instructions to charge. Today I came home from work, plugged in telephone jack. phone will not turn on. Attempted to re-register (4X's). Led flashes....


I have two older (2002) model cordless Uniden phones that require the handsets to return to their original factory bases. If they have rested on another Uniden base, even of the same model, there is no dialup tone. Replace to the original base and you should be back in service.

Aug 11, 2008 | Uniden Lands Phones

Not finding what you are looking for?
Dynamo MartinLogan Subwoofer Speaker Logo

Related Topics:

799 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dynamo Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5487 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

The Knight
The Knight

Level 3 Expert

75591 Answers

Are you a Dynamo Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...