Question about Apple safari

1 Answer

How do i get the latest version of safari - Apple safari

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Www.apple.com/safari/download
You can get latest version from here

Posted on Sep 29, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The page levels for Bubble Safari have gone to be very small and I can't hit them to get to the level


Update your java runtime environment software to the latest version for here:
http://www.java.com/en/download/manual.jsp

Then update your Adobe flash player software to the latest version.
For Internet Explorer you need this update:
http://majorgeeks.com/Adobe_Flash_Player_for_Internet_Explorer_d5163.html

For Firefox, Netscape, Opera and Chrome use this update:
http://majorgeeks.com/Adobe_Flash_Player_for_Firefox_Mozilla_Netscape_Opera_d7806.html

Sep 06, 2012 | zynga.com

1 Answer

I have emac 10.2.8 with memory 640mb processor 700MHz power pc G4 . I would like to know what safari version is right one for my computer and where can i get that. plz help me.


Hi SardaIn order to upgrade your Safari you need to upgrade your OS to 10.4.11 at least.Try ebay for a copy. Once you have done that Software Update will automatically offer to update Safari to the latest version applicable.
It's not the machine - it's the OS that matters.

Aug 09, 2011 | Apple eMac G4 Desktop

1 Answer

Cant get old safari web page error code 36


As far as i am aware, this is a problem with previous versions of Safari. Try updating, using Software Update from the apple menu, and update to the latest version of Safari, and if possible, your whole system.
This should resolve the issue
Hope this helps

Mar 12, 2011 | Apple MacBook Mac Notebook

3 Answers

My macbook pro has lost the safari browser. How can i recover it ? Can i download it from another pc and install it on the macbook pro and work ?


You can download Latest Version of Safari for MAC from the internet and install/upgrade it. Here is the Safari Download Link
Select the Safari for MAC Version
Good Luck!
Hope this helps! Dont forget to appreciate the solution!!
CreativeTECH

Dec 30, 2010 | Apple safari

1 Answer

I have a MAC and use Safari as my browser. Why can I watch some videos on line but not others. I watch Korean TV dramas on "dramabang.com" which usually has two versions of the video (Toudou and 56). I...


it might be your Flash player. Just update your Flash player to latest one. It depends on your viewing time, also. If a lot of them watch same video at same time, it slows down the server or just freezes it.

Sep 22, 2010 | Apple Televison & Video

1 Answer

My mac wont let me update safari and in turn i cant access itunes store


Have you tried going to:

http://www.apple.com/itunes/download/

to download the latest version of iTunes?

You mentioned Safari, but you'll use iTunes to access the store. If you need the latest version of Safari, go to:

http://www.apple.com/safari/download/

Safari requires at least Mac OS X 10.4.11 (click Apple menu in top, left corner and "About this Mac" to determine your version). iTunes is similar, though it requires 10.5.x and a more powerful computer for some features.

If you don't have at least 10.4, I'd recommend upgrading to it or 10.5, depending on which Mac you have. 10.5 works best on at least PowerPC G5 machines (such as iMac G5) or Intel machines (such as Intel iMac or MacBooks).

Good luck, and please let us know if this worked for you.

* If you find this information helpful, please rate my solutions and recommend me. Thanks! *

Mar 02, 2010 | Apple 13-inch MacBook - Intel 2.0GHz Intel...

1 Answer

The Updates Mac OS X and Safari Updates can't be Installed.


The latest Safari 4.0.3 requires MacOS 10.5.7 or 10.5.8. Which versions are you using? In fact, all Safari 4 versions including betas require at least 10.5.6. Otherwise IIRC the latest was 3.2.3 of Safari. It should have said that it was not compatible but you may want to go to VersionTracker.com or Apple and check the requirements.
Also run Disk Utility and Verify the disk and Fix the permissions before and after every install. If the Verify gives errors, you will need to boot from your CD/DVD (SOL on MacBook Air, hope you have an external boot disk or drive) and Repair the disk before working on permissions. There are some "errors" shown for permissions that can be ignored, they have used links (lrw...) where it expects none. -Ken

Aug 17, 2009 | Apple MacBook Air

1 Answer

Cannot access aol login page with safari for windows


It may depend on the version of Safari you're using. There is a beta for windows floating around out there, that's absolutely terrible. Go get the latest version and see if that doesn't solve your issue!

Apr 07, 2009 | Apple safari

Not finding what you are looking for?
Apple safari Logo

Related Topics:

54 people viewed this question

Ask a Question

Usually answered in minutes!

Top Apple Computers & Internet Experts

paulcarew

Level 3 Expert

2461 Answers

Martin Buck
Martin Buck

Level 2 Expert

82 Answers

Paul Bade

Level 3 Expert

1536 Answers

Are you an Apple Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...