Question about Volfenhag ZX-8300 Car Audio Amplifier

1 Answer

Protection light after being installed my amp worked fine, but after a while it shut off and the protection light came on. so i uninstalled the amp. what must i do to get it to working again. and can i have just this amp installed to work with all the speakers in my car/ thank you very much for your help in this matter.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

If the amp goes into protection with no speakers wires connected to the amp and no signal cables connected to the amp, the amp probably has shorted output transistors.

If that's the case, they would have to be replaced. Most people simply have the amp repaired by a qualified tech. If you want to try to repair it yourself, read the following page:

Amplifier Repair Primer

If the amp failed after only a short time, the speaker ohm load may have been too low. If it wasn't lower than the amp is designed to run, the amp may not be suitable for your needs.

Posted on May 06, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Protect Light On Amp Being Weird


Could try switching right and left subs. If the problem moves to the other side pull the wiring and redo.
Then if the wiring is ok check the sub.

May 15, 2013 | Jensen JPA600D - 600 Watts Digital Mono...

2 Answers

JBL amp, worked fine untill 2 days ago. protection light on..


might have roasted your speakers voice coils a little which may be sending the amp into protect mode throw a speaker on it that you know works and if it doesnt trigger the protect circuit then you probably have a blown or almost sub.

Jan 02, 2010 | JBL BP1200.1 Car Audio Amplifier

1 Answer

Suddenly my pc re-boots when I plug my ipod into the front usb.


uninstall service pack 3 and ignore it when it asks you to re install it. go to add remove programs and uninstall it. obviously it worked befor. that is the solution. you dont need sp3 anyway.

Jul 18, 2009 | Gateway Computers & Internet

1 Answer

Amplifier protect circut is on and wont shut off


ALL AMPS HAVE PROTECTION CURCUITS, U NEED 2 CHECK ALL YOUR WIRES THAT HAVE ANY POWER RUNNING THREW THEM, U PROBLY HAVE A PINCH IN A WIRE CHECK ALL UR CONNECTIONS.

Mar 20, 2009 | Lanzar 2H 1000W MOSFET AMP Car Audio...

1 Answer

Amp is shutting off after 10 min of driving!! please help!!


Does it happen at all volume levels?
What is the gain setting on the sub amp?
Have you checked for 12V @ remote turn on after problem occurs?
Sounds as if the remote turn on relay inside the amplifier is losing signal, or has become damaged. If the protection light does not light up, the problem is not thermal, shorting, or high/low voltage.
The amplifier is in need of repair. This is not an end-user fix. Looking at about $50 to repair.

Thanks for using FixYa- a FixYa rating is appreciated!!

Feb 18, 2009 | Profile BAJA HA700M Car Audio Amplifier

1 Answer

Install MS office home and student 2007


Reboot

Shut down any active protection software such any antivirus, antispyware, antitrojan, or registry monitoring software.

Try to Unistall by using the install disk. It should detect a previous installation and ask if you want to Install, Repair, or Uninstall.

If that fails, download and run CCleaner - Use the Cleaner and Regisrty modules default settings
http://www.ccleaner.com/

Reboot, and shut down active protection software.

Download and run Windows Installer CleanUp Utility.
http://support.microsoft.com/KB/290301
Remove the applicable entries.

Reboot, and shut down active protection software.

Reinstall

Hope this helps - good luck!

Nov 01, 2008 | 10 10 Computer Network adapter Cable...

2 Answers

Protection light


either you are playing too loud or you have a malfunctioning protection light. does your amp seem to get excessively hot, as long as it doesnt, then your problem is prolly just the light itself...

May 11, 2008 | Car Audio & Video

2 Answers

Amp protection light


Hi again, Looks like you posted twice, in any case pls have a look at your other post @ http://www.fixya.com/support/t182326-amp_protection

Aug 15, 2007 | Sony XM-2002GTR Car Audio Amplifier

Not finding what you are looking for?
Volfenhag ZX-8300 Car Audio Amplifier Logo

Related Topics:

167 people viewed this question

Ask a Question

Usually answered in minutes!

Top Volfenhag Car Audio & Video Experts

Robert Rankin

Level 2 Expert

338 Answers

Professor_V
Professor_V

Level 2 Expert

92 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Volfenhag Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...