Question about Kicker 06ZX750.1 Car Audio Amplifier

2 Answers

Kicker zx750.1 protection mode

I have a zx750.1 amp which powers a comp vx 12. when i first got it, something was rattling inside the amp. i had it hooked up anyway, followed the recommended wiring guages, and sure enough something was wrong with it. after it powered up, it almost immediately went into protection mode. i sent it back to kicker, and it was returned saying that there were no problems found with it (no more rattling either). i had it reinstalled.it powered up fine, the sub sounded good (probably listened to it for about ten minutes before leaving shop). on my way to work, it randomly went into protection mode again, but came back on after about a minute.now it will power up and sound fine, but after a couple minutes it will kick back in to protection,sometimes coming back on, sometimes not. any advice that a pro could offer to someone who has a basic understanding of car audio?

Posted by on

Ad

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 156 Answers

Ok a few things to check here. So get a checklist lol.

Is the amp well ventilated?
When it goes into protetion mode is the amp HOT? like too hot to touch?
Do you have the GAIN maxed out? Turn it down
What are the gauges of your ground/power cables?
A bad speaker or speaker wire can cause this also.
Incorrect wiring of speakers like 4ohm speakers wired in parallel connected to bridge.
Inadequate alternator or battery in car
Does your system have a Capacitor? If not get a nice digital CAP they aren't too expensive.

Posted on May 06, 2008

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 3,037 Answers

Well, check again for lose wires and make sure it is grounded good and let me know what you find, Make sure you check ALL of the wires.

I will be more than happy to help you when you get back to me on this.

thanks

Posted on May 06, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Speaker blown?


disconnect the amp and do a "pop" test with a 9v battery, it should be clear and no rattle... if it rattles sub is blown

Jan 29, 2014 | Kicker Comp CVT 12 Car Subwoofer

1 Answer

Qsc hpr153i rattle


Hi,

Please specify a bit more, does the rattle is physical(Enclosure structure) or electronically hear thru speaker(Power Amp Common Issue)? I have the solution for the amp issue, let me know.

Mar 20, 2013 | QSC Audio Products QSC HPR153I 12 SPEAKER

1 Answer

I have 2 10" Kicker Comp Subs


That amplifier is only rated at 150 watts at 4 ohms, or 300 watts at 2 ohms. Not a very strong amp to run 2 kicker comps. My guess is you have the subs wired wrong for your application. There are 2 types of subs, one is a dual 4 ohm, and one is a dual 2 ohm. Most people bridge these coils together and that cuts your ohms in half. For example. Lets say you have the 10cvr104 subs. Thats the dual 4 ohm sub. You wire the coils together in parallel, now its a 2 ohm sub. You have 2 of these subs running off of your amp, if they are hooked up in parallel, now you have a 1 ohm load, out of the amplifiers normal operation. Your amplifiers internals heat up really quick and there is a thermal overload, putting your amplifier into circuit protection mode. My suggestion for wiring your subs is as follows: for each speaker, wire the coils together like this- positive coil1 to negative coil 2 and negative coil 1 to positive coil 2. That is called running in series, and doubles your ohm load. Next, we need to wire the speakers together properly to hook up to your amplifier. For this, since the coils are hooked together, you only need to use one set of terminals from each sub. And take the positive from sub 1 and hook it to positive of amp. Take negative sub 1 and hook it to positive of sub 2. Take negative of sub 2 and hook it to negative of amp.

Aug 30, 2012 | Rockford Fosgate Punch 301M Car Audio...

2 Answers

MTX 12'' sub noise


Sounds like your sub is overextending itself, and possibly losing contact at the voice coil. Overextending will make a weird rattling sound, losing contact at the voice coil will make a popping sound.

Jan 12, 2010 | Car Audio & Video

1 Answer

Hooking up 6x9's to a amp


yes as long as u put in on the high pass filter (HPF)

Dec 07, 2009 | Kicker ZX200.2 2-Channel Amp - 140W ZX...

1 Answer

Amp turns off


what ohm is it running at? if you have all three hook up it parallel then its to low of ohms and it would be louder if you unhook your 10" sub as it moves differently form the 12"s and it cancels out some bass. but if you want it then you have to change the wiring around a bit. take the positive wire off a 12 and put it on the positive side of the 10 and then take the ground for the 10 and hook it up to the positive side of the 12. so you should have one wire from the amp going to the negative side of the 12 and one going to the positive side of the 10 and a jumper wire from the 10 to the 12. and if it still shuts off then you have bigger problems.

Sep 25, 2009 | Ultra Linear UL-2200D Car Audio Amplifier

1 Answer

Dropped/jailbroken iPhone doesn't charge or restore


Try hooking it to itunes then hold the home and power buttons for 6 secs. then release the power button and keep holding the home button until itunes sees the phone then restore.

Aug 04, 2009 | Apple iPhone 3G Black Smartphone

2 Answers

Amp keep blowing the 20amp fuse


There seems to be a short circuit inside your amplifier. It could be one of the amplifier mosfer/transistors or a diode that is connected nearby the power input.

May 06, 2008 | Alpine MRP-T220 Car Audio Amplifier

2 Answers

Goes into protection mode for no reason


if the amp is powering on the sub and playing and then turns in to protect mode it could be the amp is getting hot and its kicking into protect so you wont fry the amp

May 06, 2008 | Kicker 06ZX750.1 Car Audio Amplifier

Not finding what you are looking for?
Kicker 06ZX750.1 Car Audio Amplifier Logo

357 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kicker Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

hoyzee1

Level 2 Expert

150 Answers

yadayada
yadayada

Level 3 Expert

79865 Answers

Are you a Kicker Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...