Question about Performance Teknique ICBM-896 Car Audio Amplifier

Open Question

Hello i have a icbm-896 2 channel amp and the bass sounds good but when the notes hit the power light begins to flicker and and dim once it basically dims all the way down the diagnostics ried light turns on and the amp shuts off and within seconds it turns back on and repeats the process. what is the problem or solution. currently running a 4gauge wiring to the amp.

Posted by on

Ad

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 631 Answers

SOURCE: performance teknique icbm-896 stick on diagnostics

If it's in protect mode, it probably has shorted output transistors. To eliminate other possible problems, read through the following page:

Amp in Protect Mode - Troubleshooting

Let me know if you have any other questions.

Posted on Sep 11, 2008

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Amp power dips when heavy bass drives my speakers, at low volume, the blue light flickers with the beat of the music. i suspect that the amp itself is the fault. tried a different amp.


Suggest connecting with a fuse to a car battery. The current available from a ATX power supply is about 10 amps for the 12 volt circuit(see link).

For a 100 watt per channel amplifier would require a minimum of 17 amps for a RMS (root mean square/average) It is the peak power requirement which is significantly more that can be the problem.

ei http://web2.murraystate.edu/andy.batts/ps/PowerRatings.htm
26262737-5ntl554mom5lyewa1raj0eax-1-0.gif For a typical high output stereo the fuse would be 40 amps or more!



26262737-5ntl554mom5lyewa1raj0eax-1-2.jpg Hope this helps?

Aug 19, 2016 | RCA Car Audio & Video

1 Answer

My amp works fine but the light on my amp and bass knob flickers on n off why????? N thanks


There can be a few different reasons..

1. Your punching some serious bass and pulling the power from the lights.

2. A bad connections somewhere.

3. Low end product

Is it like an actually flicker or does it dim?

Jan 07, 2015 | Memphis Car Audio & Video

1 Answer

My infinity reference 7540a amp cuts in and out with heavy bass when the ''loud'' feature is on. I redid my ground, remote wire, shortened my power cable, and double checked all speaker connections. I dont...


sounds like ur gains are set to high and is going into protect mode

also what ive seen happen before is the speakers (if mounted in metal shelf or door and arnt bolted down correctly can flex under bass notes and flex the speaker that much the termanls short onto the metal and amp hits protect mode
(rare but worth a look if you think u have elimanted most other things Had a dude come to me when i was working in sydney with this problem )

also could be things like clipping protection , overheat protection ,amp drawing to much current from the alternator

do your lights dim when you hit the bass notes ?

get back to me and im sure we could solve this problem

Jan 22, 2010 | Infinity Reference 7541a Car Audio...

2 Answers

My red protection light comes on and the amp stops if i turn up the volume on the head unit more than just a little. the settings on the amp are not more than half way up. all other lights are working....


sounds like you need a farat cap, your drawing more power than your cars gerating system and put out....does your stereo dim when the bass hits?

Oct 20, 2009 | Sony Car Audio & Video

1 Answer

What is the subsonic for on the performance teknique amp


The subsonic filter is used to filter out the bass that is too low for the human ear to detect or hear--remember the lower the frequency or bass note that you try to play the harder the amp has to try to reproduce it-so by filtering out the bass that you cant hear it saves life on your amp and subs and your not missing anything anyways cuz ya couldnt hear it to begin with.

May 14, 2009 | Performance Teknique ICBM-2400 Digital...

1 Answer

Mcintosh mc7150 lights dim on higher volume


Yes you could be right about the power supply capacitors as they have a tendency to dry out. Another tip is to inspect the terminations of these capacitors and clean their contact points as often the screw and screw boss is a different metal and corrosion and electrolysis occurs between these and the main power supply connectors. If in doubt clean with a scotch scourer till shiny metal is exposed on connection points. Then coat contacts with electrical contact conditioner (lanolin grease is good too) before reassembly.

Some amplifiers do not have sufficient storage to sustain high bass levels into difficult speaker loads, the Mac should not be one of these however . To verify that your dedicated AC outlet is not a limiting factor - use a power board and plug an incandescent lamp into the same point as the amp and see if you see any flickering of lamp when the amp lights dim.

If no evidence of limiting of main power and connection maitenance does not solve the issue, replacing the capacitors is indicated.

Mar 09, 2009 | Mcintosh MC602 2-Channel Amplifier

1 Answer

Fender Rumble 100 210 pop noise then hum after strong low e note


I just fixed my bass amp with a similar problem last week: the problem is related to a loose connection on the PCB board (likely).
A bass amp is a rough place for circuitry: the low rumble and power shake a bass amp more than a guitar amp.
In my case, the power transistors needed to be re-soldered and then the grounding bolts and screws needed to be removed and cleaned because the connection was bad. Remember that when two different metals needed for an electric connection are toughing, there is the likelyhood that corrosion WILL happen.
My bass amp did basically the same thing yours did: sounded good at low volumes, but at higher volumes it would act up.
In short, there is nothing you can do (unless you are a repair person): you need to take it to a local music shop and have a tech fix the intermittant contact problem: someone who knows what they are doing should only take an hour at most.

Hope that helps!
-mike

Feb 22, 2009 | Fender Rumble 100 Bass Guitar Amplifier

1 Answer

Performance teknique icbm-896 stick on diagnostics


If it's in protect mode, it probably has shorted output transistors. To eliminate other possible problems, read through the following page:

Amp in Protect Mode - Troubleshooting

Let me know if you have any other questions.

Sep 10, 2008 | Performance Teknique ICBM-896 Car Audio...

2 Answers

Bass sounds flat when volume is increased


probably your power is too short, increase your gauge wire, and your ground wire of the amplifier has to be shortly as possible, and the positive has to be enough to support peak power, you can also put a big capacitor on the positive wire to give some more power while the bass peak.

Apr 26, 2008 | Earthquake Sound PH-D2 Car Audio Amplifier

2 Answers

Bose lifestyle no sound


Hi, best practice when troubleshooting a no-sound Bose Lifesytle system is to first begin with the internal sources (i.e. the AM/FM). Bose Lifestyle system when connected properly (media center and bass box via the data cable) should show a steady green light underneath the bass module. Begin by simply playing AM/FM tuner and try to increase the volume till 45 (normally the sound becomes audible at this level). If the system still has no sound, then try to check if the bass module is steady green. When you see a blinking green LED (slow green) then do kindly check the DIP siwtch (red latch switch with white mini switches) just beside the Light and data connection. All of the switches should be in "ON" position (basically toggled upwards with the arrow marking indication). Before changing DIP switch settings do ensure that the bass module is not connected to the electrical power. after ensuring that all DIP switch are in the "ON" position, connect the data cable firs and then power up the bass module. Then you should see the bass module blink green twice and once you turn on the nedia center, the green blinking should turn steady green. That should sort out your problem.

Also do note tha this procedure applies only to Series II Lifesytle System and does not include the Series IV (with the smaller bass module).

If all still fails, there is an internal problem with the bass module which would require servicing.

Hope this helps!

Jan 27, 2008 | Bose Lifestyle 18 System

Not finding what you are looking for?
Performance Teknique ICBM-896 Car Audio Amplifier Logo

Related Topics:

47 people viewed this question

Ask a Question

Usually answered in minutes!

Top Performance Teknique Car Audio & Video Experts

George Nalley

Level 1 Expert

41 Answers

Radames Pagan
Radames Pagan

Level 3 Expert

196 Answers

Joe Alexander
Joe Alexander

Level 2 Expert

65 Answers

Are you a Performance Teknique Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...