Question about Car Audio & Video

1 Answer

Amp is in protect mode but it was intstalled and worked fine for almost 2yrs now having problem with it the blue light is on with the red flickering and then it goes to solid red

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,550 Answers

Your audio amplifiers ICs are damaged you gotta change him.

Posted on May 06, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Model cx600. Why is red protection light on?


The amplifier probably was being overdriven and went into protection mode to prevent the output stage(s) from getting smoked. The amp will have to be opened up to make repairs and get it working again.

Jan 08, 2016 | Kicker Car Audio & Video

1 Answer

Kenwood kac 628 red light comes on and no audio output


The red light you describe on your amp, is the protection mode warning light. An amp goes into protect for many reasons. Here's a checklist.

1st check the fuse (s) on your amp and make sure they are not blown.

2nd check the inline fuse next to your car battery (if you have an inline fuse)

3rd, disconnect the speaker wires with amp on, does the light go off?

4th check your ground, this may be ok if you have tried another amp with the same wires.

5th.if none of these turns the protect mode off, it may be an internal fault.

you may have blown transistors and it is a tricky job to repair and costly.

Jan 28, 2013 | Kenwood KAC-628 Car Audio Amplifier

1 Answer

Kenwood kac-6295 shuts off then turns back on at high volumes


Did you wire the speakers in series or parallel? 4 ohm speakers in parallel actually come out to equal 2 ohms wich most amps would see as a short causing protection issues. 4 ohm speakers in series equals 8 ohms which should be fine for your amp. been there : expert-tech / SAM

Mar 27, 2012 | Car Audio & Video

1 Answer

I bought a MTX Terminator amp and the light is red when I turn it on, but it works. Red usually means protect mode but it works fine. Should the light be red or green?


all depends on that amp... if there was an issue it wouldnt work, and the light would be by a protect symbol... if its just red next to the power symbol i say no issue.

Feb 18, 2010 | Car Audio & Video

2 Answers

JBL amp, worked fine untill 2 days ago. protection light on..


might have roasted your speakers voice coils a little which may be sending the amp into protect mode throw a speaker on it that you know works and if it doesnt trigger the protect circuit then you probably have a blown or almost sub.

Jan 02, 2010 | JBL BP1200.1 Car Audio Amplifier

2 Answers

How do I fix the problem so they work again.?


A 1000 WATT AMP HAS PROBABLY GONE INTO PROTECTION MODE BECAUSE YOU ARE TRYING TO RUN 1600 WATT SUBS COMBINED

Jun 08, 2009 | Car Audio & Video

1 Answer

Re: Denon AVR-1100 receiver Just powered it on after years of not being used, although I know it works just fine. Powers on fine, but the readout on the screen says "AUTO" (small) and "PROTECT" (large) and...


The receiver has gone into a protect mode because something is wrong and it shuts down to prevent further damage. Could be a power supply or output amp issue.

Jun 20, 2017 | Audio Players & Recorders

2 Answers

Protect led light


It appears that the amp is going into protect mode. To eliminate external causes, read through the following page. Let me know if you have any other questions.

Amp in Protect Mode - Troubleshooting

Oct 10, 2008 | Car Audio & Video

1 Answer

Amp Not working!


If the amp goes into protect mode, it's likely due to shorted output transistors. To eliminate other possible problems, read through the following page:

Amp in Protect Mode - Troubleshooting

If the problems are not with the wiring, follow the link at the bottom of the page to the Amplifier Repair Primer page.

Let me know if you have any other questions.

Sep 20, 2008 | Power Acoustik TS620-2 Synchronized...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

163 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4944 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

79865 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...