Question about Nitro BMW-482 Car Audio Amplifier

2 Answers

I have a nitro 1200 watt amp that was working great until it a red light that read " protection mode" turned on

Posted by on

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Nitro Master
  • 636 Answers

Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty
Definitely is worth .A thumbs up would be greatly appreciated if this answer is helpful to you. I have a nitro 1200 watt amp that was working - nitro-1200-watt-amp-working-lv2kkrmxrai4iihdvw4m3np2-1-0.jpg

Posted on Dec 18, 2014

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 57 Answers

This can only ean three things one the amp is fubar two bad wiring three overheating

Posted on Aug 25, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Green light comes on for a sec the red light comes on,1200 watt sony xplod amp 10'' Orion sub,I think the subs right around 3000 watts. What's wrong?:(


Your Sony Xplod amplifier turns on briefly (green light) then possibly senses a mismatch between the nominal output impedance of the amplifier and impedance of your Orion sub and goes into protect mode (red light) to prevent internal damage.

Jul 19, 2014 | Car Audio & Video

1 Answer

'"hi i have a power


The refurb may not have been complete

Mar 24, 2017 | Power Acoustik Car Audio & Video

2 Answers

The red light comes on for a while and then it turns off but no green light come on


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty D .A thumbs up would be greatly appreciated if this answer is helpful to you. red-light-comes-while-lv2kkrmxrai4iihdvw4m3np2-2-0_0.jpg http://www.nitrobmw.com/

May 18, 2010 | Nitro BMW-482 Car Audio Amplifier

2 Answers

Ok so my Nitro BMW - 481 2000w amp was working and then i came back the next day and the red protect light was on its been working for weeks but now it has the red light.


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. D .A thumbs up would be greatly appreciated if this answer is helpful to you. ok-nitro-bmw-481-2000w-amp-working-lv2kkrmxrai4iihdvw4m3np2-2-0.jpg http://www.nitrobmw.com/

Mar 17, 2010 | Nitro BMW-481 Car Audio Amplifier

3 Answers

My nitro bmw-486 amp is in protect mode how can I


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty De .A thumbs up would be greatly appreciated if this answer is helpful to you. nitro-bmw-486-amp-in-protect-mode-lv2kkrmxrai4iihdvw4m3np2-1-0.jpg

Feb 24, 2010 | Nitro BMW-486 Car Audio Amplifier

2 Answers

I have a nitro 1200 watt amp earlier today it was workin with no problems we parked then came back in the car 3 hours later and it wasnt workin wont come on or anything just red light which is protecting...


Check your speaker wires, make sure everythings connected right with no short circuits, and check all of the fuses in the amp, and make sure none of them are blown. If all this checks out just check the battery wire, grnd, and remote wires. It has to be a wiring issue unless you busted your amp, but if was working when you tuned it off it should be alright... hop this helps...

Sep 10, 2009 | Nitro BMW-484 Car Amp

3 Answers

What makes a nitro 1200 watt amp go to protect mode


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. D .A thumbs up would be greatly appreciated if this answer is helpful to you. makes-nitro-1200-watt-amp-go-protect-lv2kkrmxrai4iihdvw4m3np2-2-0.jpg http://www.nitrobmw.com/

Aug 02, 2009 | Nitro BMW-482 Car Audio Amplifier

1 Answer

Nitro BMW 484 1200 watt amp.


check fuses and remote wire at the head unit. must have a good ground at amp.

Dec 03, 2008 | Nitro BMW-482 Car Audio Amplifier

1 Answer

Red protection light


If the amp is going into protect mode, it probably has shorted output transistors. To eliminate other possible problems, do the following.

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

If the voltage remains near or above 12v, disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If it still shuts down, the amp almost certainly has shorted output transistors and will need to be repaired.

Sep 12, 2008 | Nitro BMW-482 Car Audio Amplifier

1 Answer

Amp in Protection Mode


With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage drops below ~11 volts, you need to check the wiring feeding whichever line is too low.


If the voltage remains near or above 12v, disconnect all speaker wires and signal cables from the amp. If it powers up, the wiring needs to be checked. If it still shuts down, the amp likely has blown output transistors.

Dec 19, 2007 | Nitro BMW-482 Car Audio Amplifier

Not finding what you are looking for?
Nitro BMW-482 Car Audio Amplifier Logo

Related Topics:

105 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nitro Car Audio & Video Experts

ravie__s

Level 1 Expert

10 Answers

yadayada
yadayada

Level 3 Expert

75051 Answers

Michael Kovalik III
Michael Kovalik III

Level 2 Expert

117 Answers

Are you a Nitro Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...