Question about Olympus EVOLT E-300 Digital Camera

Open Question

Hello guys, I have an Olympus E-300. From one day to the other it stop taking pictures. I sounds like it takes a picture, the flash works, but nothing comes out. no image. can anyone help me?

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

sumthin
  • 71 Answers

SOURCE: Olympus FE-240

Hi cris9ken.
The little blue bar is your memory gauge.
The Little green bar blinks after each shot just to inform you the shot was loaded into memory.
As the memory fills the green bar will increase in height to give you a approximate idea of remaining usable memory.

You will notice that it function with or without the Xd card.
meaning it displays the favorites memory as well.
Best regards and say CHEESE, Paul

Posted on Jun 12, 2008

  • 919 Answers

SOURCE: Olympus E510, Flash Flicker

If you are in a low lit area with the camera dial set to Auto the flash will do a strobing type of flash trying to help allow more light into the scene. This is called the AF illuminator function. To just go ahead and take the image, put the camera dial to P (program Auto) go to Menu - go to Wrench 1 tab - then right arrow over and then down arrow to AF Illum - right arrow and turn this function from On to Off and then take the image in the P mode setting. No flash flicker should occur.

Posted on Dec 15, 2008

  • 1 Answer

SOURCE: I am getting a lot pre-flashes before take the photo

In your manual look up page 49 AF illuminator change the setting to off and then you rprblem will go away I have had this camera for ages and couldn't figure heaps out this was so easy to fix yet so hard to find the answer. I am also finding that the photo that I see throught the lense is good and nice colour until I put the shuter button down and the photo changes colour then are you having the same problem?

Posted on Jan 02, 2009

  • 919 Answers

SOURCE: olympus IR-300

The problem you are describing could be a problem with one of the chips in the camera that controls image processing. It seems to have failed and needs to be replaced. Following are the instructions to send your camera to Olympus for service.

http://olympusamerica.com/cpg_section/cpg_servicerepair.asp

Olympus will charge a flat rate repair fee for this product if beyond the one year factory warranty or the warranty is voided. The cost is $154 plus your local sales tax. This covers parts and labor, factory cleaning and diagnostic check, 6 month warranty and the cost of shipping the product back to you is all included in that price.

Posted on Apr 02, 2009

  • 919 Answers

SOURCE: flash Does not work. Can only take pictures in flash-off mode

The problem you are describing is a problem with the flash charging indicator switch inside the camera. It seems to have failed and needs to be replaced. Following are the instructions to send your camera to Olympus for service.

http://olympusamerica.com/cpg_section/cpg_servicerepair.asp

Olympus will charge a flat rate repair fee for this product if beyond the one year factory warranty or the warranty is voided. The cost is $83 plus your local sales tax. This covers parts and labor, factory cleaning and diagnostic check, 6 month warranty and the cost of shipping the product back to you is all included in that price.

Posted on Jun 03, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Memory card errors


You may need to replace the flash card, or clear the contacts then insert again to camera.

Feb 10, 2012 | Cameras

1 Answer

Can't take a picture without abundant light


Does it work okay in bright sunlight without a flash? If so, try changing the options to factory default.

Mar 23, 2010 | Olympus E-520 Digital Camera with 14-42mm...

1 Answer

Flashing Lights!!


The problem may be from the memory card, the memory card of the camera may have been damage, try to get a new memory card then see whether the problem will still occur. Since the memory card is damage, you won't be able to take any picture.

Sep 24, 2009 | Cameras

2 Answers

Olympus E-300 Digital SLR storing black images.


Most likely the shutter "curtain" (a few pieces looking like sheet metal just behind the mirror, designed to protect the camera CCD from dust and damage due to too much light) is not opening. This will require servicing by Olympus, since you will have to take the camera apart to be able to reach this camera part. Unfortunately, this may be a pretty expensive repair.

Apr 18, 2009 | Olympus EVOLT E-300 (Double Lens Kit)...

1 Answer

Olympus E300


Hello Kate, See if you can find an internet cafe. I was reading the white balance section of your manual and there is nothing that stops your camera from taking pictures if the white balance is off. Turn your camera off, remove your batteries for about 30 seconds and let it reset to default. Then try inserting the batteries and see if this helps. I wouldn't mind sending you this manual if you can provide an email address. Or a link to go to is: www.olympus.com, then select americas, then select support, then select your camera, then download your manual in PDF format. I wouldn't want your vacation ruined either.

Aug 11, 2008 | Olympus EVOLT E-300 Digital Camera

1 Answer

My camera


check the battery to make sure it is making good connection

Jul 23, 2008 | Olympus FE-230 Digital Camera

1 Answer

Problems storing pictures to Memory Card


Shawna, Since your camera is still under warranty, best thing will be sending it to the appropriate factory service center for repair the problem.

Aug 08, 2007 | Olympus EVOLT E-300 Digital Camera

1 Answer

My camera taking crapy pictures


Where are you seeing images like this? More setail here please.

May 27, 2007 | Olympus EVOLT E-300 Digital Camera

8 Answers

Flash Not Working/Picture Not Taking Unless Flash Turned Off


well u canĀ“t do much, it needs to have the board to be replaced. normally the repair centre just repair it, and if it is under warranty they will do it for free, probably the store was the one saying that u drop it to get some money.

Feb 22, 2007 | Olympus Stylus 410 / ? 410 Digital Camera

Not finding what you are looking for?
Olympus EVOLT E-300 Digital Camera Logo

Related Topics:

24 people viewed this question

Ask a Question

Usually answered in minutes!

Top Olympus Cameras Experts

kakima

Level 3 Expert

102366 Answers

Willem.
Willem.

Level 2 Expert

359 Answers

Steven Wander
Steven Wander

Level 3 Expert

579 Answers

Are you an Olympus Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...