Question about Audio & Video Receivers

1 Answer

Purchased vintage KENWOOD AMPLIFIER KA-6000. the amplifier has a tapping noise coming out from speakers. I replced all filter capacitors and the problem did not go away. Can you help me? Tom

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 4,234 Answers

I believe that that model uses coupling caps between the fron end and the final stage. Check those as well.
Dan

Posted on May 05, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Does anyone have a copy of the Kenwood KA-127 amplifier user manual?


go google and type in user manual for kenwood amplifies model ka-127 and there are pages there that will help you with what you want

Jun 15, 2016 | Kenwood Audio & Video Receivers

1 Answer

Dead Kenwood Home stereo Amp. KA-2002


Some says it is only dead when it is buried.

Open it up and check, ( Be sure it is unplugged)

Only if you feel you can DIY or have a tech do it for you.

Oct 06, 2012 | Kenwood Vintage Model Ka-6006 Stereo...

1 Answer

System on standby due to short circuit, how do i repair


It is possible that the amplifier had encountered a fault with a higher current drain which had triggered it to a protection fault condition. The fault can be with your output drivers. Please check for short on the outputs fitted for both the channels. Use a meter after disconnecting to check for short in the drivers. Disconnect the positive and negative voltages to the output and see if the protect changes. Even a fault in the preamp stages that drives in high current into the output can shut the Amplifier. Sometimes this can be a noise which can be a HUM or HISS before the protect works. Faulty capacitors in these circuits also can cause similar issues and needs close observation.You need to confirm and replace the specific stages or outputs. If not there can be issues in the mother board. Maybe the protect circuit by itself is shutting off due to a faulty bias or there is a leak in any voltage/current sensing circuit. Also disconnect the speakers and test, if the amplifier comes out of the protect mode then check for short on the speakers.

Dec 12, 2011 | Kenwood Audio & Video Receivers

1 Answer

When i turn on my kenwood kr-v990d it powers up for about 2min then shuts down


It is possible that the amplifier had encountered a fault with a higher current drain which had triggered it to a protection fault condition. The fault can be with your output drivers. Please check for short on the outputs fitted for both the channels. Use a meter after disconnecting to check for short in the drivers. Disconnect the positive and negative voltages to the output and see if the protect changes. Even a fault in the preamp stages that drives in high current into the output can shut the Amplifier. Sometimes this can be a noise which can be a HUM or HISS before the protect works. Faulty capacitors in these circuits also can cause similar issues and needs close observation.You need to confirm and replace the specific stages or outputs. If not there can be issues in the mother board. Maybe the protect circuit by itself is shutting off due to a faulty bias or there is a leak in any voltage/current sensing circuit. Also disconnect the speakers and test, if the amplifier comes out of the protect mode then check for short on the speakers.

Oct 23, 2011 | Kenwood KR-V990D Receiver

1 Answer

Describe your kenwood manual "ka


Hi, Yes it is safe to leave this connection unhooked. The system control is what the stereo uses to remote control a cassette deck,cd,turntable etc... using the amplifier separately should be o.k. I hope this helps, good luck and thanks for choosing FixYa-Prodzilla

Apr 20, 2011 | Audio & Video Receivers

1 Answer

The model number is Kenwood KA-894 integrated Amplifier I'm trying to find out how many watts. Thanks


The manual with 'specs' is here. Take them with a grain of salt because it's impossible to produce more audio watts than are consumed electrically (250 total).

http://www.retrevo.com/s/Kenwood-KA-894-Amps-review-manual/id/479ag211/t/1-2/

Dec 25, 2010 | Audio & Video Receivers

1 Answer

I have a kenwood stereo integrated amplifier KA 791 and the dual cassete KXw892, niether will come on. when plugged in the standby light only comes on. the reciever and cd player components come on fine?...


That system came with the kt591 tunner in a bundle which consisted of what you call the Kenwood Spectrum 700 rack system, you had to plug the tuner into the wall and then plug the amp into the tunner if you didnt , when you turn the amp on you just get a relay clicking noise and nothing turned on.

Sep 14, 2008 | Audio & Video Receivers

1 Answer

Buzzing sound thru speaker even with volume down to zero


maybe some filter capacitors of the amplifier has been drying out! check for the main filter capacitors and output capacitors of your amplifier. replace them if necessary with a higher capacitance but the same voltage rating!

Nov 16, 2007 | Onkyo TX-DS696 Receiver

Not finding what you are looking for?
Audio & Video Receivers Logo

Related Topics:

347 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio & Video Receivers Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

68323 Answers

yadayada
yadayada

Level 3 Expert

61037 Answers

Are you an Audio and Video Receiver Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...