Question about MTX 3002 Car Audio Amplifier

Open Question

Okay i have a mtx 300.2 car amplifier. ive had it for a while and all of a sudden it stops working.... i take a look at it and see that the red power light is really dim and not as bright as it usually is. when fully on. i then took my amp home and hooked it up a computer PSU and it works just fine, the red light is bright and fully powered... why wont it work in my car?

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 631 Answers

SOURCE: mtx 1501d no sound

There are a number of things that can cause it to act as you described. Have you pulled the covers off of it yet to see if you can see any problems?

If you do, disconnect power from it and don't touch ANYTHING on the board when ANY of the 3 LEDs (2 are not visible from the outside) are lit.

Posted on Aug 19, 2008

SOURCE: Apx stopped working, MTX 702x

maybe the audio amplifiers Ic´s damaged or the power fet

Posted on Mar 06, 2009

jrw4u
  • 62 Answers

SOURCE: Everything works fine but my amp light is red.

if its not coming on it usually means you have a bad ground if it works for a little while then does it then its over heating and you will need to get a fan

Posted on May 01, 2009

etirbynnor
  • 655 Answers

SOURCE: i have a mtx thunder 1501d..i have the power cord

Hello tonytone54, The ground should go directly to the vehicle frame, never through a cap, fuse, or anything else. Also, if you are connecting positive through a cap, make sure that you charge the cap before connecting it. Hope this helps.

Posted on Jun 03, 2009

  • 36 Answers

SOURCE: mtx 1000xd led light is flashing and the subs will not work

The light flashing usually means there is a short somewhere. Check your wires to make sure there are no slices and are touching. Also check to make sure you have your remote wire hooked up.

Posted on Sep 21, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Cant get power to my mtx rt251d amp


Test the power to both the remote and power wires, and make sure you have a secure ground. If those are good make sure the fuse is okay. If you still get nothing, the amp may be faulty and you should take it to your local audio professionals.

Aug 11, 2012 | MTX RT251D Car Audio Amplifier

1 Answer

Car amp not working


is amp getting power or not could be wires came loose inside speaker box

Mar 29, 2012 | MTX JackHammer JH600 Car Audio Amplifier

1 Answer

Stopped working suddenly. No PF lights, no smell. Power light turns on sometimes. Fan turns on. Wired properly. No power to sub/subs.


check the fuse holder an the power holder on the inside of the amp an just to see check ur ground some time they lossen

Jun 21, 2011 | MTX JackHammer JH600 Car Audio Amplifier

1 Answer

Okay i have a mtx 300.2 car amplifier. ive had it for a while and all of a sudden it stops working.... i take a look at it and see that the red power light is really dim and not as bright as it usually is....


Sounds like your power wire or your ground wire are either not geting a good conection or they are to small to cary the amperige it takes alot of amperige to do the work.

Aug 23, 2010 | Car Audio & Video

1 Answer

Mtx terminator 250 stop workind and red light is on


check the ground make sure its not loose from the frame of your car thats why the red light comes on.

Jun 03, 2010 | MTX Terminator TN400/4 Car Audio Amplifier

1 Answer

Amp and sub have been working great together then all of a sudden the amp is not putting out enough power to push the sub. MTX Thunder 311D


check to see if one of the RCA cables is unplugged or bad. check the gain check the sub level control on the deck if yours has one.

May 19, 2010 | MTX Thunder 311D Car Audio Amplifier

1 Answer

It just stopped working after about 4 years. the amp went in and out a couple of times then it just stopped working.


ok what type of amp are we talking about, what impedence and voice coils are your subs, and have you checked power, ground, fuses, etc... a quality amplifier kicker, jl, mtx, rockford... etc... should, if set up and wired properly, last you a very long time... I actually had a kicker amp since 96 and it still worked great to the day i gave it to my buddy... That's 11 years old with no issues...

Dec 12, 2009 | Jl Audio 300/4 Car Audio Amplifier

1 Answer

MTX Thunder problem


Make sure that your connection at the battery is still good-sometimes the wire corrodes up front when your system is installed for a long time-so check that out and of course the fuse that you installed a foot away from the battery so that you dont burn your vehicle down if a short occurs somewhere down the line

Jun 03, 2009 | MTX Thunder 421D Car Audio Amplifier

1 Answer

Apx stopped working, MTX 702x


maybe the audio amplifiers Ic´s damaged or the power fet

Mar 06, 2009 | MTX X Thunder 702X Car Audio Amplifier

Not finding what you are looking for?
MTX 3002 Car Audio Amplifier Logo

Related Topics:

47 people viewed this question

Ask a Question

Usually answered in minutes!

Top MTX Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

yadayada
yadayada

Level 3 Expert

75797 Answers

Are you a MTX Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...