Question about Audio Players & Recorders

1 Answer

My Jamo i300 has stopped working - smell of a burnt out part. Can anyone tell me how to open the subwoofer box. So far I have been unsuccessful. Thanks very much, Geoff

Posted by on

  • 1 more comment 
  • gpdobson_dob Aug 22, 2010

    Hi technical114



    I've removed the 10 screws, but the plate does not seem to come loose. Any thoughts?



    Thanks,



    Geoff

  • gpdobson_dob Aug 22, 2010

    Thanks very much - a bit more force did the trick,



    Geoff

  • gpdobson_dob Aug 22, 2010

    Thanks very much - a bit more force did the trick

    Geoff

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,851 Answers

Have you tried to unscrew the 10 screws at the back panel of the sub? Theoritally doing this you will have in hand all the electronics except the speaker.
My Jamo i300 has stopped - 89b5b69.jpg
In case of a problem or clarification, don't hesitate to post me a reply.
If you are satisfied, accept my solution. Please consider leaving a 4-thumbs rating; I'd appreciate it greatly.

Thanks and regards
Stelios
direct FixYa link: http://www.fixya.com/users/technical114

Posted on Aug 22, 2010

  • Stelios
    Stelios Aug 22, 2010

    It has to be taken apart this way. In case your device is old use a little force; it may have been stacked. I'm not sure if Jamo uses any kind of sealant at the end of the back panel. Unscrew all the screws and use a wide screwdriver to disapart the plate from the body. Just take care to disapart slowly in order not to cut the internal cables for the speaker.

    In case of a problem or clarification, don't hesitate to post me a reply.
    If you are satisfied, accept my solution. Please consider leaving a 4-thumbs rating; I'd appreciate it greatly.

    Thanks and regards
    Stelios
    direct FixYa link:http://www.fixya.com/users/technical114

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Jamo sub 250, the R30 was blown. May I know the value of this resistor ? Anyone can help ?


If its still is defective in a corner or in the attic? Maybe you can make info by a KLIPSCH service centre because Klipsch is the owner of JAMO http://www.jamo.com/about/ if you have not find the answer.
Jamo About

Sep 04, 2015 | Jamo Audio Players & Recorders

1 Answer

Why won't my a102 speakers from jamo witch came


The Jamo speakers need an AV Receiver to drive them properly. The TV doesn't have the correct outputs nor does it have the power required.

The Jamo kit consists of a powered subwoofer ans 5 small surround speakers. Each surround speaker needs to be powered by the speaker output from an an AV Receiver. The subwoofer should also be connected to the receiver, but the connection is a phono/RCA lead from the receiver's "Sub Out" socket.

Your TV connects to the AV receiver via the Optical out.

Sep 01, 2014 | Audio Players & Recorders

1 Answer

I think we had a power surge and my jamo i300 speakers have stopped working, how to open the subwoofer, i've tried undoing the 10 screws around the edge........


Perhaps some triage first before you open it up.

Are you sure it's just the speakers that are 'damaged'. The control dock is a vital link in this. Try other sources attached to IT. Or a source plugged into the Line Input directly on the back of the sub. Identify the correct patient before doing the surgery.

May 27, 2011 | Audio Players & Recorders

1 Answer

What batteries to put in the jamo i300 remote control


Remote Control Battery Replacement

To replace the battery, remove the two screws on back of the
remote and disassemble. It is a "Button" type battery not sure what the number is but look at the battery and find the number on it and replace it with the same style battery

To download a free owners manual go to this website
http://www.jamo.com/na-en/support/owners-manuals/

Jan 14, 2011 | Jamo I300 Docking Station

1 Answer

Please help! Jamo SUB 300 subwoofer still blows (0.8A) fuses after replacing a faulty thermistor, despite a high ohms reading directly across AC mains terminals on the board. What is causing the fuse to...


hi,
i have a jamo 250 sub.the blue light is working.when i connect the jack to the left line IN according to the manual it makes a sound as well.but seems not working.is it related to the fuse????i know the fuse box.but i dont know how to remove the fuse to check.pls help me out.my receiver is onkyo tx-sr 608

thank you

ron

Jan 08, 2011 | Jamo SUB300BA SUB 300 Powered Subwoofer...

1 Answer

Jamo i300 dies after powercut


If its out of warranty you might as well open it up , and if your lucky it might only be a fuse to replace , if it is fused inside it will probably have blown before it could do any damage to circiuts . hope this helps

May 25, 2009 | Jamo A 102 HCS 5 System

1 Answer

Jamo i300 docking cradle broken


I've experienced exactly the same problem but by my 1 year old. I have tracked down the Jamo repair centre in the UK - Tele Fringe. Contact them at sales@telefringe.co.uk - They have just advised me that a new i-cradle for the i300 is £72.

Apr 02, 2009 | Electronics - Others

1 Answer

Sound faliure


If the subwoofer has its own power cord seperate from the rest of the audio system, the internal amplifier could be fried or u have a loose connection inside the box

Mar 29, 2009 | Jamo SUB300BA SUB 300 Powered Subwoofer...

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

1,499 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5017 Answers

The Knight
The Knight

Level 3 Expert

73635 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...