Question about Jl Audio Slash v2 500/1v2 Car Audio Amplifier

1 Answer

Have a JL audio slash 500 that isnt putting out any audio... i know the sub is fine. but i noticed the RCA inputs are loose and dont hold the cables very tight.. is this my problem and what can i do to insure my amp is working properly?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 58 Answers

Yes it possible that the inputs have been damaged on the circuit board of the amp. If the amp has hi level inputs you could try running a speaker wire input to it and see if it works. You might try another pair of rca cables to.

Posted on Aug 20, 2010

  • plumpninja Aug 20, 2010

    your saying bypass the inputs and meet them with the?...

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

So my jl 500/1 v2 has power and no audio... i get 3 ohm when i use the voltmeter on the amp the sub but no voltage? is this a fuse problem or am i an *** who has no idea how to troubleshoot


Okay lets go step by step. First check and sure you have battery voltage and twelve volt turn on on the remote term. of your amp. Be sure u have a ground also. Next take your speaker leads disconnect them and pop them with a battery, and make sure it pops. I(f that all passes you need to make sure your amp is getting an input signal because you could have a bad rca cable.

Aug 20, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

JL Amp isn't powering subs and speakers


just go through ur connections man one by one ull find the prob soon.....check teminals on battery...power line to amp ....all fuses within prob area and obviously make sure u have a good ground.....really impotant.....ground is the most neglected thing people do from my experience bein a audio tech oh and if that isnt it check ur subs....stick a 9v batt on the back pos n neg of each sub n c if they pop in r out this will determine if ur subz r blown

May 14, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Installin car systems


you dont want to connect both of those amplifiers together. You could run them separately to separate subs or the jl to your sub and your alpine to your front speakers. But you dont ever want to mix and match amps to the same sub. Even if you had 2 jl500/1's you wouldnt want to just hook them up together. Because they both have to be putting out the exact same amount of power. Which no 2 amps are ever exactly the same. Some companies make bridges to properly connect 2 exact amps together. I Hooked up 2 JL 1000/1's to each voice coil on a 13.5 W7 and i smoked the sub. So i definitely dont reccommend doing it unless the amps are conneccted to separate things.

Apr 28, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

My Jl Audio 500/1, power light comes on but no power to subs


maybe it dont have enough to push it ,,did you try it before you buy it?

Mar 01, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Got jl300/2 amp confused which subwoofer sounds good


Hello drsubhakar26,

JL W6's will perform well with from 150-600 watts RMS. W7's with from 150-500 watts. Less expensive Alpine Type R's work OK with from 200-500 watts RMS. Either of the brands will sound good. None of them will perform to their full potential with 300 watts RMS. Powering any sub with a 2-channel amp is a compromise. A monoblock is more efficient.

Hope this helps.

Jul 12, 2009 | Jl Audio Slash 300/2 Car Audio Amplifier

2 Answers

Jl audio amp 1000/1 fix


IVE HAD 2 JL 1000/1S DO THIS TO ME EACH TIME ITS TURNED OUT TO BE A SHORT IN THE RCA IMPUT BUT ALSO CHECK YOUR RCA CABLES AND THE SUB INPUT ON YOUR HEADUNIT

Dec 22, 2008 | Jl Audio 1000/1 Car Audio Amplifier

2 Answers

Amp not putting out on speaker end


The audio amplifier IC´s maybe are fried

Nov 28, 2008 | Jl Audio Slash v2 500/1v2 Car Audio...

1 Answer

Rca Connection


You need to check the shield ground on the head unit. The following link will guide you through the test procedure.

Shield Ground Testing

Jun 07, 2008 | Jl Audio 500/1 Car Audio Amplifier

2 Answers

Input sensitivity


Make sure your multimeter is set for AC voltage. 

Feb 20, 2008 | Jl Audio 1000/1 Car Audio Amplifier

Not finding what you are looking for?
Jl Audio Slash v2 500/1v2 Car Audio Amplifier Logo

Related Topics:

125 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Audio & Video Experts

Mark Skinner

Level 2 Expert

77 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Are you a Jl Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...