Question about Kenmore 25512/ 25513 Progressive Canister Vacuum

1 Answer

My vacuum motor started to smell "hot" and sound like it was struggling. Also not a lot of suction. Could there be an obstruction? The bag is new and the performance light isn't coming on.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Kenmore Master
  • 43,501 Answers

Hi,
Here is a tip that I wrote about my Bissel but I bet you have the same problem and the hose is clogged...

Bissell Bagless Upright Vacuum not working
http://www.fixya.com/support/r4387950-bissell_bagless_upright_vacuum_not

heatman101

Posted on Aug 20, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

I started vacuuming and the vacuum motor slowed down, then stopped. I smelled a burning smell. Then I discovered the next day that the bag bottom was wet and falling apart. Sebo X4 model


sucked up liquid goes with the air through the motor
that would cause the motor to burn out
with the current low cost of new vacuums , the repair /replacement of the motor would be close to a new unit
take it to an appliance repair shop and get a proper diagnosis and quote

Dec 02, 2016 | Vacuums

1 Answer

The beater bar in my vacuum does not go around and there is no suction in the power head?


Turn up side down- check if belt is intact- I would remove belt ant look for an obstruction. Not familiar with this vac but some motors have replaceable bruches on the motor. Try running and feeling for suction. The motor should sound strong when running. Remove beater brush and check for freedom of movement.

Jul 28, 2014 | Sebo Felix Classic Bagged Upright Vacuum

1 Answer

Decreased suction for filterqueen vacuum


Put a broomstick or such down the hose, something may be stuck. Look inside with the bag out, is there a screen before the motor?

Dec 01, 2013 | Filter Queen Majestic Canister Vacuum

1 Answer

No suction in hose


There is most likely something stuck in the hose.

Jun 06, 2013 | Riccar Model RC1100 Canister Vacuum...

1 Answer

Suction is not as strong


you may have a clog in the lines.

check some Maintenance Cloths and run them through your lines and you should see some improvement.

If you still are having problems, contact your local vacuum shop and see if they do maintenance calls for central vacuums.

Apr 15, 2010 | M&S Systems FX-3000 Bagged Central System...

2 Answers

The motor is running, the roller brush spinning rubber smell


Sounds like the main suction pipe is blocked.
Unplug, and in good light - see if you can see any obstructions in the pipe from the prush area to the bag (in a bagless vacuum) or to the fan in a bag model.

Aug 04, 2009 | Vacuums

2 Answers

Motor slows down and makes burning smell


If the noise is coming from the canister motor, you probably have bad motor bushings. I had the same problem, replaced the motor and all was fine - only for one year. The problem is back and is due to the fact the motor is very high speed (to get good suction) and should be made with bearings, not bushings. I will not be repairing a second time as a $70 motor annually is a bit pricey, and yes it will get VERY hot. I will buy a new vacuum - not another Kenmore.

May 25, 2009 | Kenmore 23612 Progressive PowerMate Bagged...

1 Answer

Vacuum doesn't ****


Assuming the unit (motor) runs ok and since it used, you may need to disassemble it and check the suction right at the motor. Sometimes there is a filter screen in front of it that can plug. The motor impeller could be partially obstructed or dirty, reducing the vacuum force. The bag should be the correct one for the unit or suction can be lost if it doesn't fit correctly.

Mar 28, 2009 | Kenmore 23612 Progressive PowerMate Bagged...

1 Answer

Hoover U5468-900 WindTunnel Supreme suction is suddenly poor


The other possibility is there is a blockage in the foot. these models have dual channel air flow (windtunnel) and become blocked when not cleaned depending on use. under the roller there is a cavity that can be removed for cleaning. a hot motor can be caused by poor air flow.

Mar 15, 2009 | Hoover U5453-900 WindTunnel Supreme Bagged...

1 Answer

When the vaccum is running the motor gets hot & smells & is very noisy.


Sounds like yu may have a clog, either in the inlet by the brush roll, or the hose. If the hose comes loose, see if there is suction there. If no suction then it is clogged. If suction, then the inlet maybe clogged.

Jul 22, 2008 | Dirt Devil Reaction Twin Cyclone Upright...

Not finding what you are looking for?
Kenmore 25512/ 25513 Progressive Canister Vacuum Logo

127 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18392 Answers

kakima

Level 3 Expert

102366 Answers

yadayada
yadayada

Level 3 Expert

75822 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...