Question about Kenwood KAC-9152D Car Audio Amplifier

1 Answer

What could be wrong???????

My subwoofers and amplifier were working fine, i switched my old subs for more powerful subs (hooked-up right for sure) drove down the street and they cut out. i figured since i dont have a capacitor that was the problem, but they wont come on...the amp is ON, not in protect mode, but wont play music. i tested another amp and sub and same ****..green light no sound. and i didnt turn my sub off on my cd player..... no clue......PLEAZZZZ HELP....and if you can fix this **** over the internet, you'd better be getting paid!!!

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Kenwood Master
  • 1,635 Answers

The only thing left is the wiring, and or connectors from what you are describing.

You can try another amp and another set of speakers on the same wiring to see if they work. If not, the only thing you have left is the wiring and connectors (if connectors are used).

This suggestion is valid providing that substitution equipment is not defective.

Jerry G.

Posted on May 01, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a pioneer GM-X524 amp connected to a TS-W253C subwoofer and it isn't working. It has 12v power to it and a solid ground, but the power light wont come on and the sub isnt working


there should be 3 power related cables connected to the amplifier:

1-From battery to amp via fuse (positive)
2-From chassis of car to amplifier (negative)
3-From head units (power continuous) (blue or blue/white cable) to the amplifiers remote connection.
this connection enables the amplifier to switch on when the head unit is switched on and off when the headunit is switched off.
I hope this helps and let me know if I can further assist you.
....andy....

Jan 06, 2014 | Pioneer Car Amplifiers

1 Answer

Subs wont turn on


make sure there is correct wattage with the subwoofers and the power supply

Dec 07, 2013 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

8" compact subwoofer not working it was installed


post more information about your amp. its likely the vibrations moved something in the amps, or buttons.

Oct 10, 2013 | Alpine Swe-1000 8" Compact Subwoofer...

1 Answer

My Jl Audio 500/1, power light comes on but no power to subs


maybe it dont have enough to push it ,,did you try it before you buy it?

Mar 01, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Hooking sub up


Hello missywarden,

According to the specifications, the amp is capable of "tri-mode" operation, that is, running normal speakers on the individual channels while also powering a subwoofer in bridged mode.

Your sub needs to be a minimum of 4ohms and should be relatively efficient. I'd look for a sub that has an RMS power range of from about 75 watts up to a maximum of 250 watts.

The sub connects to the leftmost speaker terminal (positive - right channel) and the rightmost speaker terminal (negative - left channel).

It's not going to be a really loud subwoofer. The power is 360 watts RMS which will be shared by the normal speakers and subwoofer.

Hope this helps.

Aug 05, 2009 | Power Acoustik TS620-2 Car Audio Amplifier

1 Answer

Car system


if you have dual voice coils connect on each seporate sub negative left channel to possative right channel of the subwoofer same to other sub then conect the left possative and the right neggative to your box power terminal same to other sub then conect the two sub outs on your box left speaker positive to your positive left channel bridge then conect left speaker negative to the right speaker possative then connect your right speaker negative to your right channel negative brigdeg to your amp is single coil hook the box its self up the same way to your amp i have two dual voice cooil 12" hooked up to the same amp that way and it rocks without the power protecter turning on

Nov 09, 2008 | Pyle PLA2200 Car Audio Amplifier

1 Answer

Improper function


try hooking up your subwoofers in series. then connecting them bridged to the amplifier. as follows: positive from sub#1 into positive of amplifier left channel.. negative sub#1 into positive sub#2. negative sub#2 into negative amplifier right channel. turn the gain down as this will sound pretty loud.

Jul 13, 2008 | Pioneer Car Amplifier GM-5100T - 2CH 760...

1 Answer

Thunder 5604


okay u will have to troubleshoo the amp.....dose the amp light up?...when u have the radio on? also check your sub wires.going to the amp....make sure the rca'sare hooked up to the radio rear out puts are the radio sub out puts...and then test your amp gain adjustment...let me know if that work's

Jun 23, 2008 | MTX Thunder5601 300W x 1 Car Amp Mono...

1 Answer

My Amp


sounds like the sub that throws it into protect mode is cross wired pull sub out and make sure they are wired right make sure ground from sub goes to ground on box and do same for power wire

Jun 11, 2008 | Sony Xplod Car Audio Amplifier XM-DS1300P5...

Not finding what you are looking for?
Kenwood KAC-9152D Car Audio Amplifier Logo

87 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Amplifiers Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1042 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pieter Vleeshouwers

Level 3 Expert

1423 Answers

Are you a Kenwood Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...