Question about Onkyo TX-DS939 Receiver

1 Answer

Onkyo TX-DS939 I just got tricked into buying a 2nd hand Onkyo TX-DS939 which doesn't work... The situation is like no matter which speaker output I hooked it up to, I can barely hear the music when it's at the highest volume, with my ears at the speakers. Would you happen to know what might be wrong with it?

Posted by on

1 Answer

I have to ask the obvoius, did you get the manual, have you used the onscreen menu to set up the speakers, you can calibrate the speaker levels on the TV screen if you use the S video or RCA vidoe connection .have you turned off tape monitor?

Posted on Jun 28, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Can the speakers surround sound work if the optical out is not red?


Yes.

There are several other methods for your surround sound channels to operate without your optical connection.

Jan 01, 2011 | Onkyo TX-DS939 Receiver

1 Answer

Turn on power and the amp goes to protect mode


disconnect the speakers and see if it does the same thing.
if it does not shut down,check that the speaker wires are not touching on the back of the speakers.
many times,people run over the wires with a vacuum or similar and a short results,or bump the speaker.most people have the leads way too long,and even if one strand touches,it will shut down the amp.
if it still shutting off,there is an internal problem.
the best place to go with an onkyo is an authorized depot.
they are tricky to work on.
i did onkyo warranty for 7 years.

Sep 06, 2009 | Onkyo TX-DS939 Receiver

1 Answer

Problem with onkyo tx 919 unit


Hi...
If you've had it "fixed" 3 times and the problem comes back either you have the wrong impedance (ohms) speakers connected or the power supply in the unit is the actual problem.

Happy new years,

Scott

Jan 01, 2009 | Onkyo TX-DS939 Receiver

1 Answer

ONKYO TX-DS939 (sound and heat/fan issues)


This sounds like the amp is seeing too small an impedence load. In other words, the amp is expecting to see an 8ohm load and is being presented a 4 or 2 ohm load. This will force the amp to work really hard and generate excessive heat. Does the amp generate sound at all? ever? If not, then you probable have a situation with high frequency oscuillations that you can not hear. This means that the amp is sending out a lot of power to the speakers that the crossovers are shunting to ground. Without seeing the output of the amp with a scope, I can not confirm this. This is not a problem that will be solved remotely. Bring the unit to a shop and request that the output be examined using a scope to check the waveforms. I suspect that a bad feedback look internally is causing the generation of the high frequency signals.

Keep us posted.

Dan

Oct 29, 2008 | Onkyo TX-DS939 Receiver

1 Answer

Onkyo HT-R530 with powered speakers


I would not suggest hooking up powered speakers to your receiver. Only if unit has sub woofer output can you hook up powered speaker

Apr 22, 2008 | Onkyo TX-SR605 Receiver

1 Answer

Onkyo TX-DS939 optical selection problem help!


That coaxial, opt-1 and opt-2 are available only if they are not selected to some other channel. So you have to check if opt-2 is selected to Video-1,2,3,4,5,6,7,CD or DAT. Change that to Analog and then opt-2 is free to another device.

Mar 24, 2008 | Onkyo TX-DS939 Receiver

1 Answer

Need to buy the jumper plug


What do you mean by a jumper plug. Are you referring to the preamp jumper plugs?

Sep 01, 2007 | Onkyo TX-DS939 Receiver

Not finding what you are looking for?
Onkyo TX-DS939 Receiver Logo

273 people viewed this question

Ask a Question

Usually answered in minutes!

Top Onkyo Audio & Video Receivers Experts

D. E. Hev

Level 3 Expert

1059 Answers

gbob59

Level 3 Expert

2963 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1042 Answers

Are you an Onkyo Audio and Video Receiver Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...