Question about Bissell 1698 PowerSteamer ProHeat Upright Wet/Dry Vacuum

1 Answer

ICAN NOT GET IT TO PICK UP THE DIRTY WATER. - Bissell 1698 PowerSteamer ProHeat Upright Wet/Dry Vacuum

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Mentor:

    An expert who has written 3 tips or uploaded 2 video tips.

  • Expert
  • 327 Answers

THERE ARE TWO BELTS ONE IS OFF ITS THE VACUUM ONE YOU HAVE TO TAKE OFF THE COVER AND REPLACE WHEN YOU DO THOU MAKE SURE YOU LOOK AT EXACTLY HOW THAT LITTLE RED CLICKER THAT HOLD THE ROLLER BAR IN VERY IMPORTANT, ALSO WHEN YOU GET THE BELT BACK ON LIMIT YOU CLEANING FLUID TO A LITTLE NOT SO CONCENTRATED WHEN ITS TOO MUCH CLEANER THE BELT WLL KEEP SLIPPING OFF.

Posted on Aug 11, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

It does not pick up the water after cleaning solution is applied


The most common reason for lack of pick up on the F5000 series is that the lid is not fully seated on the dirty water tank. Be sure to hook the two tabs on the front of the lid, and then snap the rear latch into place. Another reason is that the duct on the front of the dirty water tank is missing. The duct may have been removed to install the hose, and was not put back in place. It is a square plastic piece, about the size of a slice of sandwich bread, which slides into the front of the tank. A far less common reason for no pick-up is that the seal that the tank sits on has fallen off the motor cover suction tube. You will see a round tube on the bottom of the dirty water tank. This sits on top of a large rubber seal on the motor cover when the tank is in place. Be sure the seal has not fallen down into the hood.

Aug 16, 2011 | Hoover SteamVac Carpet/Upholstery Deep...

1 Answer

The steam vac will not pick up dirty water. I never had this problem with a steam cleaner. I bought Hoover because of its reputation and I cannot get the suction on the bottom container to work. This...


The most common reason for lack of pick up is that the lid is not fully seated on the dirty water tank. Be sure to hook the two tabs on the front of the lid, and then snap the rear latch into place. Another reason is that the duct on the front of the dirty water tank is missing. The duct may have been removed to install the hose, and was not put back in place. It is a square plastic piece, about the size of a slice of sandwich bread, which slides into the front of the tank. On new models the duct tilts forward and cannot be removed. A far less common reason for no pick-up is that the seal that the tank sits on has fallen off the motor cover suction tube. You will see a round tube on the bottom of the dirty water tank. This sits on top of a large rubber seal on the motor cover when the tank is in place. Be sure the seal has not fallen down into the hood.

Jul 27, 2011 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

My hoover rug clearner won't pick up water when I pull back.


You don't say which model you have but this often occurs on the F5000 series. The most common reason for lack of pick up is that the lid is not fully seated on the dirty water tank. Be sure to hook the two tabs on the front of the lid, and then snap the rear latch into place. Another reason is that the duct on the front of the dirty water tank is missing. The duct may have been removed to install the hose, and was not put back in place. It is a square plastic piece, about the size of a slice of sandwich bread, which slides into the front of the tank. A far less common reason for no pick-up is that the seal that the tank sits on has fallen off the motor cover suction tube. You will see a round tube on the bottom of the dirty water tank. This sits on top of a large rubber seal on the motor cover when the tank is in place. Be sure the seal has not fallen down into the hood.

Jul 26, 2011 | Vacuums

1 Answer

It does not **** up the dirty water after shampooing


The most common reason for lack of pick up is that the lid is not fully seated on the dirty water tank. Be sure to hook the two tabs on the front of the lid, and then snap the rear latch into place. Another reason is that the duct on the front of the dirty water tank is missing. The duct may have been removed to install the hose, and was not put back in place. It is a square plastic piece, about the size of a slice of sandwich bread, which slides into the front of the tank. A far less common reason for no pick-up is that the seal that the tank sits on has fallen off the motor cover suction tube. You will see a round tube on the bottom of the dirty water tank. This sits on top of a large rubber seal on the motor cover when the tank is in place. Be sure the seal has not fallen down into the hood.

Jun 22, 2011 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

I have a hoover steam vac spin scrub that won't pick up the dirty water heeelllllllppppppppppppp please


The most common reason for lack of pick up is that the lid is not fully seated on the dirty water tank. Be sure to hook the two tabs on the front of the lid, and then snap the rear latch into place. Another reason is that the duct on the front of the dirty water tank is missing. The duct may have been removed to install the hose, and was not put back in place. It is a square plastic piece, about the size of a slice of sandwich bread, which slides into the front of the tank. A far less common reason for no pick-up is that the seal that the tank sits on has fallen off the motor cover suction tube. You will see a round tube on the bottom of the dirty water tank. This sits on top of a large rubber seal on the motor cover when the tank is in place. Be sure the seal has not fallen down into the hood.

Jun 15, 2011 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

I have a Hoover SteamVac Spin Scrub that won't pick up the water. Could you please give me some info on how I might fix it. Thanks!


The most common reason for lack of pick up is that the lid is not fully seated on the dirty water tank. Be sure to hook the two tabs on the front of the lid, and then snap the rear latch into place. Another reason is that the duct on the front of the dirty water tank is missing. The duct may have been removed to install the hose, and was not put back in place. It is a square plastic piece, about the size of a slice of sandwich bread, which slides into the front of the tank. A far less common reason for no pick-up is that the seal that the tank sits on has fallen off the motor cover suction tube. You will see a round tube on the bottom of the dirty water tank. This sits on top of a large rubber seal on the motor cover when the tank is in place. Be sure the seal has not fallen down into the hood.

Jun 15, 2011 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

My Hoover Steam Vac does not **** up the dirty water.


The most common reason for lack of pick up is that the lid is not fully seated on the dirty water tank. Be sure to hook the two tabs on the front of the lid, and then snap the rear latch into place. Another reason is that the duct on the front of the dirty water tank is missing. The duct may have been removed to install the hose, and was not put back in place. It is a square plastic piece, about the size of a slice of sandwich bread, which slides into the front of the tank. A far less common reason for no pick-up is that the seal that the tank sits on has fallen off the motor cover suction tube. You will see a round tube on the bottom of the dirty water tank. This sits on top of a large rubber seal on the motor cover when the tank is in place. Be sure the seal has not fallen down into the hood.

Mar 07, 2011 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

Pet hair and dirty water back on carpet


If you have followed the instructions.And your not happy i would return it.Get a repacement.

Aug 08, 2009 | Bissell 1698 PowerSteamer ProHeat Upright...

1 Answer

Shampooer won't pick up water


look on the vacuum where the suction is to pick up and you will see its clogged ,clean out the suction ports

Apr 13, 2009 | Kirby G6 Bagged Upright Vacuum

Not finding what you are looking for?
Bissell 1698 PowerSteamer ProHeat Upright Wet/Dry Vacuum Logo

31 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bissell Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18425 Answers

Brad Brown

Level 3 Expert

17448 Answers

Jim Parker
Jim Parker

Level 3 Expert

1041 Answers

Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...