Question about Hobart Handler 140 Mig Welder

1 Answer

Have Hobart 140 Handler, The motor won't run to feed the wire, even whith out wire. gas will come on when trigger depressed.Where can I find parts to fix?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 23 Answers

You need to look at the wiring diagram to see what parts could be causing the problem. I had a 120 that did the same thing and it was the bridge rectifier that was bad. I unhooked my motor and hooked it to my battery charger to see if it was good.Hope this helps. I will see if I can find a diagram to look at and check back later to see if you have fixed the problem.

Posted on Aug 10, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My motor on my hobart handler 135 is not working to make the wheels roll to feed wire. I disconnected it at the connectors and tested it and was not getting any readings on my meter as if it was not g


Make sure the trigger switch is applying power to the motor. If there is no reading when you checked for OHMS then the motor is open. You'll have to get a new one.

Jan 13, 2014 | Hobart Handler 140 Mig Welder

1 Answer

Hobart handler 140 mig welder gas wont shut off


Looking at the Hobart manuals, that is how they set them up at the factory.

One way to make a change to that is to wire in a solid state relay or solid state Triac and pick up an energizing voltage off of location RC2-1 or RC2-2 on the control board when the trigger is pressed, or as an alternate location from the feed motor through a resistor and rectifier. Once you know if the voltage goes low, or voltage goes high at your point of signal, you pick the contact you want on the relay so when the wire is feeding out, the gas is flowing. and when it is not feeding wire out, the gas is shut off.

Dec 31, 2011 | Hobart Welding Tools

1 Answer

Hello, I have a Hobart 180 and the wire feeder motor won't run. I replaced the wire feed motor and it still won't run. any ideas?


Sound like you have a bad trigger on the gun. Does gas spray when you pull the trigger? Check the wire plug that goes from the pistol to the unit. It should be under the liner hose where it connects to the machine. Then use a voltage meter on the wires going to the drive feed motor, and see if you get current when you pull the trigger. If gas doesn't spray neither, sounds like you got a bad trigger switch

Jun 27, 2011 | Hobart Welding Tools

1 Answer

Wire feed motor will not run even without the wire in it.


Probably the bridge rectifier. I had a 120 and thats what happened to it...

May 15, 2010 | Hobart Handler 140 Mig Welder

1 Answer

I have a hobart handler 135 motor stops feeding


Take the drive motor off and blow out dust, chips, wire pieces, etc. and then rinse out with contact cleaner, blow dry, re-install. Had to do this every so often with mine. Hope that helps.

Jan 05, 2010 | Hobart Handler 140 Mig Welder

4 Answers

I have a hobart handler 135


You do not indicate if the wire is already out of the nozzle. If not, commonly the wire can jab the side of the tube it runs through and cannot advance.

IF the wire is already threaded, then there MAY be a fuse to protect the motor.

The click MAY be the gas valve, or the relay driving the motor and/or the main transformer for welding current. The circuitry for these is relatively simple and a voltmeter is your friend to troubleshoot this.

Oct 26, 2009 | Hobart Handler 140 Mig Welder

1 Answer

My hobart 135 will not feed wire. I checked for voltage at the drive motor no voltage. The gas still comes on when trigger is pulled but seems that the problem is in the control board?


does it have a reset button? if so it has gone bad, if not there is a fuse or something inside. they protect that circuit against shorting at the working end of the gun. happens ALL the time.
Hawk

Mar 31, 2009 | Hobart Handler 140 Mig Welder

2 Answers

Hobart handler 140 will not feed wire


A schematic would certainly help, give Hobart a call and ask for a wiring diagram. or manual. Hobart are very helpful and may even give you guidance, you may have to pay the postage, they usually fax these documents so it will not cost you anything.

Feb 13, 2009 | Hobart Handler 140 Mig Welder

Not finding what you are looking for?
Hobart Handler 140 Mig Welder Logo

808 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hobart Welding Tools Experts

Doctor PC
Doctor PC

Level 3 Expert

7733 Answers

Matt Olenzek
Matt Olenzek

Level 2 Expert

293 Answers

Troy
Troy

Level 1 Expert

35 Answers

Are you a Hobart Welding Tool Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...