Question about Yamaha DSPE390 Amplifier

1 Answer

No sound MY YAMAHA DST-E390 I HAVE IT ALL WIRED UP OK rec out works perfect, but no sound is coming out of front or rear speakers turns on perfect and display still works just no sound any ideas? ic's?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 319 Answers

Make sure speakers are hooked to proper connectors. Also check speaker switch "A"/ "B"/ "A+B" is positioned to correct speakers.
Also make sure mute switch is off

Posted on Apr 29, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Please advise if I can fix myself ? or do I need to take some where and if yes where and who can I trust


Can you please tell me exactly how you have the receiver wired. What I need is, for example, the left front speaker is wired to what? Do you have more than one speaker wired to to the same speaker terminal? For more information, or if you would like to inquire about having your Sony repaired, please visit my website at audioserviceclinic.com. By the way, I was a Sony Factory Authorized Service Center for over 30 years. Thank you.

Feb 01, 2012 | Sony TA-E9000ES Amplifier

2 Answers

My yamaha DSP AX1 amp does not work when audio is connected via optical or coaxial any suggestions how to correct this. no sound comes from any speaker except the subwoofer.


Are all the speakers turned off (set to None) in the speaker menu.(except the sub)?

2 channel direct analog stereo may still work, but any surround modes will use the speaker settings and the full DSP digital section.

Check also the input mode isn't incorrect - although if the sub is wired correctly and gives sound this can't be whats wrong.

Aug 26, 2010 | Yamaha DSP-AX1 10-Channel Amplifier

1 Answer

I dont get streo sound from my front left and


On the front LCD display of the receiver their is a small button for speakers A & B, make sure they are both lit. If they are, post a comment and I will help you troubleshoot further

Jun 29, 2009 | Amplifiers & Preamps

3 Answers

Str-D590


This is not a reset. Most likely one or more transistors have shorted and need to be replaced. Does the front display come on OK?
Dan

Apr 29, 2008 | Amplifiers & Preamps

2 Answers

Yamaha dsp-/e300 wont switch on


check your speaker wire and speaker for short circuit.

Jan 17, 2008 | Yamaha DSPE390 Amplifier

1 Answer

Can i use small satelite speakers with my big front speakers?


Hi, I asume your setting up a home theater with five speakers a center left and right and rear surrounds don't know if you have a subwoofer. The large speakers in the front will work fine if you set the amp to large front speakers the bass will be sent to these. If you have a subwoofer set, the amp to small front speakers and the bass will be directed to it. Also try to get a center channel speaker that sounds somewhat like your large speakers.

Feb 14, 2007 | Yamaha AX-596 Amplifier

Not finding what you are looking for?
Yamaha DSPE390 Amplifier Logo

Related Topics:

104 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha Amplifiers & Preamps Experts

 Grubhead
Grubhead

Level 3 Expert

4590 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

68323 Answers

Are you a Yamaha Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...