Question about Power Acoustik LT-980/2 Car Audio Amplifier

1 Answer

Kac 8452 so i would buy a new one but i luv this one, its amazing and hard to find, so it was workin fine and just stoped. wont blow a fuse but wont power up, led turns on for a few sec. and you hear a thump in the sub but then shuts off. led and all. i checked the soldering and nothings warped of fried. i fixed it once before but this isnt the same problem!!! email me eldiscjockey@yahoo.com thanx

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

The amp probably has shorted output transistors. You'll need an ohm meter to check them. If you're new to electronic repair and want to try to troubleshoot/repair the amp yourself, read the following page and then post any questions you have.

Amplifier Repair Primer

Posted on Apr 29, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

X621 excelon amp has red light on, stoped workin all of the sudden now a minimum sound exports with a bit of static. do i reset it? what do i do and how?


If disconnecting all power wires, and replacing all fuses (including inline ones) doesnt reset it. then its toast. Hate to break it to you :( Contact the manufacturer if you feel it is under warranty.

Apr 14, 2010 | Kenwood Excelon KAC-X521 Car Audio...

1 Answer

The heater fan stoped workin


Check the blower relay,and the blower switch.

Feb 06, 2010 | 2003 Kia Spectra

1 Answer

While cooking the microwave stoped workin. no


There is probably a fuse inside that you can replace (unplug before opening case). If after replacing it blows again, you'll need to test for a short (control, magnatron, diode, capacitor, among other possibilities).

Oct 21, 2009 | Microwave Ovens

1 Answer

I have a kenwood kac-8452 4 channel amp that makes the speakers pulse after the volume gets turned up to 10. I also have a kenwood amp doing the same thing with my subs. any ideas?


Its not pulsing, its called clipping. The sound is being clipped due the amp being pushed past is power capacity and distorting the signal. This will damage your speakers very quickly. No amp should be turned more then 3/4 up. If its not loud enough you need to purchase a larger amp or be comfortable with the wattage it produces at 3/4 volume. You may also have speaker wires touching/crossed causing th issue.

Sep 10, 2009 | Kenwood KAC-8452 Car Audio Amplifier

2 Answers

Running 2 amps


amps could be overheating or the subs could be requiring more power then the amps are giving off.

Apr 01, 2009 | Kenwood KAC-8452 Car Audio Amplifier

2 Answers

1 amp cuts off


i had this same prob. & i run 2 amps as well, cameto find out i had a neg. & positive touching , so check all ur wiring for tht amp..

Apr 01, 2009 | Kenwood KAC-9102D Car Audio Amplifier

1 Answer

My sons kac 848 amp just stopped working


There is an Internal Fuse on Most of these Models that will blow from time to time. You might also check the Ground Connection. A loose Ground can cause the Same Problem. Please Rate My Response! Thanks!

Feb 02, 2009 | Kenwood KAC-848 Car Audio Amplifier

4 Answers

I turn on the amp then the fuse blows??


If the fuse only blows after the remote voltage is applied, the amplifier probably has shorted output transistors.

Dec 01, 2007 | Kenwood KAC-X401M Car Audio Amplifier

Not finding what you are looking for?
Power Acoustik LT-980/2 Car Audio Amplifier Logo

Related Topics:

45 people viewed this question

Ask a Question

Usually answered in minutes!

Top Power Acoustik Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

yadayada
yadayada

Level 3 Expert

64012 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you a Power Acoustik Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...