Question about Optoma RD50 50" Rear Projection HDTV-Ready Television

1 Answer

Ghost images! Installed new lamp after getting a solid red lamp/internal problem signal. After install picture came back on but soon started showing these intermittent ghostly images over the entire screen when televising channels or dvds. Re-installed new lamp only to get the solid red signal again. While engine is booting up there is this humming noise that was not there prior to a neighborhood power surge which initially caused the new lamp install. Old lamp's marks are: P-VIP 100/1.3 E23 qN5 Hg (underscored) Made in Germany. New lamp's marks are: P-VIP 120/1.3 E23 Czech Rep. W (underscored) H5 Hg (encircled). Both are labled TOP OSRAM.

Posted by on

  • 1 more comment 
  • locar May 06, 2008

    Hi everyone, I have a similar problem on a optoma rd50, the tv started flashing (ghost images), then one fine day the tv didn't start, along with a set of red ligths and a humming noise at the begining. Replaced the lamp and the little fuse on the lamp circuit board, tried to turn the tv on , but the same syntoms as described above; please help me, what should i do to resolve this issue. Thanks

  • syd9 May 14, 2008

    Hi locar. That is my post under syd9. You might have to get a service person in to look at your tv. I did and right now my tv is in the shop and possibly in need of a ballast and/or a color wheel. Optoma sells the wheel only with the engine it is attached to for almost a thousand dollars. My repairman as well as I thinks this is ridiculous. He is saying the wheel should cost no more than 150 - 175 dollars. Hope this is not your problem and it is an easy fix..

  • syd9 Jun 05, 2008

    Syd999 here and have posted on this subject earlier. This might help or not in regards to getting set to work after new bulb installation: Initially my repairman said I needed a new lamp, a new ballast and a new color wheel (only sold from Optoma with its engine at a cost of $933.00). I opted not to have this done because of the cost. Repairman wanted to charge an exorbitant amt to return tv to me. After much haggling I picked up tv myself. When I plugged it in at home the set worked perfectly and still does. My point here is that I read somewhere that there is a service menu in the tv (to reset the new bulb installation) and I passed this info on to the repairman. Whether or not this corrected the problem I don't know because the repairman didn't give me this info but he did say that he had to replace the fuse that was blown in the lamp housing. Hopefully this will give some light on how to reset the set. Bottom line - have the fuse checked and also have the re-set's menu (I could not find this function in the regular menu) calibrated or whatever terminology is correct. If I find out how to do this I will post that info here! Good luck videophiles!

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I had the same problem, reset the lamp hours by pressing 'menu, 619 , menu" and browsing until I found the setting, but then I also saw an option to test the lamp.  The TV shut off when I tried this and 2 red lights indicating a new lamp is needed came on instead.  It's probably the ballast and not the lamp, but I don't know that I want to put any more money into this set.  I have only had it 2 years.

Posted on Jun 22, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

No sound or picture. red timer light on. wd60735


Hi there,

This model as 3 LED indicator lights:

1) Power/Timer 2) Status 3) Lamp


If "STATUS" LED is blinking RED:

1) Internal Fan has stopped. These tv's require fans, to prevent overheating and causing damage.

If "STATUS" LED is solid RED:


1) Circuit failure (short)
2) Disconnected DVI cable, chassis to engine
3) No LAMP-EN signal from Engine to turn the lamp On.
4) Ballast UART communication problem.

If "LAMP" LED is solid RED:

1) Lamp Failure - Lamp failed to turn On.
2) Lamp is broken (e.g. burst or blown)
3) Lamp turns Off during P-ON

There is no data relating to TIMER LED being solid RED.

Hope this helps.

Cheers,

Scott

Feb 01, 2013 | Mitsubishi Projection Televisions

1 Answer

Hi! I am experiencing the following three


Hi Rafael,

First of all thank you for posting your question here at Fixya.
Please confirm if the brand and model number above is correct.
Blinking of the the LED (yellow and blue) at the front panel indicating that the lamp door cover is not seated properly. This cover will engaged to a micro switch giving the signal to the processor, once it is in open position, the unit will not power up and will experienced that kind of blinking error code. Go back to the lamp door cover and ensure that it is properly seat-in.
3D, 2D, red/green/blue ghost on the picture and letters means that the convergence circuitry gone bad. Symptoms is not connected to the light engine. The faulty parts is the convergence chips(IC). This chips are mounted on the large aluminum heat sink and starts with STKXXXX-XX (X means number). The most common STK chips used on Projection TV's is the STK392-110. You have to replaced them both on the board to resolve the issue(red ghosting). It is necessary also to check the resistance value of the resistors around its circuitry using the multimeter. For more info how to repair a convergence problem, watch the video below.




Jdvillanueva

Jan 27, 2012 | Toshiba 62MX195 62" HDTV

1 Answer

Installed new lamp. When powered up blue solid light and yellow blinking light (15x) , tv would torn off and on several times trying to light lamp. Once that failed red blinking light and yellow solid...


Hi Genaro,

Blue led light lit solid and yellow led light flashes is an initial attempt of the set to re-light the lamp.Red led flashes and yellow led light solid means that the lamp won't light up that's why it only has sound without the picture.
Since you've replaced the lamp twice and still the symptoms persist, I suspected that the fault came from the ballast board and not on the lamp itself. If the ballast board gone to malfunction, there's no high voltage will produce to light up the lamp and will sensed by the processor and trigger the error code (Flashes/solid led light with color code).

To verify whether the ballast board is faulty or not, check if the lamp will lit by looking through the lamp door louvers at the rear of the cabinet upon turning on the set.
Please let me know what you will find to assist you further.

Jdvillanueva

Nov 05, 2011 | Toshiba 65HM167 65" Projection Television

1 Answer

My Mitsu 52525 lamp indicator went solid red. I


sounds like the caps on the power board have failed. You can get the V26 DM/Power repair kit from www.tvrepairworld.com which also contains the instructions.

May 12, 2010 | Mitsubishi WD-52525 52" Rear Projection...

2 Answers

Sony Wega KF-42E200A Projection Bulb


New bulb is just fine.
3 blink shows that lamp cover after replacement of bulb in TV is not fixed properly or not seated well in its position.
Put new bulb and carefully place back lamp cover in its position because lamp cover will press tinny safety switch inside that will send signal to system control of TV that lamp is installed properly.
Turn On TV and get vivid picture of Sony.
Thanks.


Oct 17, 2009 | Sony Grand WEGA KF50WE610 50" Rear...

1 Answer

Toshiba theatreview


sounds like vertical problem maybe bad solder connections on vertical ic check and get back to me

Nov 03, 2007 | Projection Televisions

2 Answers

WD-52525-Code 34-Sound OK-No picture!


I had another problem kinda the same and emailed ctechnicians.com and they gave the fix.

Nov 02, 2007 | Mitsubishi WD-52525 52" Rear Projection...

2 Answers

Replaced lamp and now can't get a picture


Hi Sally Jo, Unit powers on and works properly for a while then shuts off with a red lamp LED (lamp error). Suspect bad lamp part # 915P020010 2. Lamp enable line at J14 pin 6 does not switch to 5 volts after turn on, 12 and 5 volt supplies are good. Suspect the Light Engine part # 939P977010 3. At power on the lamp turns on and off three times and then the unit shuts down with a red lamp LED (lamp error). Replace the Light Engine part # 939P977010 4. Check for 12-volts DC at J-9 connector pin 4 on the Engine Driver PCB, if missing check for an open F9A09 on the Power PCB, if it is open replace F9A09 part # 283P127060 and the Light Engine part # 939P977010 5. Lamp enable line at connector J14 pin 6 on the Engine Driver PCB switches to 5 volts after turn on but does not go back to 0-volts (low) after 5 seconds, 12 and 5 volt supplies are good. Suspect the Light Engine part # 939P977010 6. Check for 5-volts DC at J-9 connector pin 1 and 2 on the Engine Driver PCB if missing replace the Power PCB part # 934C148001. Hope this helps!

Sep 17, 2007 | Mitsubishi WD-52327 52" Rear Projection...

Not finding what you are looking for?
Optoma RD50 50" Rear Projection HDTV-Ready Television Logo

Related Topics:

245 people viewed this question

Ask a Question

Usually answered in minutes!

Top Optoma Projection Televisions Experts

Jaime Hernandez

Level 3 Expert

2267 Answers

matt martin
matt martin

Level 3 Expert

1191 Answers

yadayada
yadayada

Level 3 Expert

60867 Answers

Are you an Optoma Projection Television Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...