Question about Humminbird Fishfinder 570

1 Answer

My 570 quit showing the depth and continues to show 0.6'. It will show the depth once when first turned on then go back to the 0.6' reading. It worked when I first installed it a couple weeks ago but doesn't seem to work now. Is it the unit or transducer or both? Thanks D.J.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 3 Answers

I had the same problem. It was the transducer.

Posted on Aug 30, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2015 polaris rager that quits now and then and a 520305 code comes up, what is wrong. throttle body has been changed?


I had same problem. Turned out to be temp sensor putting bike into limp mode then quitting. Never seen that code though as my ranger only shows codes from 21-61

Mar 04, 2015 | Polaris 2015 Ranger Crew 570 EPS

2 Answers

Just purchased and Eagle Fishmark 320 used. Will not display depth reading - just shows 0'0"? I have reset to factory settings. We have had in lake,same thing. Right now in 5 gallon bucket of...


Hello! Do you have the PDF users guide for your unit? I'm looking at a copy in the troubleshooting section...I don't want to cover information you have already looked at or tried...Since I do not know if you have that manual I'll give you a few items to check...

Measure the battery at the units power connector...Must be at least 11 volts DC...In portable mode it uses 8 D cell batteries= 12 volts
Make certain the Transducer is securely connected...
Did you use the in-line fuse supplied with the unit?...
Try the Manual Depth Range...First turn off Auto Depth Range...From the sonar Page Hit MENU...Down-arrow to Auto Depth Range...Hit ENT...Hit Up-Arrow to Depth Range...Hit ENT..
And the Depth Scale Range appears...Up-Arrow or Down-Arrow to select a different depth range...Hit Exit...The minimum depth the unit can read is 5 feet...

If you do not have the PDF guide, here is the link...

http://www.eaglenav.com/upload/Eagle/Documents/Manuals/seafinder320df_0143-661_101602.pdf


Let me know how you make out....Guru....Saailer

Sep 11, 2011 | Eagle Fishmark 320 Portable Fishfinder

1 Answer

The unit will not show a depth reading - just shows 0 0?


Try adjusting ur puck,and go into menu look for a shallow,fresh water setting.less than a 100ft put in shallow all other depths in fresh

Sep 11, 2011 | Eagle Fishmark 320 Portable Fishfinder

1 Answer

The unit worked fine for 3-4 months.Now,it just gives a reading of 0 ft. with the water temperature. Once in a while while i'm drifting it will give me a depth for a few seconds and go back to a 0...


It sounds like your transducer has gone bad. You may be able to find a replacement on Craigslist or eBay, since this is an older model. Transducers are pretty sensitive to bumps and drops because of the crystal inside.

Aug 23, 2011 | Humminbird Piranhamax 170

1 Answer

I have a humminbird pmax 170. It does not show depth. It stays on 0 ft all the time. The unit reads temp but no depth


Contact our customer service group and they will be able to help you. There number is 800-633-1468.

Jan 08, 2011 | Humminbird Piranhamax 170

1 Answer

Mastercraft Prostar 197,2005. Electrical problem?


Try your tether , plug and unplug it a few times , sometimes they stick, get corroded from the water..

Aug 22, 2009 | Garden

1 Answer

Eagle 640c Fish Finder dosen't read corectly.


I had the same problem and got the transducer changed. It now works perfectly. That could be the problem you are having... bad transducer.

May 17, 2009 | Eagle Intellimap 640c Marine GPS GPS...

2 Answers

Inccorect cartrigde


Try using a pencil eraser to clean the gold contacts on the back of the cartridge. If they get dirty or cruddy, the printer won't be able to 'read' the cartridge correctly.

Hope this helps, and please rate my advice, good OR bad.

Thanks, and good luck!

Feb 04, 2008 | Lexmark X3480 All-In-One Printer

Not finding what you are looking for?
Humminbird Fishfinder 570 Logo

Related Topics:

849 people viewed this question

Ask a Question

Usually answered in minutes!

Top Humminbird Boating Experts

Mike Marcotte
Mike Marcotte

Level 2 Expert

76 Answers

Phil Walker
Phil Walker

Level 3 Expert

608 Answers

Steve
Steve

Level 3 Expert

693 Answers

Are you a Humminbird Boating Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...