Question about Western Digital Passport 320GB External USB 2.0 Hard Drive

1 Answer

I purchased the unit and plugged in. Is there something else I should have done. It doesn't seem to be working.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

If you plugged it into an unpowered USB hub, it may not be getting enough current. Try plugging it directly into a USB port on the computer. It requires 2 amps to spin up and unpowered hubs only provide 500ma for all connectors, just a quarter of the required power. Or you can buy a powered hub, which relieves the strain on your computer's power supply.

Posted on Aug 05, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Technician can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Technician (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The machine doesn't work even in plug


First check that the house circuit breaker isn't tripped. If it seems good, unplug the machine and plug a lamp or something in to check receptical. If all seems good let me know.

Jan 20, 2013 | Washing Machines

1 Answer

DVI no signal keeps saying check video cable i have


If it worked before and suddenly doesn't work now it could be a bad cable. kinks in the able can be a problem but also when you plug-in the cable be careful because damaging the cable end or the the cable port is easier than you may think.. first replace the cable with one that you know works on another unit ..if that doesn't work examine the ends carefully for anything out of the ordinary.. get a technician to take a look if something seems strange with the cable end or the port..DVI cables come in several flavors make sure your using the right one and don't force the cable in that could make matters worst and more expensive....good luck..!

Sep 24, 2011 | HP w1907 LCD Monitor

1 Answer

Our 4 month old Frigidaire FRA256ST2 stopped working today.We had an eletricain check the plug and the unit is getting power.When you plug it in and press the reset,it beeps,LCD flashes but doesn't...


A dirty or clogged air intake filter will prevent the unit from turning ON, as a safety feature. If that isn't of doesn't solve the problem. Contact Frigidaire 1-800-944-9044. As you unit is still under 100% warranty at this point. They will repair it or replace it at their option. Don't do anything to the unit, that could possibly void the warranty.

Hope this helped you and thanks for choosing FixYa.

Aug 21, 2011 | Frigidaire FRA256ST2 WallWindow Air...

1 Answer

Recently purchased brand new m116 fullbore metal and it doesn't seem to be receiving power....


The plug into the inout jack turns the unit on. You don't mention if you are using a bettery or an adapter...

Aug 15, 2011 | MXR M116 FullBore Metal Pedal Guitar

1 Answer

Its an onkyo av reciever tx-sr601It was gaven to me from a friend...I can turn it on but it shuts off seconds after. I have left it unplugged many times and have retried but the same problem occurs. Does...


Hi,
The receiver doesn't have a password, but the unit can be fried, let's go with by a process of elimination.
First, the most noticeable procedure would be to not plug in anything in back of the receiver, and plug it in the an outlet and turn it on. If the unit shuts off after a few seconds, then the unit has a short and must be sent in for repair.
If the unit stays on, then there is something that is being plugged into the Receiver that doesn't seem to agree. Start by plugging in one source at a time and repeating the step above. It's a slow process but hopefully and eventually, you will find the culprit.
In most cases though, it usually the speakers wires in the back touching even a slight bit or your speakers impedance don't match what the receiver is capable of taking.
I strongly recommend starting with the first step since this will allow you to figure out if the receiver is defective or is something else the culprit.
Hope this helps, Best of Luck

Jul 24, 2011 | Onkyo TX-SR701 Receiver

1 Answer

Hello. I just plugged my danby and there's no light, no nothing: it doesn't work? It used to work perfeclty last summer. What can I do?


Marie, the problem may be with the receptacle that it's plugged into. Unplug the AC unit and plug a lamp into the receptacle to see if it works. If it doesn't, the circuit breaker for that outlet may be tripped in your home's circuit breaker panel. Or the receptacle may have a loose wiring connection or internal damage, which wouldn't necessarily trip the circuit breaker, until something like an AC unit is plugged in.

Hope this helps you troubleshoot and solve the problem.

Jun 08, 2011 | Heating & Cooling

1 Answer

I just recieved a Laser q13-mp4. I thought it was a "plug-n-play" on my windows vista. The driver will not install. The unit itself simply says "connect". I tried installing device...


I just got one for Mother's Day and managed to get songs onto it and 2 photos but that's it. I have spent all day trying to get it to talk to the computer but without any luck. I'm in Australia too but it should have nothing to do with it.
if it doesn't work on my lappy, I'm returning it for a refund. No good keeping something that doesn't work.

May 14, 2011 | Laser MP4-V970 MP3 Player

1 Answer

I purchased a 32" Dynex


You only need to plug in the Red/White/Yellow plugs. Make sure you plug them into the correct colors on the TV. Most HDTVs have Red/Green/Blue ports. DO NOT use these ones, they are for receiving HD video signals. A lot of HDTVs also have the Red/White/Yellow plugs on the side of the TV (often labeled "Game", maybe something like "Video 3")

The Red/White/Yellow cables are known as RCA cables or Composite cables so look for any ports with those labels as well.

May 09, 2011 | Nintendo Super NES Console

1 Answer

I have a Pioneer PL202-az turntable. That's all I have. No receiver to plug it into for power. However, the unit does have the two audio cables and cord (male end) to plug into the receiver for power. ...


"PHONO" is the only designated connection on a receiver that is literal and exclusive. Nothing but PHONO will work right on it and old-school turntables would require it to preamplify the tiny current produced by a Phono cartridge.


If your unit doesn

Feb 26, 2011 | Pioneer Audio Players & Recorders

Not finding what you are looking for?
Western Digital Passport 320GB External USB 2.0 Hard Drive Logo

Related Topics:

42 people viewed this question

Ask a Question

Usually answered in minutes!

Top Western Digital Computers & Internet Experts

Arora Singh
Arora Singh

Level 2 Expert

180 Answers

Alun Cox

Level 3 Expert

2678 Answers

Marcin

Level 2 Expert

191 Answers

Are you a Western Digital Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...