Question about Air Tools & Compressors

1 Answer

I bought the compressor about two years ago and used it only a few times. It ran fine a few weeks ago but today it will not start. It is as though it is not plugged in even though the outlet works for all other appliances. What can I do?

Posted by on

  • rcbailey36 Aug 04, 2010

    I refer to HItachi compressor, model EC 79

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 843 Answers

Is it possible that you didn't drain the air out of it after you used it a couple of weeks ago? If the pressure in the tank is somewhere around 100psi, the compressor won't run until it drops lower. If there is no pressure in the tank you might see if you can wiggle the pressure lever that makes the switch move to turn on the motor - it might be stuck.

Posted on Aug 04, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Leaking something awful; plastic base appears to be cracked. I just bought two weeks at at Home Depot. Can I return. (Can't find my receipt.)


Usually they will accept it without a receipt. No cash back though. Store credit or go get another one.

May 08, 2015 | Cars & Trucks

1 Answer

GE Profile PTS25LBMARWW - Power, but no Cold


yes the mother board is located under the plate in the back.. but when you replaced the relay did you put on a 3in1 relay or a manufactured relay?

Aug 01, 2008 | GE Profile PFS22 33" Artica French Door...

1 Answer

2003 Toyota Corolla AC Blower/Fan will not turn on, I replaced the Blower/Fan a few weeks ago,


A/c compressor works fine and the blower motor works and shutdown right? it is the problem with the blower resistor or with blower motor relay. try to direct the resistor irrespective of the speed. hope the problem may be solved.

Jun 05, 2014 | 2003 Toyota Corolla

1 Answer

My 2003 lincoln ls is running hot. It stared about a few weeks ago. it ran hot, and I let it cool off. It ran fine after that. Today, it ran hot. I let it cool for a few hours. When I crunk it up, it...


First check your coolant level.

Next make sure your fan is operating properly.

Lastly, if all of those criteria have been met check your water pump, it may need replaced.

Hope this helps.

Sep 06, 2011 | Ford LTD Cars & Trucks

1 Answer

I bought a john deere riding mower less than a year ago. i used it last season without any problems. I think the last time i used it, was in august 2010. winter came about, the grass wasn't growing, so...


First, I've had a motorcycle for almost 50 years and have never drained the gas. At one point it was not used for 3 years. It started, I added gas and it ran fine.
Second, next time you are running the machine and it begins to stall, immediately loosen the gas cap. If it starts to run good again, drill out the air vents on the cap.
Gary

Mar 09, 2011 | Garden

1 Answer

Weed wacker worked fine a week ago. tried to start it up today and nothing happens. I followed step by step instructions and still got nothing. Only had it a year and only used it three times.


I have a two month old red max weedwacker that just decided to start shutting off when i give it gas. I hold idle no problem. Aircleaner=good, spark=checked, primer=good, dumped fuel and got same problem, I am upset because when redmax hit the scene with the backpacks they were solid. I just replaced a magneto on a year old red max blower and I am waiting on a crankshaft for a redmax set of gas shears: I hit a fence and in the past with other companies shears that was not a major problem. The redmax shears crankshaft broke and sheared two bolts of hardened steel on an irregular, recessed angle in the aluminum housing. After shelling out 450 bucks i am not the happy camper. I went old school and bought electric little wonders--know what: I forgot what a pleasure they were: light and no fumes. Any helpon the whip would be greatly appreciated. TOM 39 accounts long island ny

May 25, 2009 | Troy Bilt Tb70ss Gas Trimmer

1 Answer

New battery car wont start


may just be a loose terminal. I had mine replaced and it took a few hours before it ran right again. something about the electronic modules take a little time to recharge.

Apr 04, 2009 | 2003 GMC Yukon Denali

Not finding what you are looking for?
Air Tools & Compressors Logo

Related Topics:

79 people viewed this question

Ask a Question

Usually answered in minutes!

Top Air Tools & Compressors Experts

John Trevino

Level 3 Expert

1383 Answers

Joe Garcia
Joe Garcia

Level 2 Expert

205 Answers

Brad Brown

Level 3 Expert

15633 Answers

Are you an Air Tool and Compressor Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...