Question about Kenwood Excelon KAC-X811D Car Audio Amplifier

1 Answer

Kenwood kac X811d amp was shot by a positive wire and went off. What could have blown?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 70 Answers

Could be the board could be just some fuses on the amp and in the power wire sometimes it actually blows the computer on your car but rarely.

Posted on Aug 04, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a kenwood kac-9152d running a 10 inch rockford fosgate power t1 and the amp keeps going into protect but i have a smaller kenwood kac-8102d running on another t1 and i have no issues with it why...


either the wiring your running is short circuting,or the amp is shot, or the subwoofer is shot, try hooking the same speaker up to the other amp. along with the other speaker to the other amp, see if the same thing happens.

Feb 04, 2010 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

My kac-x811d shows a message "E-03" upon connecting the remote wire.


According to the Manual for the KAC-X811D, E-03 indicates that there is a short curcuit in the speaker wires.

Check that you dont have a short on the wires and also check your speakers.

Try disconnecting the speakers and the wires and then swith it on.

If it comes on without showing the error then connect the wires and speakers 1 at a time

Oct 20, 2009 | Kenwood Excelon KAC-X811D Car Audio...

1 Answer

My kenwood excelon KAC-X811D overheats after about 15 minutes and my fan won't turn on, i'm thinking either that or the ground wire being to small could be part of the problem. id really like to know how...


Hi was the fan running fine before overheating problems if so sounds like the fan has gone open amp up take fan out and take to a elec store for replacement

Oct 18, 2009 | Kenwood Excelon KAC-X811D Car Audio...

1 Answer

FLASHIN RED LIGHT AND SHOWIN E2


1st of all secure your subs/amps good. the tighter they are not only is it safer but your bass will hit harder cuz the box can't move and absorb any of the sound... As far as your amp, check the fuses on the amp. when your ground was disconnected it could have easily fried a protection fuse in the amp. To fix this simply replace the fuse with a new one of the same ampere rating, it shouldn't be hard to find. If all your fuses are good you'll have to see a service professional to fix your amp, or get a new one.

Aug 29, 2009 | Kenwood Excelon KAC-X811D Car Audio...

1 Answer

Kenwood Excelon KAC-X811D blinking e-03


Hello mogly20,

The amp probably won't know if it's you or the homeless guy, so try smashing a glass bottle on it like he did. If that doesn't work, I'd recommend you locate another homeless guy and buy another amp.

Hope this helps.

Aug 08, 2009 | Kenwood Excelon KAC-X521 Car Audio...

1 Answer

Blinking E-03


somthing is fried on your motherboard

Apr 28, 2009 | Kenwood Excelon KAC-X811D Car Audio...

1 Answer

My amp is turning on but!!!


you probably blew it up. Whenever you smell that smell it is almost always a capacitor in there that blew.

Jun 17, 2007 | Kenwood Excelon KAC-X521 Car Audio...

2 Answers

Amp reading E-03


the manual say it means that the speaker cord is shorted, or when the speaker output is in contact with the vehicle ground, i hope you can solve the problem with the info i just gave. good luck

Oct 04, 2006 | Kenwood Excelon KAC-X811D Car Audio...

Not finding what you are looking for?
Kenwood Excelon KAC-X811D Car Audio Amplifier Logo

Related Topics:

114 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4862 Answers

yadayada
yadayada

Level 3 Expert

76164 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...