Question about Yamaha 12V Air Pump

1 Answer

I have a 1999 1200XL Waverunner and while riding it lost 1/2 its power. I changed the spark plugs in it they looked pretty worn. But I can only get 1/2 the power. It takes off great for a few minutes when sitting for a while but then slows right down. It sound it makes when I exclerate is as if it is skipping a gear very few seconds

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers

Always good to start with a compression test to make sure the cylinders haven't lost compression (power). If all are equal and above 100psi you are good. It may be a cavitation problem... (too much air leakage into the jet pump) a gasket kit may resolve this issue if it is over reving on accelleration.

Posted on Aug 27, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Help with 92 waverunner 650 no spark issue


Hi, Banjomaniac and the usual suspects are:
1. Fouled spark plugs.
2. Severely discharged or a damaged battery, should have 12.5 volts or better and be able to pass a load test if necessary.
3. Check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
4. Loose connection at ignition coil or plug between ignition sensor and module.
5. Spark plug cables in bad condition, shorting / leaking, spark plug cable connections loose.
6. Faulty ignition coil or electronic control module or CDI box.
7. Faulty CKP, CMP, or BAS sensor.
8. Faulty ignition switch.
9. Tilt sensor needs a reset.
10. Security alarm failing to disarm needs reset
For more information about your issue and valuable "FREE" downloads that you will need please click on the links below. Good luck and have a nice day.
Thread Waverunner No Spark
1991 waverunner III 650 turns over no spark won start Want to fix for the...
Jet ski 91 Yamaha wave runner 650 with no spark need some
http://www.yamaha-motor.com/assets/service/manuals/1998/LIT-18626-03-05_371.pdf

Aug 01, 2016 | Motorcycles

1 Answer

Yamaha waverunner won't idle and losing power


L stands for limp mode
it is a mode that the ECM selects to prevent serious damage to the engine ( from you lack of oil )
have the fault codes read then reset with the scan tool

Mar 31, 2017 | Water Sport

1 Answer

KTM 105 SX spark plug fails every ride???


Hi, Sagi nice novella and the usual suspects are:
1. Fuel mixture too rich or enrichner left out too long.
2. Faulty spark plug.
3. Incorrect spark plug for the engine type or service.
4. Piston rings badly worn or broken.
5. Valve guides are badly worn and/or seals worn, crushed or have come off the valve guide and are pumping oil through it.
6. Spark plug cable weak or leaking check for spark jump in the dark.
7. Faulty ignition coil.
For more information about your issue and valuable "FREE" downloads that you will need please click on the blue links below. Good luck and have a wonderful day.
http://www.ktmforums.com/forums/two-strokes/1966-solution-fouling-spark-plugs.html
Why Does My Dirt Bike Keep Fouling Spark Plugs
KTM 85sx 105sx service manual repair 2004 2009 85 sx 105 sx Download... $8 cheap
http://www.partsfish.com/page/oem-parts-for-ktm
KTM 85 105 SX Owner Manual

Mar 11, 2017 | 2007 KTM SX 105

1 Answer

Installed new engine now wont fire from distributor to spark plugs.


If you've got spark from the coil but not at the spark plugs, it can only be 1 of 3 things.
  • Bad spark plugs or plugs not gapped properly.
  • Bad spark plug wires.
  • Bad distributor cap and rotor. This is pretty easy to check. Open up the cap and look at the points on the underside of the cap and also the point on the rotor. If they look corroded or worn, then you should replace them.

Good Luck!
~Brandon

May 29, 2011 | 1994 Nissan Pickup

1 Answer

YAMAHA WAVERUNNER 2000 XL 800, WILL NOT RUN PAST 12 MPH


Have you done a compression test on all cylinders? My guess is you have a dead cylinder (no oil to one or more cylinders causing loss of power). If the compression test passes (all cylinders equal and higher than 100-110 psi) you have a restricted exhaust from a failed catalytic converter that has broken apart.

Apr 05, 2010 | 2003 Yamaha YZ 250

1 Answer

Yamaha fzr250rr 88' i was out riding and lost power and wouldnt idle could only ride in gears up to 4th i check the plugs spark to no.1 sparkplug no spark at 2-3 and light orange spark at 4 spark plug wont...


check your distributor unit or as they call it on my honda 87cbr, a pulse generator. You can switch coils around (if they are exactly the same!).. see if problem is now opposite!...if it changed... well its new coil time. but my problem wasnt the coils which i was almost positive it was because i wasnt getting any spark to #1 or #4 ...i didnt check 2-3 but im sure it wasnt getting any spark either because the bike wouldnt even hint at starting. it cost me two hours of trouble shooting and $50 for the used part...starts right up now everytime...hopes this helps.
Can i get a rating too...thanks!

Oct 03, 2009 | 1989 Yamaha FZR 250 R

2 Answers

I have a 2003 yamaha 700 waverunner. It starts


if u did any modifactions to the air intake than that could be a reason.

Jul 23, 2009 | Water Sport

1 Answer

Waverunner sat for 4 months. thought battery was


Try jumping the waverunner using a set of jumper cables and your vehicle, this will rule out if the battery is bad. If you still have the same issue, check the connections. The connection at the starter or another place may have corroded a bit. Yet another option is to remove your spark plugs to make sure that your motor has not hydraulically locked. Once you have removed the plugs try and turn over the engine. You may need to ground out your plug wires if you have an electronic ignition to protect it. I hope this helps.

Jul 13, 2009 | Sport & Outdoor - Others

Not finding what you are looking for?
Yamaha 12V Air Pump Logo

Related Topics:

220 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha Water Sport Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Piyal Perera
Piyal Perera

Level 3 Expert

528 Answers

Are you a Yamaha Water Sport Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...