Question about Lanzar Vibe 218 Car Audio Amplifier

1 Answer

Amp is wired but power light not comin on

Hi, i recently hooked up my amp. the power light is not comin on and the subwoofers are not powering on. I decided to open up the back up and I see where something on the inside looked burned. I'm guessing this is the source of the problem. I dont know the name of the part burnt out but it is located on the sides, and there are several of them on both sides. It looks like a silver bar that is screwed in holding down two pieces of metal... Please help

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 70 Answers

It might be cheaper to just buy a new amp then to fix it cause i would go for MTX or coustic cause its almost the same company. Coustic is made by MTX and the price is good for the quality.

Posted on Aug 03, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Technician can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Technician (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a pioneer gm-354 amp and the power indicater light on the front has changed from solid to flashing and no sound from the amp to the subwoofer it used to power any idea's


If it is flashing it went into the protect mode.Check that a speaker wire hasn,t come off, Or that the ground cable conection is good end all other hook up wires to it.

Oct 27, 2012 | Pioneer GM-X354 Car Audio Amplifier

1 Answer

My Jl Audio 500/1, power light comes on but no power to subs


maybe it dont have enough to push it ,,did you try it before you buy it?

Mar 01, 2010 | Jl Audio 500/1 Car Audio Amplifier

2 Answers

Im trying hook up a subwoofer to my reciever and its getting power to the amp, however the amp is not powering on.. do you have any idea?


did you hook up the power antenna or amp. turn On wire? make sure you should ha a wire that is to power an antenna and this is the wire that has 12 volts as soon you turn On your stereo and send 12 volts to your amp. but if you don't connect this wire, the amp will never turns On

Jan 04, 2010 | Kenwood KDC-MP438U Car CD/ MP3 Player

1 Answer

Crossover issues?


if only highs are comin through subwoofer then check pf switch on amp then adjust crossover frequency to 80hz hope this helps

Apr 28, 2009 | Infinity 475A Car Audio Amplifier

1 Answer

Green light, No Power


Disconnect the remote wire and make a jumper at the amp from the 12v + to the remote input and see if you get the same results. If yes, then you probably have a bad ground point. It might not be able to handle the transfer load it's receiveing. If no, then you have an issue with your remote wire or power wire. Check for any kinks or pinches in the wire.

Jan 25, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Subwoofer out problem


Thats an installation error. I'm almost 100% sure whoever hooked up your amplifier hooked the amp turn on to your power antenna wire. If there is no amp turn on wire, the accessory wire will do.

Dec 31, 2008 | Clarion Car Audio & Video

1 Answer

Hi, I've just install an alpine power amp with JL 10inch subwoofer, everything seems to be working properly except for the subwoofer


If you have the RCA's running from the head unit to the amp, and the speaker wires running to the speakers then you have it hooked up right. Now If you still don't have any sound then you need to look at the amp to make sure that you have a green light. Still I would use 8 or 10 gauge power wire and then the same for the ground wire, make sure that you have a good ground.

Freakville03

Dec 21, 2008 | Alpine MRP-F250 Car Audio Amplifier

1 Answer

Not working


maybe you should use 4 awg wire

Jun 24, 2008 | Rockford Fosgate Punch P5002 Car Audio...

2 Answers

Installing The Subwoofers to the amp... etc.


You should go with a 4 guage power wire kit. If your amp is going in and out
at high volume than that is your problem. 8 guage will work but, if you want
the proper current which is your power from your battery, going to your amp
than I would recomend the 4 guage amp install kit or just the main power
wire coming from your battery. If you would like contact me and I will send you
to a very good sight with all the info you will ever need for car amplifire installation.

Apr 21, 2008 | Insignia 600W Bridgeable Amplifier with...

Not finding what you are looking for?
Lanzar Vibe 218 Car Audio Amplifier Logo

Related Topics:

56 people viewed this question

Ask a Question

Usually answered in minutes!

Top Lanzar Car Audio & Video Experts

Joe Alexander
Joe Alexander

Level 2 Expert

65 Answers

Chris Ward

Level 2 Expert

158 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Lanzar Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...