Question about Boss AUDIO SYSTEMS D8002 Car Audio Amplifier

1 Answer

What size blade fuse would I need for my D800.2 Boss amplifier? I took it to a shop to work on my music system ,and for some reason they threw away the fuse. I don't remember what size was in the single fuse slot before.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 4 Answers

You need a 30 amp fuse according to Boss Audio's owners manual.
http://www.bossaudio.com/support/index.php?_m=downloads&_a=viewdownload&downloaditemid=564&nav=0,2

Posted on Aug 02, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

After 7 yrs of use, it just stopped working


I agree that It could be one of the other reasons listed here.....

But, I had the same problem with a 1,000 watt Kenwood amplifier and it worked like a boss for the whole two years that I had it and then one day the box that I had my subs in somehow came apart and after I changed out boxes the amp quit working. It came on but it wouldn't work anymore except for when I turned it a certain way or sat it against something.. Anyway it ended up being a loose female port plug on the inside where the auxilary cables plug up.

Hope it helps.

May 11, 2013 | Clarion APA4320 Car Audio Amplifier

1 Answer

800 watt mono block sony xplod amp blowing my dual coil 1500 watt subs


if the wiring to the sub is correct, then you have something wrong with the amp itself... something is power surging to the subs which is causing them to blow

Aug 25, 2012 | Car Audio & Video

1 Answer

What size fuses do i need for the 3 slots and im blowing the power fuse its all hooked up right


  • A Metrik MAX-1404 Amp requires 3 20 Amp Maxi Blade Fuses yellow in color.

Regards, Tony

May 23, 2011 | Metrik Amplifiers MAX-1404 Car Audio...

1 Answer

I have a boss s120.5a 12" sub with 5 channel 3000


Check the power pack and the fuse to make sure the are working but if the are not okay then take the car audio amplifier to audio mechanic.

Jan 22, 2011 | Boss gt580 - GT580 1000W 2 Channel MOSFET...

1 Answer

Blown fuse


Continued replacement of fuses without fixing the reason for them blowing MAY be doing additional damage to components in the unit.

It needs to go to a repair shop. It is likely there is damage in the power supply section or that of the power amplifier section.

Feb 28, 2010 | Marshall MG100HDFX 100-Watt Amplifier Head

1 Answer

Boss noise reduction pedal stopped working for no reason at all. worked fine the day before, went to use today no power at all. it is run from an adaptor so its not the battery, any clue?


The power jack on MANY of the pedals are weak and a yank sideways can damage the jack or the board it is mounted on.

ANOOTHER problem is using an adapter with the wrong size plug. SOME plugs have a larger diameter hole and will work intermittenly.

Oct 05, 2009 | BOSS AUDIO SYSTEMS Boss Ns2 Noise...

1 Answer

Channels Not Playing


i had afriend who is atechnician. his boss amplifier stopped working on one channel,so what he did is openened the amp,tested the mosfet transistors and it showed signs of failure.then he went shopping for same type of mosfet transistors and with no luck in buying the right type, he put the amp away for acouple of weeks. then one day he hooked it up and strangely it worked again. he told me that while it was hooked up itwent into protection mode and for some reason it worked later. so i would not open it because of static discharge i would disconnect the amp for maybe acouple of weeks then hook it back up.... its worth a try & good luck

Nov 10, 2006 | Boss C350 Car Audio Amplifier

Not finding what you are looking for?
Boss AUDIO SYSTEMS D8002 Car Audio Amplifier Logo

Related Topics:

159 people viewed this question

Ask a Question

Usually answered in minutes!

Top Boss Car Audio & Video Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

xxxxxx xxx

Level 3 Expert

4862 Answers

The Knight
The Knight

Level 3 Expert

74251 Answers

Are you a Boss Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...