Question about Harley Davidson 426290 AM/FM Radio

2 Answers

Radio comes on just fine. But no sound coming from speakers? I was riding my bike down the road and the sound just stopped. I turned the unit off and turned it on again and it came back on just fine. Went a few more miles down the road and it shut off again. The intervals became more frequent(on/off) and now sitting still. The unit is on, The cd is tracking but no sound from the speakers. Help!!!

Posted by on

  • houslekd Aug 01, 2010

    The first solution was made sense except for the fact that in my experience when the amplifier goes bad the result is poor sound quality and that is not the case. My unit is on and there is nothing coming from the speakers. . .No crackling sounds. . Nothing. Speakers are dead.

×

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 360 Answers

Hi, most likely vibration from the bike caused damage to the radios audio circuit. Speaker wires are contained in the 23 pin wiring harness. if the harness came loose, you would loose the entire radio, wires then go to the individual speakers.

Contact Iron Cross Audio for repair options. www.ironcrossaudio.com

Take care


Posted on Aug 01, 2010

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 6,826 Answers

Sounds like the amplifier is slowly getting worse over time. May want to have it serviced, repaired, or ultimately replaced if the other options are not available.

I had the same problem in my 1990 Cadillac, only it popped and would play out of some speakers but not all, and eventually I replaced the radio with a new one.

Posted on Aug 01, 2010

  • 1 more comment 
  • houslekd Aug 01, 2010

    Are we talking the entire Unit or a seperate entity? I'm thinking the amp is located in the unit? When the radio comes on it plays great? I would think if the amp was the problem I would hear poor sound quality and the like?

  • Duane Wong
    Duane Wong Aug 01, 2010

    Many radios have the built in amp that can fail intermittently if there's a bad component on it. The board could be cracked causing a bad internal connection that makes it work on and off depending on heat conditions inside the unit.



    Everything may be fine with the radio's built in amp, but it may fail due to the defect on the printed circuit board. Sometimes it will work fine, and other times it will not depending on a number of heat related factors.



    It's a quality control issue, I guess. If it's under warranty you might be able to get it fixed or replaced for free, but I'm not sure about that part. You'll have to check your records for when you bought the unit. Did it come with the bike?

  • Duane Wong
    Duane Wong Aug 01, 2010

    I had to deal with a bad amplifier in my radio for months trying to guess what it was, but it turned out that when I changed the 'black box' or the entire radio, the problem was solved.



    I wish you luck in repairing your radio or replacing it.

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Technician can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Technician (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2008 harley ultra classic


Switch is fine. You have a damaged audio circuit caused by vibration. Check the bikes mounting brackets. probably broken. The radio will need to be repaired. www.ironcrossaudio.com

May 27, 2014 | Harley Davidson 426290 AM/FM Radio

1 Answer

On my 2008 flhtcu my radio will be working fine then speakers will stop working [no sound]i will turn rocker switch off then on & some times the sound will come on.i think its a bad rocker switch but i'm...


Hi S.Vale, switch could be a contributing factor, take it out of the housing and inspect it for loose or broken connections also inspect the spring pressure on the toggle for adaquacy and the toggle contacts, sometimes they get contaminated by excessive grease and dirt. If no luck ride the bike over to your local dealer and strike up a friendly conversation with someone in service. Good luck

Oct 01, 2013 | 2008 Harley Davidson FLHTCU Ultra Classic...

1 Answer

2003 HD Road King - starts fine, idle normal. Once it is warm, idles at 2000 rpm. Does not come back down, even after riding for an hour or two. Only idles normal when cold. Help??


If you bike is equipped with a carburetor, the idle stop screw is located at the top of the carb on the right side. Counterclockwise turn slows the idle speed.

If you bike is fuel injected, a dealer or shop will have to set the idle speed electronically.

Good Luck
Steve

Sep 16, 2010 | 2003 Harley Davidson FLHRCI Road King...

1 Answer

Cd plays when bike is on ,but when you start the motor it doesn't play . and when your riding down the rode the speakers crackle , but doesn't do it when your standing still . whats wrong .the speakers are...


When starting the bike, the starter relay pulls in to divert power to the starter solenoid. To insure that the solenoid gets all the power it needs, the accessories on the bike are turned off momentarily. Once the bike is running, they come back on. The "crackle" sounds like it might be interference from something on the bike, nothing wrong with the speakers or it would make the sound all the time. It's probably pickiing up the impulses generated by the speedometer or something when when the bike is moving but is not doing anything when you're standing still. A dealer may can find it or you can disconnect various accessories and take a ride down the road to see if the interference stops. Once you determine what is causeing the interference, then you'll have to figure out how to stop the interference from affecting your speakers.

Good Luck
Steve

Aug 11, 2010 | 2000 Harley Davidson FLHTCUI Electra Glide...

2 Answers

Radio working just fine But no sound coming from speakers


if the radio still has power the audio amplifier ic in your radio has failed.
take your radio to an electronics repair shop or, replace the radio; this not something you can fix unless you know how to use an oscilloscope.

Aug 01, 2010 | Harley Davidson 426290 AM/FM Radio

1 Answer

06 ultra radio no sound from speakers only headset.


Switch is fine. You have a damaged audio circuit caused by vibration. Check the bikes mounting brackets. probably broken. The radio will need to be repaired. www.ironcrossaudio.com

Apr 21, 2009 | Harley Davidson 426290 AM/FM Radio

1 Answer

1996 chevy blazer radio turns on but there is no sound


I have a strong feeling that the head unit "radio" has finally gone bad. You describe a situation, in which you have to turn it on and off, to get it to work. Typically if the sound comes out of all speakers, after doing that, then the speakers were never broken. The head unit itself should be replaced. I hope this helps.

Nov 16, 2008 | 1996 Chevrolet Blazer

1 Answer

Need help


If your radio and phone are synced up together, it probably muted the radio when the call came in then didn't un-mute. I'd try to reset the radio (disconnect the power for maybe 10 minutes) and try it then.

Oct 07, 2008 | Jl Audio 1000/1 Car Audio Amplifier

2 Answers

Power, but no sound coming from my speakers, checked fuses.


i have power but no sound it worked fine for a little while yesterday but it stopped whats wrong wit it

Mar 04, 2008 | Onkyo HT-SR700 System

Not finding what you are looking for?
Harley Davidson 426290 AM/FM Radio Logo

Related Topics:

79 people viewed this question

Ask a Question

Usually answered in minutes!

Top Harley Davidson Audio Players & Recorders Experts

Jim Goldsmith
Jim Goldsmith

Level 3 Expert

1906 Answers

Stephen Burdy

Level 1 Expert

7 Answers

xxxxxx xxx

Level 3 Expert

4885 Answers

Are you a Harley Davidson Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...