Question about Rockford Fosgate Punch Stage P115 S4 Car Subwoofer

1 Answer

So my subs just got hooked up in a new car yesterday and they were both going strong for a bit, then one just stopped working after about an hour but i thought it was just loose wiring and decide to fix it later. then this morning i went to figure out what the problem was and the other one stopped working too but there's nothing wrong with any of the wires or fuses. what do you think my problem is?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

    Governor:

    An expert whose answer got voted for 20 times.

  • Expert
  • 170 Answers

Speakers are like shoes, they have to be worn in. you cant buy new speakers and them slam them as hard as you want as soon as you get em. you burned the voice coil up and they are real pretty fishing weights now. Sorry bout your bad luck bro.

Posted on Jul 31, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kenwoodxw1000f shut off after 10 sec


the problem sounds like your new sub is drawing to much power and your amp can not handle it. bridging the amp is a good way to get the full power out of your amp. But it isnt always suggested, my solution is to get a bigger amp. I install stereo systems for a living, and i tell my customers that it is smart to get an amp about 100 more watts then the rms rating of your subwoofer.

Feb 13, 2010 | Kenwood eXcelon KFC-XW1000F Car Subwoofer

1 Answer

94 Jeep wont start running after 3 seconds.


It could be the security system or maybe a crank sensor.

Jan 04, 2010 | 1993 Jeep Grand Cherokee

1 Answer

I have a brand new L7 is it blown?


check to make sure your box is securely sealed and that the box itself is not rattling. if not, most subs require a break in period where they can not be played full gain/full volume for the first 48 or so hours... did you break in your subs by paying it softly the first day and slowly turning your amps gain and receivers volume up the next couple of days. if not, it is likely blown

Oct 07, 2009 | Kicker Solo-Baric L7 S15L72 Car Subwoofer

1 Answer

PHOENIX GOLD RYVAL V1502


Most the time want happens is the postive wire is not the right gauge or the amp cant handle pusing two speakers you m have to put in two amps try hooking up one sub and see want happens if it dosent die out the amp not strong enough for the 2

Jul 08, 2009 | Car Audio & Video

2 Answers

My subs don't bump to the beat, they just go THUMP THUMP THUMP...


It sounds like you need to ask for pro help mate, mybe the amp just needs setting properly, Is the amp on bypass for bass, or does the amp run the complete system

Jun 13, 2009 | Cadence TXA 750D High Power Mono Amplifier...

1 Answer

Ma audio hk 4000d


you have definately blown a output channel, or power supply. Send it in for warranty.

Jan 09, 2009 | MA Audio HK4000D Car Audio Amplifier

1 Answer

Kenwood KAC-8401 light goes from blue to red when turned on


Either the amp is ad or the sub got shorted? You can check itby disconnecting the Sub and seeing if the amp comes on blue then. If yes, then the sub is shorted. If no, then the amp is shorted. Also chck the voltage AT THE AMP. Make sure that it is above 12 Volts.

Larry T
Winona Lake, IN
http://www.cybersoundsaudio.com/cybersounds/vehiclepics.html

Dec 29, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Running rough


I would check sparkplugs, plug wires, vacuum hoses to map sensor, check to see if exhaust is strong out pipe, may be a catalytic convertor stopped up , bad O2 sensor will cause starting and idling problems.

May 15, 2017 | 1999 Ford F150 Regular Cab

3 Answers

Kicker 750.1 Amp wont play music


it is probably the rca inputs on the amp may have fried. was your cd decked turned up loudly before the power went out? did any wires accidently touch each other? If had worked fine and then suddenly stopped, than either a wire came loose or the inputs fried. try using different cables and I also suggest disconnecting power for 24 hours and then reconnect. If the green light is on then it is getting power and the problem is in the rca cables or the inputs

Jun 03, 2008 | Kicker 06ZX750.1 Car Audio Amplifier

Not finding what you are looking for?
Rockford Fosgate Punch Stage P115 S4 Car Subwoofer Logo

180 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rockford Fosgate Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Professor_V
Professor_V

Level 2 Expert

92 Answers

Robert Rankin

Level 2 Expert

341 Answers

Are you a Rockford Fosgate Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...