Question about Crate FlexWave FW15 Guitar Amp Combo, 15 Watt Single 8 Speaker

1 Answer

I have a Crate RFX120 that turns on but only puts out a weak, almost inaudible sound when I plug in... when I plug in to the insert of the back panel I get a nice tone at a pretty good volume. I know nothing about amplifiers or electronics, but I can assemble/disassemble most things. I just have no clue where to start my search... Any suggestions are WELCOME.

Posted by on

  • arclark1144 Jul 29, 2010

    thanks man..
    seems a little overwhelming since this is the first time i've ever gutted an amp, but now that it's narrowed down I feel so much more comfortable.

    again, thank you!

  • arclark1144 Jul 29, 2010

    thanks man..
    seems a little overwhelming since this is the first time i've ever gutted an amp, but now that it's narrowed down I feel so much more comfortable.

    again, thank you!

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 11,800 Answers

The sound circuit on your system is like this:
1 = on guitar : pickup - signal potentiometer - signal tone potentiometer - plug. Simple test : plug the guitar in another amplifier to test it.
2 = on your amplifier : plug - preamplifier - volume control - reverb system - final amplifier. Since you get a good volume otherwise then the problem is before the final amplifier. Start by checking the cable with an ohmmeter for breaks and replace it if necessary.To test the rest you must dismantle it and access the components: start by shorting the potentiometer (center plot/signal input to the signal output) - the volume should go to the max. Then check that the preamp is working by touching the input wire - the brum should be clearly audible. Finally check the power source, the voltage on one of its power rails might be down and the preamp might not be powered.

Posted on Jul 29, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Crate gtx212 mute circuit (Q24 across IC4A pins 1 and 2) should go positive on the gate when a plug is inserted.


Looks like Q24 changes the gain at IC4-A from low with no input jack to normal gain with a jack inserted. Since this appears to be a guitar amp that expects a floating input plug any connection at the input to say, a mixer etc may cause a re-grounding via that equipment's circuits, thus negating the auto mute...... eggs & suck :-) If using a moving coil meter it could upset things.... an interesting fault! Sorry I can't be more help - Good luck!

Feb 11, 2017 | Crate Music

1 Answer

Crate bv120h weakness.


bad wires or fuse or connections

Jan 05, 2013 | Music

1 Answer

Buzz across all channels in crate rfx120


I also have this issue. Same crate combo amp. There is a loud buzz emitted only when there is a cable plugged in. Cables and instruments checked good, only possible issue is inside the input of the amp. Popped it open, solders and connections were intact and appeared solid. Anyone have a guess as to why this is happening?

Feb 12, 2012 | Crate Music

1 Answer

Is there a fuse in this amp? is it replaceable without soldering?


Hi, blowing a fuse in an amplifier is a problem that most guitarists face at one time or another. If an amp won't turn on, or it turns on for a second, then makes a popping sound and turns off, the problem is usually a blown fuse. Though a blown fuse can be a hassle, especially during a performance, it does not have to put a stop to your musical enjoyment. With a spare fuse you can be back jamming to your favorite tunes in no time flat.

Things You'll Need

Fuse.

Instructions

Turn off the amplifier and unplug it from the wall.

Locate the fuse, which is usually found at the back of the amp. The fuse will look like a small black wheel sticking out of the amp with a number and the letter V next to it. For example, 9V.

Gently turn the fuse counter-clockwise to remove it from the amp.

Discard the old fuse.

Insert the new fuse into the empty fuse slot and turn it clockwise until it is firmly in place.

Plug in the amplifier; make sure the power switch is in the off position.

Turn the amplifier on to make sure the new fuse is working properly.



Hope it helped..

Jun 14, 2011 | Crate FlexWave FW15 Guitar Amp Combo, 15...

1 Answer

Crate TX50 DB has noisy DSP circuit when rotating the DSP pot!


When you are changing the DSP effect on the fly, static or noise is NORMAL !!! The DSP is changing the data and having to recalculate on the fly and doesn't mute itself while doing so which results in "garbage sounds out".

The bypass setting should NOT get any tone UNLESS you have feedback going on. If your guitar can "hear" the speakers in the amp, the strings can vibrate and get feedback going.

Unplug the guitar and see if high freq tone is still there on bypass. If the tone is in the musical range, then there is a problem if nothing is plugged in. If it is a VERY weak, very high frequency tone, this may be the digitizing noise from the DSP. On bypass, the audio is likely to still go through the DSP, just not be modified by it.

May 03, 2010 | Crate FlexWave FW15 Guitar Amp Combo, 15...

1 Answer

I have a small crate rx15 solid state amp. The power light comes on, but no sound comes out of either the amp or headphone jack. No buzz etc....


Power light means very little. If unit has a preamp output, plug a set of headphones into it and see if you can hear anythin going through. (it will be weak). If you can, the power amp section is bad. Take in for service.

Mar 29, 2010 | Crate Music

1 Answer

I have a crate cpb150 amp i want to connect it to my digitech gsp2101 via livewire stp-202 cable what is the correct way?


I can understand your confusion... and a lot depends how you are going to use this. There are some caveats regarding the connections,
If you use the 1/4 outputs on the GSP, there is a speaker modeling like function that is NOT available, that IS available IF you use the XLR outputs.
The STP is an "Insert Snake" which is not really what you want as it is intended to send and receive (audio going both directions in the cable.
If you want that speaker function, then you should get two XLR to 1/4 TRS cables and go from the XLR's on the GSP to the Left and Right inputs on the back of the Crate. Your audio or guitar then is connected to the GSP guitar input.
If you connect the guitar to the crate and then use the STP, Plug the TRS single connector into the Left/Mono/send/rtn on the Crate. The Send cable of the Y should go to the Send jack on the back of the GSP and the return should go to the left return jack of the GSP. This connection I would NOT recommend as it will be noisier and you will lose the stereo effect capabiltiy since the effect is inserted as a mono.

I believe you would be happier with using the XLR's to carry left and right to the Crate and run your inout to the GSP. In short, you have the wrong cable to do the best job.

Jan 30, 2010 | Crate Music

1 Answer

No sound from speaker, but works with external speaker plugged in


It sounds to me like you have blown the internal speaker.

Jun 17, 2009 | Music

1 Answer

My acoustic guitar sounds choppy when played back.


Try Using A Condenser Mic Or Making Sure That Your Phantom Power Is Turned Off When Using A Regular Mic.\www.Myspace.com/CrossRoadsToNowhere2007

Nov 06, 2008 | Boss Micro BR Digital Recorder

Not finding what you are looking for?
Crate FlexWave FW15 Guitar Amp Combo, 15 Watt Single 8 Speaker Logo

Related Topics:

183 people viewed this question

Ask a Question

Usually answered in minutes!

Top Crate Music Experts

rjivaro

Level 2 Expert

153 Answers

Michial Gueffroy

Level 3 Expert

1138 Answers

Ben Armstrong

Level 2 Expert

357 Answers

Are you a Crate Music Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...