Question about Yamaha DSP-A1000 5-Channel Amplifier

1 Answer

Su-x501manual I am woundering if they is any site that has the manual for the amp su-x501

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 10 Answers

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Su-x501 turning off intermitently


If your unit is intermittent, check the speaker wires on the back of the amplifier for stray threads of wire, next! the printed circuit board underneath should be checked for bad or cracked solder joints, finally one more parts are defective, tough problem to nail down, recommend technician.

Jul 08, 2012 | Technics Amplifiers & Preamps

2 Answers

I need an Operator Manual for a Technics Amplifier SU-600


HI,
I have the User manual of Technics SU-600 in pdf format. If you can sent your email address the i will sent you the manual.Its not possible to sent the manual through this site as it is a pdf file.
OK

Oct 26, 2011 | Technics SUV500 2-Channel Amplifier

1 Answer

Techics new class A digital integrated amplifier SU-X501. Unit switches itself off after a short while when playing cd or records? Any ideas why?


Is this happening in a regular pattern. If so please check from the mains power section.Check from the plug, the socket, use another outlet if possible to check. If the faultt recurrs, then you willneed to open the set when it trips off, check all the connectors, the main PCB for any signs of bad joints caused by dry soldering in heating sections. If so use a good iron to resolder these sections bbut attempt only if your familiar with these circuits. Next notice if there is any excessive heating when it is cutting off, if so reduce the treble and bass to confirm any transcient noise running the amp.Use another source to recheck if the noise is coming from the present one. I hope this helps. Good day

Jun 14, 2010 | Technics Amplifiers & Preamps

1 Answer

I want to no how to wire the hole system up just picture diagram SU-X501


This appears to be a tough one to find for free. There is some info out there - but it will cost a few bucks. The service manual or sometimes called a "shop manual" is for those that work on damaged units - and is probably over the top for your needs. The operating manual or owner's manual is likely the same as the one that came with the unit when new. Either can be had at the site below for $15 and $10 respectively:

http://www.manuals-in-pdf.com/index.php?main_page=advanced_search_result&keyword=Technics+SU-X501+manual&forward=plist

I am not affiliated with this or any other site that charges for manuals, tips, advice, etc.; and only offer it as a source for the info you're looking for. I hope this helps!

Jun 11, 2010 | Technics SUV500 2-Channel Amplifier

2 Answers

I need a cooling fan for my su g50 where can I get one web site maby


The fan assembly can be purchased from tritronicsinc,com (use the guest account) for $24.31 using part number SYE1128-4


Dan

Jul 11, 2009 | Technics Amplifiers & Preamps

1 Answer

Need to replace my Technics SU-X501 Amplifier.....HELP!!!!


its better to buy desame brand of your unit for compatibility sake...

Jun 19, 2008 | Amplifiers & Preamps

2 Answers

Technics su-v45a


Hi ferrariman

For sure, even though a manual is a bit hard to find for free, we may be able to help you solve the problem. I have worked on alot of technics amps over the years. What is happening to the amp?

regards
robotek

May 14, 2008 | Amplifiers & Preamps

1 Answer

Sound from one speaker only.


your output stage had a problem in electronic output device and must be maintained in service center.

Nov 03, 2007 | Amplifiers & Preamps

1 Answer

Channel has switched off.


Make shure speaker wires are not crossed at amp or at speaker terminals. Check balance control is at center. Check sound with headphones to see if final amp to speakers is the problem. Try switching imputs on back panel from right to left see if same speaker is on,.Try all loudness controls and tape dubbing buttons to see if any are dirty.
Good Luck
BIG RED

Nov 03, 2007 | Amplifiers & Preamps

Not finding what you are looking for?
Yamaha DSP-A1000 5-Channel Amplifier Logo

Related Topics:

358 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha Amplifiers & Preamps Experts

 Grubhead
Grubhead

Level 3 Expert

4584 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

68223 Answers

Are you a Yamaha Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...