Question about Vacuums

2 Answers

We have a Kenmore Stylite Retrax vacuum cleaner, brand new. Suction is not working properly.

Posted by on

  • 4 more comments 
  • Anonymous Jun 05, 2008

    The suction comes and goes. I constantly clean the filter (almost ridiculous) It just suddenly shut off, I turned it over, cleaned out any lint, hair, etc. Brand new and won't start.

  • mccabes5 Jul 22, 2008

    I have the exact same problem. I've only had it for a few months and it just turns itself off and won't start again for a day or 2 and then only runs for about 2 minutes before shutting itself off again.

  • Anonymous Jul 25, 2008

    I have the same problem - it seems that the fine mesh filter at the top of the "waste bucket" gets clogged.  If I scrape off the fine dust film that accumulates there, it works again -- only to have the same problem within minutes.  I can't even get through one room without it losing suction.  I am calling Sears next week to see if they will take it back or suggest a solution.  Ugh!

  • janbaby02 Apr 02, 2009

    Same problem....when I try to use the hose I get no suction whatsoever. I am disgusted. I've only used it a half dozen times.

  • Anonymous Apr 20, 2009

    I will not be buying bagless vacuums anymore! Same stupid problem!

  • Anonymous May 12, 2009

    junk, junk, junk! funny smell. no suction. musty smell. kicks back dirt. we traded it in for a hoover w/bag.

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

I actually pulled back my old vac after using this thing. Having said that I have played around with it and one quick cure is the remove or clean the little circle sponge filter at bottom. If you remove the canister and look at the bottom of vac you will see where the air travels down through a small circle. In there is a sponge filter that is probably clogged. Now Being frustrated, I just removed it and the vac sucks like crazy now. There are just way to many filters to worry about. As mentioned you need to clean the top main filiter, then the top sponge filter, and then dont froget there is alson one in the front of the machine (square paper filter) that catches dust leaving vac. These are on top of the little circle one that I removed, so I dont think it will be missed. Try and see what you think.

Posted on Nov 12, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Lost suction. I bought the vac as reconditioned and did not have an instruction book. I cleaned the top foam filter and knocked the dirt out of the top pleated paper filter and it works great now. I like this vac because it doesn't get dog hair all wrapped around the beater bar. I have two Shetland sheepdogs, so this is a real problem. It says clean the sponge filter after each use? I did it before and after. It was pretty clogged up. I think I have worse than average person's dirt in my house.

Posted on Aug 28, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Brand new dyson DC40 has no suction at bottom


Hi Marin, it's Jack at Dyson.

DC40 is a powerful mid-size Dyson upright vacuums, and we wouldn't expect you to have any concerns about performance on hard flooring or carpet. As long as the machine is used and maintained as described in the User guide we would not anticipate a change in performance, and we're on hand to help if Dyson owners need assistance.

It's important to note that for effective pickup, the cleaner head needs to form a close seal with the floor surface. Simply placing a hand under the cleaner head does not give an accurate idea of suction as you're not creating a seal, as you would be when you place your hand right across the end of the wand or hose. If you turn on and recline the vacuum, turn off the brush bar then lower the cleaner head onto something like a sheet of newspaper, you should see the newspaper held tightly against the soleplate by the vacuum's powerful suction.

We're keen to discuss this with you, and to help ensure your DC40 is working as well as it should be. Please email your full contact details to my colleagues at askdysonUS@dyson.com, and one of our experts will be in touch as soon as possible to provide further assistance.

Feb 14, 2015 | Dyson DC40 Animal Upright Vacuum -...

1 Answer

Hose does not dispense cleaning solution, and the cleaner solution will immediately go down to the dirty water tank. It can suction, though. Any tips?


sounds to me as if you have calcium deposits from hard water.

Take your cleaner solution reservoir and fill it with Vinegar and Hot water. Place your machine in a dry bathtub and run it until the tank is empty. Do this a couple times. When it works properly run some clear water through.

Mar 19, 2013 | Kenmore 85930 PowerSpin Deluxe Upright...

1 Answer

I have a kenmore stylite retraxx vac. That needs a belt.does any one know what style or number belt I need? Please help


Go to www.searspartsdirect.com and enter the model number of your vacuum. Then you'll be able to find the specific belt which goes with your model. If it's the Model #21637020700, then the belt is part number 1CKD208000, and costs $3.29.

Aug 14, 2012 | Vacuums

1 Answer

Kenmore stylite vacuum has no suction


CAN'T USE THE PARTS.THE SUCTION WONT COME THOUGH

Aug 01, 2010 | Kenmore Vacuums

2 Answers

Kenmore progressive 360 vacuum cleaner has low suction


Check the tube that leads down to the brush head for clogging as well as any motor or HEPA filters. If that still shows nothing, take the cover off the brush head (like you're changing the belt) and look for obstructions in there. Usually, if you have low suction on the accessory hose, the problem is with a motor filter, HEPA filter, or a clog where the hose goes into the unit. If you have good suction on the accessory hose but none on the floor, it's usually in the brush head (clog or broken belt) Good luck

Feb 28, 2010 | Kenmore 35912 / 35913 Progressive Upright...

1 Answer

We have a Kenmore canister vacuum cleaner and the power in the floor component (rotating brush, etc) is no longer functioning. The vacuum is producing suction, but does not seem to be providing power to...


the problem could be with the power head itself or the hose providing the power. If you can turn the unit on from the handle, then its not the hose and you need to get a new power head..

Aug 14, 2009 | Panasonic Kenmore Canister Vacuum Vacuum

1 Answer

Not sucking up water


Hi.  I had the same problem.  After looking at the manual I went back and made sure the canister was making a proper seal.  That fixed the problem.  Make sure when you put the top back on the canister (that holds the dirty water), that you place the two front hinges in  place first and then snap the center clap on the back of the top.  This will give you a proper seal for suction. (My two front hinges weren't fitting correctly.)
Good luck!

Oct 25, 2008 | Hoover SteamVac Carpet/Upholstery Deep...

1 Answer

Little suction in craftsman canister style carpet/floor cleaner


you might have a leak on the suction side...perhaps the housing is not properly secured, or there is a **** in the black plastic hose.

Sep 10, 2008 | Shop Vac 925-13 Canister Wet/Dry Vacuum

1 Answer

Miele vacuum cleaner not working properly


Is the suction low or ok at the vacuum without the hose attached? If it is ok, then there is a clog in the hose. If it isn't, then check filters, is the speed variable, is the contol set too low. Could be a bad motor, running too slow.

Mar 05, 2008 | Vacuums

1 Answer

Sudden loss of suction.


Check the inlet down by the brush roll to see if it is clogged. Also check the belt to be sure it is ok. Is there suction at the hose? If not then it is still clogged.

Oct 30, 2007 | Kenmore 33721 Upright Vacuum

Not finding what you are looking for?
Vacuums Logo

Related Topics:

1,274 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18330 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...