Question about Jl Audio 300/2 Car Audio Amplifier

1 Answer

NO BASS!! I have a JL 300/2 that no longer pumps out bass...I had it checked & ALL tha connections & lights are ON,but still nothing...izs it even worth fixing 'cuz its such a good *** amp...HELP!!

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 1,940 Answers

1) Check the Subwoofer for continuity - At the subwoofer, one at a time, test the terminals for Continuity using your Digital Multi-Meter; if your DMM doesn't have a Continuity test, use the Resistance, or Ohms, test and check for Resistance in the Subwoofer Coil (be sure to disconnect the subwoofer wiring before performing these tests).
2) If they test out good, hook the wires back up and test the terminals at the terminal cup or at the Amp hookup if you didn’t use a terminal, don't hook it up to the amp yet. Sometimes the wiring inside the box can be a problem if it has come loose, or isn't making a great connection.
3) If you have a Sub or multiple Subs with Dual Voice Coils, or multiple Subs with Single Voice Coils, make sure your wiring is correct by checking here:
http://www.the12volt.com/caraudio/woofer_configurations.asp
4) Make sure there are no Hi-Pass filters, crossovers, or multi Channel switches enabled.
5) Replace your RCA cable/s with known working RCA cable/s from the Source/Head Unit to the Amplifier/s.
6) Check your Head Unit settings; make sure the Bass is turned up and/or the Subwoofer setting is turned On.
7) If you are still getting no or low output, try plugging in an MP3 player or CD player using a headphone to RCA adaptor and check for sound output. If there is still no or low output, your Amplifier outputs are probably burned out.

Posted on Jul 18, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Technician can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Technician (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

It's not hitting hard at all


Signal getting to and from the Amp is problematic, if you do not have the correct wiring that will carry the necessary power then you are never going to get the sound you are looking for. Start with testing the AMP and then Wires....

Mar 01, 2014 | Hifonics Car Audio & Video

1 Answer

Amp shuts off.


check the connection of power connection and the remote connection tone amp,you can check also you inside by using your hand ,turn on the amp and wiggle it the power connection parts.

Jun 15, 2013 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Bass cut off when volume is too high


When an amplifier shuts the Bass off that means its going into protection mode otherwise it will burn out the outputs. One way is to turn your gains down, Pioneer amps are not the best amps for bass out there, they are more for car speakers, I personally wont use a pioneer amp to run my subwoofers especially if they are hard driven subs like JL , Kicker Solo's and MTX subs. But for now just turn the gains down to 3/4 and that should help u, you can also install a fan to keep your amp cooler, if this never happened before in 5 yrs and now it does then that means your amp is just tired and the inside components are overheating easily, thats common with Pioneer and Sony amps.

Good luck buddy.

Lex...

Jun 12, 2010 | Pioneer Car Amplifier GM-5100T - 2CH 760...

1 Answer

Bass freezes at a certain volumn and no longer gets higher


JUST CHECK THE CROSSOVER SWITCH, AND MAKE SURE THE SWITCHES ARE IN THE CORRECT POSITIONS

May 22, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

500/1 amp turns on, but small ugly bass comes out speakers


Heat sink is jacked!!! Burned it out. Replace it or send it away to get fixed.... check the pricin on it sometimes cost alot almost as much as new amp....

Nov 04, 2008 | Jl Audio 500/1 Car Audio Amplifier

2 Answers

JL 300/2 v2 Power Light Blinks, No sound out of Sub. Works in friends Car HELP


Are you sure you don't have any shorted wiring or defective speakers?


Sep 30, 2008 | Jl Audio 300/2 Car Audio Amplifier

3 Answers

Jl audio


If the amp was hot, it probably has a serious problem. You should have it checked out by a qualified tech. Don't continue to use it. More serious damage could occur.

May 29, 2008 | Jl Audio 1000/1 Car Audio Amplifier

2 Answers

Bass boost


yes! just set it to bridge mode connection!

Oct 12, 2007 | Jl Audio 1000/1 Car Audio Amplifier

Not finding what you are looking for?
Jl Audio 300/2 Car Audio Amplifier Logo

199 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Audio & Video Experts

Mark Skinner

Level 2 Expert

77 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

hoyzee1

Level 2 Expert

150 Answers

Are you a Jl Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...