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My computer is slow - Dell C521 DimensionTM PC Desktop

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DEAR

  • Issue:
  • My computer is running slow what steps can I do to fix it?
  • Cause:
  • This issue can be caused by any of the below possibilities.
  • Hard disk drive is short on available disk space.
  • Several software programs have been installed/uninstalled leaving behind bad files and/or confusing the software.
  • Data Corruption.
  • Missing Windows updates / Outdated drivers.
  • Computer is overheating.
  • Corrupt OS.
  • Bad Hardware.
  • Solution:
  • Below are steps for Microsoft Windows users that should help speed up the computer or determine why the computer is running slow.
  • Note: If it is just your Internet that is slow see document CH000986 for reasons why this may be happening.
  • Not enough hard disk drive space
  • Verify that there is at least 200-500MB of free hard disk drive space. This available space allows the computer to have room for the swap file to increase in size as well as room for temporary files.
  • Steps on how to determine how much disk space your computer has can be found on document CH000369.
  • See document CH000528 for additional information about regaining lost hard disk drive space.
  • Hard drive corrupted or fragmented
  • Run Scandisk or something equivalent to help ensure that there is nothing physically wrong with the computer hard disk drive.
  • Run Defrag to help ensure that data is arranged in the best possible order.
  • Background programs
  • Remove or disable any TSRs or programs that automatically start each time the computer boots. See document CHTSR for additional information. If you're wanting to see what programs are running in the background, how much memory they're using, and their CPU usage open Task Manager. Also, if you are running Windows 7, you can run Resmon to find out which programs are taking up a lot of space.
  • If you've got an anti-virus scanner on the computer, spyware protection program, or other security utility make sure it's not running in the background as you're trying to work. Often when these programs begin to scan the computer it can decrease the overall performance of your computer.
  • Hardware conflicts
  • Verify that the Device Manager has no conflicts. If any exist resolve these issues as they could be the cause of your problem. Information about how to get into Device Manager can be found on document CH000833.
  • Update Windows
  • Make sure you have all the latest Windows updates installed in the computer. Additional information about making sure Windows is up-to-date can be found on document CH000545.
  • Update your drivers
  • Make sure you've got the latest drivers for your computer. Especially the latest video drivers. Having out-of-date drivers can cause an assortment of issues. See document CH000546 for additional information.
  • Computer or processor is overheating
  • Make sure your computer and processor is not overheating, excessive heat can cause a significant decrease in computer performance some processors will even lower the speed of the processor automatically to help compensate for the heat related issues. Additional information about your processor temperature and was of determining how hot it is can be found on document CH000687.
  • Specific operating system basic troubleshooting
  • Basic Microsoft Windows XP troubleshooting.
    Basic Microsoft Windows 2000 troubleshooting.
    Basic Microsoft Windows NT 4.0 troubleshooting.
    Basic Microsoft Windows ME troubleshooting.
    Basic Microsoft Windows 98 troubleshooting.
    Basic Microsoft Windows 95 troubleshooting.
    Basic Microsoft Windows 3.x troubleshooting.
  • Or go through the other basic troubleshooting steps.
  • Memory upgrade
  • If you've had your computer for more than one year it's likely you're computer is not meeting the memory requirements for today. We suggest at a minimum the computer have 1GB of memory. Additional information about determining how much RAM is installed in your computer can be found on document CH000149.
  • Erase computer and start over
  • Finally, if none of the above solutions resolve your issues, it is recommended that you either reinstall Windows and/or erase everything and then start over. Additional information about how to do this can be found on document CH000186.
  • Hardware issues
  • If your computer continues to be slow after going over each of the above recommendations it's possible that your computer is experiencing a more serious hardware related issue such as a failing component in the computer. This could be a failing or bad CPU, RAM, Motherboard, or other component.
-----YOUR CHIRAG---

Posted on Jul 17, 2010

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Use reg in out it will solve ur problem

Posted on Sep 03, 2010

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Posted on Jan 02, 2017

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