Question about Kenwood KNA-G510 GPS Receiver

2 Answers

Navigation not working

Hello . mybe you can help me i just got a kvt-819dvd and the kna-g510 and i just had it put in my car it does not come on it says naviation on the top of the screen in blue but the reast of the screen is black screen with nothing on the screen its blank . please help me if you can

Posted by on

  • rmss Apr 26, 2008

    well if you reset it allready try pressing the v button 1-3 times it should come on after that 

  • rockmakde Jun 03, 2008

    i got the kna-g430 all connected properly there is power and all but on my monitor the ddx7039 i sellect nav, and it dosent work,it says navigation on top left but nothing happeneds

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Recheck your connections on the kna-g510 and ensure it is getting power, not too familar with the kvt-819, but I've got the kvt -915 and when I pull up the screen, there is an icon right by the src icon, that looks like a wrench. Press that and find A/V interface and ensure that the navigation input is set to RGB, also you can back out and go to user interface and ensure the Navigation is set to auto intstead of manual. That may be the case if it is similar to the kvt -915.

Posted on Apr 26, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

Well, I cant really give a solution yet to this problem.I too will have this same setup. I will be home soon around may 1st, and I will be installing this same set up. Once I get installed I will see if there is anything I can suggest to solve this problem you are having.

Posted on Apr 25, 2008

  • Xr4t3D May 05, 2008

    I checked both of these solutions; by changing the navigations input to RGB and also hitting the v button a couple of times. I was able to get the navi to work. But now I have another problem...



    On the main menu page, were the Tuner, DVD, USB, etc.. are displayed; my Navi button doesnt work. It seems to be greyed out, but I can access the Navi Button by changing the the V button. I find this a little weird. Does anyone have any suggestions?

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hello


post your question and we will help you the best we can thank!

Nov 30, 2008 | Kenwood KNA-G510 GPS Receiver

1 Answer

Maps Unavailable???


You should go back to that place who installed it for you and ask them. I'm not an expert, just another poster with another problem.

Aug 25, 2008 | Kenwood KNA-G510 GPS Receiver

2 Answers

Garmin's KNA-G510 won't find satellites unless I tell it I'm in another state and it expands satellite search


I have the g510 with a kenwood head unit. On the satellite screen, on the left it only shows one satellite and on the right it is showing that there are upwards of six or so satellites that it is receiving reception from. I thought it might be the antenna, so I bought a new one. Still having the same problem. It cannot find my location. I've updated the software, I don't know what to do!!

Aug 14, 2008 | Kenwood KNA-G510 GPS Receiver

1 Answer

KVT-719 NAV button not highlighted unable to select


Well I see no help here, but emailed kenwwod and they told me:

The Garmin menu is not accessible from the main source select screen, only thru the V.Select which you have already discovered.

The reason why "NAV" is displayed as an audio source is if you were to add a GMX30 XM Radio/NavTraffic antenna, you would be able to access XM radio (subscription required). So unless you have the GXM30, you will never use that source key.

Jul 12, 2008 | Kenwood KNA-G510 GPS Receiver

1 Answer

I need a gps with maps of europe and north america


hello i got a navigation system for sale i do have some of thoes maps ill sell it to you for a good price i need the money or i will not sell it . you can email me at . dsm_rick@mchsi.com if you are intersted in the unit . thanks 

Mar 28, 2008 | Kenwood KNA-G510 GPS Receiver

1 Answer

Installing kna-g510


You have to select your video source to GPS instead of the source in the main menu to GPS

Jan 22, 2008 | Kenwood KNA-G510 GPS Receiver

6 Answers

Kna-g510 gps receiver not working


I have the same problem, did anyone get to fix it?

Jan 02, 2008 | Kenwood KNA-G510 GPS Receiver

2 Answers

Kenwood DV4100


Check the navigation setup and make sure the voice guidance is set to on. If it is, then the installer didn't catch the right wire for vss. Had the same problem, after getting my unit professionally installed, figured it was a problem with unit so I upgraded to the G510 and installed the DV4100 in my other vehicle myself, caught the right vss wire and now the unit works perfectly,displays turn by turn and gives voice guidance. Read previous solutions, they really help.

Dec 25, 2007 | Kenwood KNA-DV4100 GPS Receiver

1 Answer

KNA G510 arrow looking forward but when driving going backward


if you haven't done so already, upgrade to the latest firmware and see if it fixes the issue.

firmware can be found here

if this doesn't fix the issue, post a followup, if it does, please mark this as solved.

Nov 21, 2007 | Kenwood KNA-G510 GPS Receiver

1 Answer

KNA-DV4100 goes nutz


I have seen this before it is hard to put into words what cause the trouble you are haveing, you done the right thing by ordering the update wait for that to come then go through the install process. The processor chip inside is what doing it the update might help and it might not GPS units can not handle any kind of power spike no matter how small its that or the single from a satellite could have done it that happens alot when the rays from a sun spot don't get filltered out it can mess up the satellite single and send crazy info down to the unit which messes up the unit processor. Some units has a small battery inside if yours has one take it out before you do the update just for an hour then put it back in give it two min, and start your update if you don't have a battery plug it in turn it on then unplug with power butten still on give it an hour then start your update good luck some times the update works and some times it don't.

Oct 12, 2006 | Kenwood KNA-DV4100 GPS Receiver

Not finding what you are looking for?
Kenwood KNA-G510 GPS Receiver Logo

Related Topics:

619 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood GPS Experts

yadayada
yadayada

Level 3 Expert

63456 Answers

Mike

Level 3 Expert

4332 Answers

kakima

Level 3 Expert

98762 Answers

Are you a Kenwood GPS Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...