Question about John Deere Garden

1 Answer

Lack of power after running for 15-20 minutes.

After using the John Deere X300 for a while (15-20 minutes), it doesn't have as much power. A hill that I normally climb is impossible to climb after the mower has been run for a while. It isn't that the ground is wet and the wheels are spinning, it just won't make it up the hill.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 404 Answers

It sounds as though the ground travel belt (Drive belt) is slipping, you didn't mention the engine was bogging down so that is what comes to mind first. adjust the tension or replace the belt and if it is slipping that will remedy the issue.

Posted on Jul 16, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Model X300. How can I replace drive belt?


Visit the on-line store, know as reliable-store, they have the repair manuals. I'm sure you will get the solution of your problem.
JOHN DEERE X300 SERVICE REPAIR MANUAL

Apr 15, 2016 | John Deere Garden

2 Answers

John Deere x300 want go forward are backward and the lever is all the way in also when you pull it out it doesn't go into neutral


Visit the on-line store, know as reliable-store, they have the repair manuals. I'm sure you will get the solution of your problem.
JOHN DEERE X300 SERVICE REPAIR MANUAL

Oct 29, 2015 | John Deere Garden

1 Answer

Motor will only run a few minutes, then cuts off.


clean carb,make sure float isnt stuck or full

May 25, 2015 | John Deere Garden

1 Answer

John Deere X300 stalls after running for 1 hour


Diesel filter clogging up, may have water in it

May 15, 2012 | John Deere Garden

Not finding what you are looking for?
Garden Logo

Related Topics:

1,195 people viewed this question

Ask a Question

Usually answered in minutes!

Top John Deere Garden Experts

Phil Walker
Phil Walker

Level 3 Expert

608 Answers

Tim Whalen

Level 3 Expert

3074 Answers

Matt Olenzek
Matt Olenzek

Level 2 Expert

293 Answers

Are you a John Deere Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...