Question about Celestion CSW Speaker

1 Answer

I have a Celestion CSW Sub woofer. It powers on as the light lights up but I get no sound i checked the fuse and it seems to be great and intact. I also checked the actual driver to see if it was blown or rotted but it is in great shaped. I connected it to my amp and also to satelite speakers but did not get a sound is there anything you can tell me about this speaker? thanks

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

This speaker has a low frequency roll-off filter. Does your program source have low enough frequencies to pass through the filter? The effect of the subwoofer on most music is very subtle unless there is heavy bass in the source. You should try some songs that have a heavy under beat.

How are you driving the CSW -- by way of the line input or as a series connection to your full range speakers?

Posted on May 06, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Blue light flashes on sub woofer cant get sound


After you confirm that the audio signal is reaching the subwoofer, then either the amplifier or the woofer itself is defective. U can establish continuity across the leads of the SW - if ok, then check to make sure that the surround of the cone is intact. If sw passes the inspection(s) the the anomaly lies with the amp.

May 22, 2015 | Audio Players & Recorders

1 Answer

Hello Guys,Can you please help? can I replace the sub woofer on my sony home theatre system DAV-DZ231 with a Celestion sub woofer s10


Presumably, the Celestion subwoofer is self-powered in which case it would connect to an RCA subwoofer output on your Sony system if there is one.

Oct 30, 2014 | Audio Players & Recorders

1 Answer

How do I set up a Celestion S10 Subwoofer...


OK
Voltage is relevant to where you live in the world. America it's 110. Europe mostly 220.
What you're asking is a very deep and complicated question.
I'm attaching a link with some articles.
What I suggest is that you find an upper end audio store and ask a 20 audio head to set up your system for you. Subwoofer Setup and Calibration for Best Bass

Apr 12, 2014 | Celestion S10 Subwoofer

1 Answer

MX6050D Subwoofer Issues


Hello, welcome to Fixya!

Fault is either from the main system or the sub-woofer itself.

You need to test both unit in order to detect which of the two is giving the fault, so that you can concentrate on the faulty unit.

Test the woofer with a AA battery or any other battery. Put your ears close to the woofer and observe if you will hear any sound. If the woofer makes sound, then it means the woofer is working, but if it doesn't make sound, then it means the woofer is defective. Or you can disconnect one of the working speakers and connect the woofer to that part. If there is no sound, then obviously, the woofer is defective.

If the woofer seem to be working, then the unit needs to be tested also.

Connect one of the working speakers to the sub-woofer's section of the main unit. If the speaker doesn't bring out sound, check the system's menu settings, check the volume and make sure the sub-woofer volume is raised to the highest level and not on mute. ( Note that most Theater systems has separate volumes for each speakers). If the volume is raised to the highest level and there is still not sound from the woofer part, then it means the woofer channel has burnt. It could be a fuse or a defective channel. At this point, I think you need help from a repairman.

I hope the above is clear.

Regards.

Nov 17, 2011 | Audio Players & Recorders

1 Answer

My subwoofer doesn't receive power, all amp fuses are fine, amp powers on, remote wire and rca wires are connected and intact. Before it stopped working all together the woofer would cut out and after...


If you are getting power to the amp, try this....Find a small speaker, unhook your sub and wire speaker to amp. Turn on your system at a low volume....If the other speaker is playing through amp, then your sub is shot.....If the small speaker doesnt work, then its either your channel is gone on the amp or the rcas have quit off off your head unit.

Oct 07, 2010 | Kenwood eXcelon X1200M Car Amp

1 Answer

When i hook up my subwoofer it won't sound


Make sure that the Sub woofer power is on ,if so check the woofer after removing if the windings are intact.
If so the power amplifier is faulty as the power output is not working.It can be the output , possible that a fuse has blown or the driver but a voltage and continuity test is important to determine.

Sep 26, 2010 | Yamaha RX-V740 Receiver

1 Answer

No Sound


This might very well be a fuse - check by setting the sub woofer to "On" to see if it powers up. If it does, there may be a problem with the sub woofer audio cable(s) or connection(s).

Don't forget to check for a tripped circuit breaker or blown fuse on the stereo's speaker output. If your sub is connected to a low level output - this shouldn't be a possible cause - as circuit breakers & fuses are usually on amplified (high level) or speaker outputs.

Another possibility is that the settings of the stereo has been changed from a *.1 system to plain stereo 2.0 or some other setting that disables the LFE (low frequency effects) or sub woofer audio output.

Sep 18, 2009 | JBL Venue SUB10 Subwoofer

1 Answer

Clestion S10 Sub not working


Instead of connecting it to the sub output, try it on the L or R output of your amp.
This will eliminate the Denon.
If this fails, you need to test the loudspeaker driver unit whilst disconnected from the sub amp. Use a 1.5v cell (AA or bigger) connect using croc leads to the speaker's terminals. If the speaker is OK, you should hear a click. If you hear nothing, the speaker unit is faulty.

Jan 25, 2009 | Celestion S10 Subwoofer

2 Answers

NAD 304 AMP...No Sound at all on both channels, Black marks on inner case.


This may be a silly question, but the pre-out/main-in jumpers are installed, yes?

Sep 25, 2008 | Audio Players & Recorders

Not finding what you are looking for?
Audio Players & Recorders Logo

358 people viewed this question

Ask a Question

Usually answered in minutes!

Top Celestion Audio Players & Recorders Experts

Josh Whitehead
Josh Whitehead

Level 3 Expert

1148 Answers

 Grubhead
Grubhead

Level 3 Expert

5047 Answers

Pieter Vleeshouwers
Pieter Vleeshouwers

Level 3 Expert

1790 Answers

Are you a Celestion Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...