Question about Hoover Tempo Widepath Upright Vacuum - Blue

Open Question

My Hoover wind tunnel tempo has lost suction, WHY? It is only three months old!!

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Agent Don
  • 310 Answers

SOURCE: Hoover wind tunnel self propelled U6617-960

http://www.geeksquad.fixya.com/ThreadView.aspx?prdid=40485&thid=557365
Hoover Windtunnel self propelled U6617-960
Posted by srkelly on Apr 29, 2008
The vacuum has no suction at the floor. I have checked the hose, and no blockage. When I try to use the attachments, still no suction. What could be the problem.

Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure.
Hoover U6437-900 / U6439-900 Windtunnel upright Vacuum
You definitely have a clod between the tube by the brushroll area and the attachment hose and the best way is to take a wire hanger and make a little hook on the end to see if there is a clog, the clog is closer to the fan area and anything big would clog up the area sideways and
-- you may have to remove the top cover to see if there is a clog and to better get @ it from the top. Another suggestion is to do a belt change whether you have one or 2 belts on the vacuum and to change the belts @ the same time every 4 to 6 months. Also, check you owner’s manual under trouble shooting to see if there is something else, other wise that is what I think is the problem. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.
http://www.hoover.com Telephone
Contact our Customer Service Department at 1.330.499.9499
Monday through Friday
8 a.m. - 7 p.m. EST

Don – The Vac Man
Go Ahead. Use Us.

Posted on Apr 29, 2008

  • 1 Answer

SOURCE: Hoover Wind Tunnel ON/Off Switch

This happens all the time on our vacuum. Just remove the handle and switch the button manually inside. You will have to do this from time to time as the power switch on the outside will constantly stop working. This, along with the belt replacements are the common complaints on this machine.

Posted on Jul 28, 2008

Pnutgllry
  • 57 Answers

SOURCE: Hoover Wind Tunnel bagless- issue with turning on

Have you tried to plug the vaccuum in another outlet that is on another breaker? It could be the vaccuum tripped the breaker. Turn the breaker back on. The manual mentions the thermal protector could have been activated. If this happened it resets and your vac should run after 30 minutes. I have a Widepath Tempo and it has tripped the surge protector. If this is the problem try turning some things off that are also on that breaker/outlet, or unplug them when you use the vac.

Posted on Jan 06, 2009

  • 120 Answers

SOURCE: Hoover Wind Tunnel does not turn on

that is a pretty good lifespan for a hoover, but its probably the power switch that's bad. Hoover uses a very poor quality switch. It shouldn't cost to much to have it replaced

Posted on Jul 06, 2009

Vac Belts
  • 701 Answers

SOURCE: How to change the V belt on hoover wind tunnel U6435-900 ?

Below I have listed a link to the manual which has instructions and a link to the V belt you need.

Windtunnel Manual

Windtunnel Replacement Belts

Posted on Nov 03, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hoover 30600 max wind tunnel less than a year old makes a whistling noise


Ours did too. I bought a Dyson.

Check for gaps in the hoses and in the wind tunnel canister. Something is not sealing properly.

Nov 11, 2016 | Hoover Vacuums

1 Answer

Loud rattling noise and no suction


You have something that's been sucked up into the floor cleaning part of the machine... then clogged it off. Be persistent and you should be able to find it and get it out..

Nov 04, 2013 | Hoover Vacuums

1 Answer

My hoover has no suction. How do you unclog the hose?


get an old wire coat hanger and straighten it out and unclog you pipe.adrian,,,,

Jul 07, 2010 | Hoover Company Wind Tunnel U53019 Upright...

1 Answer

Hoover Wind Tunnel bagless- issue with turning on


Have you tried to plug the vaccuum in another outlet that is on another breaker? It could be the vaccuum tripped the breaker. Turn the breaker back on. The manual mentions the thermal protector could have been activated. If this happened it resets and your vac should run after 30 minutes. I have a Widepath Tempo and it has tripped the surge protector. If this is the problem try turning some things off that are also on that breaker/outlet, or unplug them when you use the vac.

Jan 04, 2009 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Lost suction - Hoover Wind Tunnel S3630


You have a clog. The "bag full" indicator is nothing but a vacuum gauge, and impeding the airflow will cause a false indication of a full bag.
Clear your hoses and the air pathways behind the brushroll, and you will be back in business.

-R

Sep 27, 2008 | Vacuums

1 Answer

No suction on Hoover Wind Tunnel.


Greetings from GoVacuum.com,

First this is a common problem on ALL bagless vacuum cleaners. Usually it takes longer then 1 day however.

Is there no suction in the suction hose, or is it not suctioning from the floor?

Most people buy a bagless vacuum once, then return to a bagged one after their bad experience, you are not alone!

Please give me the model number to your Hoover, (found on the bottom or the back of the vacuum on a foil label).

Thanks,

Chris Jones
GoVacuum.com
1-866-468-2288
chris.jones@govacuum.com

Aug 18, 2008 | Vacuums

1 Answer

Wind tunnel hoover


Do you have suction at the hose end, if you do then it may be clogged at the inlet by the brush roll. Is the filter cartridge clean? If it is clogged and air can't pass thru it, then you will have no or low suction. Might also check the belt to make sure it is turning.

Nov 30, 2007 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Problem with vacuum suction in upright position


Move the lever on the front of the machine to "carpet". It won't agitate on floor

Apr 11, 2007 | Hoover Company Wind Tunnel U53019 Upright...

Not finding what you are looking for?
Hoover Tempo Widepath Upright Vacuum - Blue Logo

Related Topics:

82 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18392 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1461 Answers

Brad Brown

Level 3 Expert

15557 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...