Question about Kicker 06ZX1002 Car Audio Amplifier

1 Answer

My amp stopped working

My amp went into protection and then it just stopped working i seen that the fuse was blown but evertime i put a fuse in it pops without the car being on the fuse to the battery is not blown only the one that is hooked up to the amp..

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 407 Answers

Its a short inside the amp. Sorry to say, but you will have to have it fixed or buy a new one which sometimes cost about the same. Good Luck!

Posted on Jul 11, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hello, im having problems with my Audiobahn a2300hct amp. Ive bought it from ebay, putted in my car, added my sub wirred on 2 ohm. It had pumped it for about 5 mins, and then went into a protection mode....


HELLO THESE AMPS ARE FAMOUS FOR DRAWING ALOT OF CURRENT AND IF YOU PLAY THE AMP WHILE THE VOLTAGE DROPS FOR TOO LONG YOU CAN FRY THE AMP BUT AS FAR AS THE SECOND AMP NOT WORKING AS WELL YOU MAY HAVE A PROBLEM WITH THE RCA'S OR THE OUTPUT ON YOUR HEAD UNIT WENT BAD OR YOU HAVE A BAD GROUND CHECK ALL FUSES THEN CHECK THE GROUND WIRE TO MAKE SURE ALL PAINT HAS BEEN SCRATCHED OFF AND THAT IT IS CONTACTING BARE METAL THE ONLY OTHER OPTION IS FIND A FRIEND THAT HAS THEIR WIRES RAN AND HOOK UP YOUR AMP ON THEIR SUB IF IT WORKS THEN TRY IT WITH YOUR SUB IF IT GOES INTO PROTECT THEN YOU MAY HAVE A BLOWN SUB CAUSING THE SHORT HOPE THIS HELPS THERE ARE ALOT OF OPTIONS START WITH THE WITH GROUND AND GO FROM THERE

Dec 06, 2014 | Car Audio & Video

1 Answer

My air conditioner just stopped blowing and every light on my dashboard is on, what's going on?


I personally do a little list of things when blasted with major chaos like that. You've left out about a thousand things sooo... Is the car still running did this happen when you turned the AC on or did it come out of the blue? have you done work on anything recently? Seems funny you'd mention AC when a lot of people might just say I went out to the car and Bam! or I'm drivin down the freeway and it all went dead! indicator panel and dash are fuse protected and the ground switching usually have hot already there and a switch applies or denies the ground, with no blown fuses sounds initially like my old favorite: Positive RED battery cable. some of my weirdest electrical issues ( real head scratchers ) have been a pos short or pos denied (due to corrosion// sometimes the corrosion is up inside and can't be seen) Anyway without knowing some crucial details can't really go much further. If you have done some work on say AC or Fan sw or blower resistor pack; retrace your steps. Might try disconn Batt pull high amp fuses reconn Batt check cables while you're there :-) and one by one putting fuses in {correct slot of course} you might just find it that way...let one of us know I'm curious on what you find~~~ hope it helps 77mitchase77@Gmail

Jul 14, 2014 | 1999 Chevrolet Cavalier

1 Answer

Kenwood kac 628 red light comes on and no audio output


The red light you describe on your amp, is the protection mode warning light. An amp goes into protect for many reasons. Here's a checklist.

1st check the fuse (s) on your amp and make sure they are not blown.

2nd check the inline fuse next to your car battery (if you have an inline fuse)

3rd, disconnect the speaker wires with amp on, does the light go off?

4th check your ground, this may be ok if you have tried another amp with the same wires.

5th.if none of these turns the protect mode off, it may be an internal fault.

you may have blown transistors and it is a tricky job to repair and costly.

Jan 28, 2013 | Kenwood KAC-628 Car Audio Amplifier

2 Answers

Kenwood kac-9104d stopped working was in car music loud amp stoped worked I stop to change fuse it wasn't blown popped hood that amp was blown don't know what's wrong with it


Turn your gain below half. Make sure you have a solid ground, not a seat belt bolt. The fuse blew to protect the vehicle because there was too much power being pulled by the amp, possibly from overheating.

Sep 19, 2011 | Car Audio & Video

1 Answer

No power to amp.....all wire connected properly


is protection light coming on when sub is connected? some radios have weak remote that blow out easy..check power on it if power is making it to amp..if its an ANL fuse they can look good but be bad.

Jun 08, 2010 | Sony XM-1502SX Car Audio Amplifier

1 Answer

Fuse blew on power now stuck in Protection Mode


Sounds like the out put stage of the amp is shorting, They are either 4 large transistors attached to an aluminium plate (heatsink) or one large chip with heatsink. also sounds as the driver stage went too when you switched it on the second time. If you know nothing of electronics I suggest you take it to an audio repair shop, as it is cheaper to repair than replace high power amplifiers.

Mar 29, 2009 | Audio Players & Recorders

1 Answer

Amp not working correctly goes into protection


Disconnect the speaker wires from the amplifier and see if it still goes into protection mode. If it still goes into protect with the speakers disconnected, there's a problem with the amp; if not, you may have a blown speaker or a shorted speaker wire.

Feb 22, 2007 | Legacy LA2098 Car Audio Amplifier

5 Answers

Protect light flashing/ticking


this problem sound like you have too low of power going to your amp, test your battery and make sure its putting out enough power for at least the mininum amount of power that your amp requires, you can find that information in your manual or sometimes they post it on the amp itself. i hope this info helps

Oct 08, 2006 | Infinity Reference 1211a Car Audio...

Not finding what you are looking for?
Kicker 06ZX1002 Car Audio Amplifier Logo

Related Topics:

73 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kicker Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

yadayada
yadayada

Level 3 Expert

76630 Answers

Are you a Kicker Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...