Question about Oster Golden A5 2-Speed Universal Motor Clipper 78005-140

1 Answer

I have an Oster A5 2-speed. I took it in to have the cord and some parts replaced one was the housing. Now the housing gets so hot I can hardly hold it. The blades do not get hot. Help.

Posted by Anonymous on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

It is just part of how Oster clippers are. You can try to alternate blades, and spray them with Kool Lube, but they just get warm.
In the event that you would like to sell them or be rid of them, I use their parts to try and fix low income housing clippers.

Posted on Jul 11, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have oster titan clippers. The brass anchors for the blade mounting mechanism are pulling out of the plastic housing. How do I fix this?


ok if the brass inserts are allowing the hinge to move away from the clipper this will obviously cause a few problems, you will need to replace the body housing (new housing comes with a different design) you can view the clipper parts here

Aug 04, 2011 | Oster Golden A5 2-Speed Universal Motor...

1 Answer

I took off the end cap of my single speed A5 to clean out the dog hair and now they will not run. Before I took the end cap of and cleaned out the hair, the clippers would run intermitenly. Sometimes...


Chances are if you could wiggle the cord and get your clippers to start again there is a short in your power cord. However there is a list of other things to check:
  1. Within the cap are two brass tabs which sit across from conjugate tabs within the main housing. These are designed to contact each other when the cap is secured. If there is any question whether they are in contact, you can exaggerate the bend slightly to ensure that they are.
  2. Check your carbon brushes to make sure they are not worn down. The brushes are directional so make sure the concave surface direction matches that of the housing and thus the armature contained within.
  3. Lastly, check your toggle switch. Gently, tug on each end of the switch's wires to make sure they are secured to both the housing and the switch. These wires can become broken and appear to be attached to the switch when they are not. The number one cause is a loose or missing switch nut, especially since Oster has switched from metal to plastic on the nut.
Hope this helps.

Jan 06, 2011 | Oster Golden A5 1-Speed Universal Motor...

1 Answer

I just replaced a faulty switch to my Oster hair clippers Golden 5 single speed. I forgot how to reattach the switch and power cord wiring. Whoops?


I had the same problem with an Oster 76. I disassembled the unit and replaced the switch but my "repair" caused the house fuse to blow.
If you're a "once in a while user" such as myself, you may find my eventual solution useful: I screwed the terminal ends of the cord directly into the main body of the clipper. This made the on/off switch the power cord itself.

Aug 06, 2010 | Oster Golden A5 1-Speed Universal Motor...

1 Answer

I have an Oster A5 2-speed. I took it in to have the cord and some parts replaced, one was the housing. Now the housing gets so hot I can hardly hold it. The blades do not get hot. Help.


tricky i should return the clipper to the repair centre with a desciption of the fault, there shouldnt be anything related to the housing problem.

Jun 11, 2010 | Oster Golden A5 2-Speed Universal Motor...

1 Answer

Back panel of dryer gets really hot.


if it was me I would replace the control thermistat mounted on the blower housing.

Jun 03, 2009 | Frigidaire GLER642A Electric Dryer

1 Answer

Oster showmaster clipper motor will not run


cord is still burnt out your local grooming tools repair shop will have it or they can put it on for an extra $2 

Mar 24, 2009 | Oster Golden A5 2-Speed Universal Motor...

1 Answer

Replacing a cord on an oster 76


Very simple task. The part is under $3. The schematic and parts list is located in the link.

http://www.clipperrepair.com/parts.htm?mid=106

Oct 28, 2008 | Oster 76076-010 Hair Trimmer

3 Answers

Replacing the part that connects the motor to the blades on an Oster blender


I don't know if this will help or if this is what you are looking for. But today I was searching the web for the bottom piece that fits on the jar and saw this website has a lot of replacement parts for Oster blenders. Hope this is what you're looking for.
Good Luck
http://www.goodmans.net/get_item_os-070_square-drive-pin-for-oster-osterizer-blenders-shor.htm

Sep 12, 2008 | Oster 6803 14 Speed Blender

6 Answers

Oster Kitchen Center won't hold a steady speed


My wifes Oster Kitchen Center slowed down and I think finally stopped. I say I think it did because I took it apart two years ago and am finally finding the time to get it back together. I cleaned it, checked the brushes on the motor(all of this is in the base unit with the control buttons on it. The upper blender/beater arm has no electrics in it.) The brushes were coated with some kind of dried crusty stuff which was keeping them from contacting the motor.I put it back together and tried it but it only hummed and did not move.
I took it apart again, this time everything came out. Motor, electric wiring plus the metal gearbox attached to the motor which drives the blender and the upper arm. I took the transmission apart (it's attached to the motor in the base unit) and found the gears in it were so gummed up with who knows what. Probably everything that leaked out of the blender.
You see, what happens is that the seal between the blender black base and the glass jar started to leak after a few years but we don't notice it. Maybe we did but we cleaned it and we thought it was all good. But the liquid can leak down into the bottom unit around the drive teeth and that little square drive that the blender locks onto. And then it goes into the gearbox and the motor. So it is a major job to clean it. Since I don't have a manual for disassembling the lower base unit, I'm just putting it back together. I cleaned all the gunk out, put some grease on the gears and the gearbox is working better but I fear not perfect. It is 30 years old!! So unless you take it apart yourself or find an appliance repair shop (is there such a place anymore?) it might not be worth the effort. But it is do-able. How long have you got?

Mar 01, 2008 | Food Mixers

Not finding what you are looking for?
Oster Golden A5 2-Speed Universal Motor Clipper 78005-140 Logo

123 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oster Health & Beauty Experts

Anglia Clipper...

Level 2 Expert

191 Answers

shaveroutlet.com
shaveroutlet.com

Level 3 Expert

1598 Answers

Michael Vincent Cruz

Level 3 Expert

868 Answers

Are you an Oster Health and Beauty Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...