Question about Power Acoustik A3000DB Car Audio Amplifier

1 Answer

Amp is on but no power output

I have the power and the ground run to the amp and the green light stays on why? even without the remote wire but when i hook the remote and audio cables i get no sound out the subs

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Power Acoustik Master
  • 17,129 Answers

Are you sure that the Main power and the ground is connected and you are gettting this switch on of the amp. If so there is a shorting inthe standby/ relay switch on circuit. You will have to open the amp and check for any burnouts. since the power is on I presume that if the set is new , some one had wrongly connected the amp damaging the circuit. It has to be probed if this proves expensive and beyond the scope of this advice. If you notice any trigg transistors, relay faulty replace other wise you need expert help. Hope you find this helpful. Good day

Posted on Jul 07, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Soundsteam 1.800 amp rubicon protection light stays on green light chirps. How do I reset the amp?


disconnect the speaker wires from the amp, and check for power. there is no resetting, other than simply turning the amp off and back on. if it powers up fine without the speaker/sub(s) connected, check your wiring and check the ohms with a meter. if you do not find a problem there(should read within 1ohm of how you wired it) then check for dc voltage coming out of the speaker terminals on the amp. should also check that the amp is getting good power and ground. if wiring and speaker(s) check out okay, then the amp is damaged. if you get dc voltage from the speaker terminals, the output transistors are shorted out and it needs to be repaired by a tech.

Mar 08, 2012 | Car Audio & Video

1 Answer

Sound turns on and off. Green light sound, red light no sound. It is like playing name that tune. A few seconds of music then off then on and repeat. It is not the deck as it has meters showing output. The...


Amp is probably going into protection mode, or does not have enough current from the power wire to continue operating. Check that the speaker wires are not shorting out against each other. Also check your power wire and ground wire. Ensure that the amp is solidly grounded. Are you using the proper gauge of power and ground wire? (4awg recommended.)

Mar 10, 2011 | Coustic Car Audio 481QE Car Audio...

1 Answer

Power problem


The best places to look are:

1. Remote wire running from fuse box or back of head unit.
2. Ground wire, make sure it is connected good the the body of your vehicle. (I almost threw away and $700 amp because the ground wasn't secure enough).
3. If equipped, inline fuses on power wire or connections on battery.

If all these check out, then its probably a short inside the amp. You can have them fixed, but sometimes it cost just as much for a new one! Hope this helps and good luck!

Jul 11, 2010 | Fusion ENAM60040 Car Amp

1 Answer

Havin problem with a1200 class a/b amp it ligts green and red at same time after hooking in remote how doi fixdo i need diagram to fix


Make sure you don't have any shorts on your speaker wires or rca cables. Unplug one at a time, the turn on power until it stays green with no protect light, then you know what input is causing the short. If you remove all speaker wires and rca wires and all you have connected is the ground, power(12volts) and remote and it still lights up red/green(in protect mode) then your problem is the amp.

Mar 09, 2010 | Car Audio & Video

2 Answers

I have a pioneer keh-p5450. can please send me a wiring diagram for this unit?


Here is the breakdown of what wire does what:
+Red..............12v ignition
+Yellow...........12v battery2.gif
-Black............Ground
+Blue.............Power antenna
+Blue/white.......Remote turn on
Orange...........Dashlight/dimmer
Orange/white.....Dashlight/dimmer
Orange/black.....Dashlight/dimmer
+White............Front left positive
-White/black......Front left negative
+Grey.............Front right positive
-Grey/black.......Front right negative
+Green............Rear left positive
-Green/black......Rear left negative
+Purple...........Rear right positive
-Purple/black.....Rear right negative

Oct 05, 2009 | Pioneer Car Audio & Video

1 Answer

Red protection light wont turn 2 green no matter what so the amp wont work


Hello mcis43fan,

The protection circuit can be activated by shorted or grounded wiring or it can be caused by a defect in the amp itself.

First, disconnect all wires except power, ground and the remote turn-on lead and see if the amp powers up normally. If it still goes into protection, the amp is defective, most likely shorted outputs and needs repair or replacement. If the amp powers up normally, test the other wiring for shorts and grounds. You can reconnect them one at a time to determine which one is causing the problem.

Hope this helps.

Aug 06, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

2 Answers

Amp light is neither green or red


have u connectted the remote wire from head unit to turn amp on? have u got + and - the rite way round.hope this of use.

Mar 05, 2009 | Power Acoustik PS2-1250 Car Audio...

1 Answer

Cant get the red led light green again


Disconnect all input and output cables and check. If the light stays red, it suggests an internal error. If not, proceed by first connecting the Sub wires and checking, then the input RCA's and checking. Remember to switch off the system before connecting/disconnecting, I suggest also removing fuses during this process.

Mar 11, 2007 | Pioneer GM-232 Car Audio Amplifier

Not finding what you are looking for?
Power Acoustik A3000DB Car Audio Amplifier Logo

93 people viewed this question

Ask a Question

Usually answered in minutes!

Top Power Acoustik Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

yadayada
yadayada

Level 3 Expert

76118 Answers

Professor_V
Professor_V

Level 2 Expert

92 Answers

Are you a Power Acoustik Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...