Question about Pyle PLTTB1 Turntable

1 Answer

I have a pyle plttb1 and i have connected with the equlilazer and did not make any sound and after connected directly with the amplifier and make some sound but very low

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 8,546 Answers

Just a guess - traditional turntables require a specific PHONO preamplifier to boost and frequency-shape the phono catrdige's tiny signal prior to sending it to conventional Line Level inputs. Get one.

Posted on Jul 06, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How to daisy-chain my Pyle amplifier with my KLH amplifier


as u do not state models here goes:
one or both amplifiers could have a stereo rca output, connect the output of the amplifier that gets signal from the head unit to the input of the other amplifier.
DO NOT share ground cables or power from one to the other (these cables should both run separate from a distribution block AND not from one amp to the other,
........do not connect both amplifiers to only one driver.........
hope this helps, let me know if you need more assistance.
....andy...

Jan 06, 2014 | Pyle Car Audio & Video

1 Answer

Does the blue wire need to be connected to 12 V + . if I have no accesories, can I just leave this wire disconnected? thanks!


The subject shows this referring to a Pyle car amplifier. Is that the case? Either way this will hopefully answer your question.

If you're talking about the blue wire from an after market car stereo and:
  • There's no accessories (as you've already stated)
  • You don't have a power antenna
  • and you're not running an amplifier
You can leave the blue wire disconnected.

If you have a power antenna it'll need to be connected to the corresponding wire in the dash (I would need to know year make an model of the care to help you identify that wire). If you have an amplifier the blue wire would be run directly to that.

Hope this helps. Let me know if you have any questions.

Thanks,
Ray

Jun 16, 2011 | Pyle Car Audio & Video

1 Answer

When i hook up both speakers it quit maken sound bt if one is hooked up it works why


are the earth connections round the right way?
try connecting the speaker wires the other way round, usually if the earth and possitives are wrong way round, it will cut the sound

Apr 06, 2010 | Pyle PLA2200 Car Audio Amplifier

1 Answer

What size amplifier to I need to operate a Pyle Driver Pro 15 inch subwoofer? It is hooked to a 200 Watt amp and there is no sound coming from the speaker?


You may want to check ALL the connections and make sure you are connected properly. You SHOULD surely hear a lot of sound even with such a small wattage amp. Blown speaker? Blown amp? Have them tested. Also the REM or remote line on the amp is a overlooked wire.

Feb 22, 2010 | Pyle Car Audio & Video

1 Answer

Trouble connecting marine amp to stereo


Hello lizskates814,

You can use either the high level (speaker) or the low-level (RCA's) inputs to the amp, but not both. Choose whichever one sounds the best or is more convenient to install and leave the other disconnected.

Hope this helps.

May 23, 2009 | Pyle PLMRA400 Car Amp

1 Answer

Can not get power to my pyle amplifier


Usually On Car Amplifiers, there is a Connector/Wire called "Remote On".
This is where Headunit supplies 12V to trigger the Power on the Amplifier.
(Of course, head unit usually has Remote Wire also in order to turn the Amplifier on).

If this wire is properly connected and still does not turn on, then try to supply 12V directly from the battery. If it turns on then your head unit has problem, If it does not turn on then your Amplifier has problem.

Jan 27, 2009 | Pyle Audio Players & Recorders

1 Answer

Wiring troubleshoot


Make sure that your car is not amplified!! Some Celicas have an amplifier under the passenger seat. If this is the case, you will need to either bypass that amplifier and go directly to speakers, or you'll need the proper interface plug. The extra rapid heat build-up indicates that your radio is incorrectly wired (channels are mixed up)
Your Pyle radio may have an extra wire for "amplifier turn-on" or for "mute". A standard wiring harness for Toyota (Scosche part TA-02B) should work in dash behind the radio in non-amplified vehicles. If you are still having difficulty, please seek advice from a local stereo installation shop.

Aug 10, 2008 | Car Audio & Video

1 Answer

What is wrong with my system


wiring may not be the problem but try connecting each coil to separate channel and make sure polarities are correct.

Aug 08, 2007 | Pyle PLA2200 Car Audio Amplifier

Not finding what you are looking for?
Pyle PLTTB1 Turntable Logo

Related Topics:

96 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pyle Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5151 Answers

Michial Gueffroy

Level 3 Expert

1138 Answers

yadayada
yadayada

Level 3 Expert

76649 Answers

Are you a Pyle Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...