Question about Hayward EC75 HAYWARD PERFLEX FILTER SYSTEM W/1HP PUMP

Open Question

Filter top seal/gasket leaks

I have a Hayward E65A DE filter and I have put three new top gaskets in and can not keep it from leaking. Is there a trick to this? I have tried tightening the bolts at different levels. Thought I made sure the seal was in straight. Just can't get it to stop leaking and now it has rusted my pump motor housing and my pressure gage. Can you help me with this or do I need to hire someone to get it right. Thanks!

Rick Brisson

Posted by on

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: My Hayward pump is leaking.

is the pump leaking from the lid if so you may have an obstruction **** as dirt leaves or debree if the pump is leaking where the motor meets the wet end of the pump then you need to replace the ps1000 seal not sure if ps1000 will work on hayward but when you go to buy one. tell the pool store employee that you need a ps seal for an hayward.

Posted on Apr 28, 2009

Ad
john224
  • 1378 Answers

SOURCE: Waste line leaking

When you had the unit apart, did you note the correct alignment of the handle to the diverter? You may have put the handle on 180 degrees away from the correct orientation and therefore flipped all the settings, making filter=backwash, etc...

If thats not it, any chance it has freeze damage inside from not draining completely and therefore needs a new valve?

Posted on Jun 14, 2009

  • 27 Answers

SOURCE: leak between seal plate and pump/strainer housing

The pump seal is leaking and needs replacing and requires removing four 3/8 bolts (9/16) wrench and removing the motor then the diffuser to get to the impeller and seal . A 7/16 wrench holds the rear motor shaft behind the springs and impeller spins off to reveal the seal which has two parts one on the impeller with a spring and one in the seal plate is white ceramic/ porcelan whatever they use. Part number is an SPX1600KA on super pumps and 1500KA wassome above grounds. When replacing do not touch the mating white and black surfaces with your fingers.

Posted on Jul 20, 2009

  • 44 Answers

SOURCE: I have a Hayward super

You forgot to replace the most important part...The" shaft seal".It is behind the impeller. Be sure to remove all the pieces of the old seal off the impeller ,(they always come off in pieces) and put silicone on the rubber part that sets in the pump housing. Make sure you keep the white porcelain surface perfectly clean, and you will also need to replace the ribbon gasket again.

Posted on Sep 30, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Google com


put a ball valve on line we do that all the time to fix a leaky multiport

Aug 15, 2014 | Hayward Pro Series 18" Above Ground Pool...

1 Answer

Just had the spider gasket replaced and now water is "gushing" out the handle


Hi Shari,
I see two possibilities. 1. The diverter shaft o-rings are not sized correctly (or missing). 2. When valve handle was reinstalled it was not oriented properly with the diverter position in valve body.
Hope this helps you.

Jun 14, 2014 | Hayward SAND FILTER, PRO SERIES

1 Answer

I have an AquaTools filter that is approximately 10 yrs old. I had a leak from the backwash. I replaced it with a Hayward spider gasket but the gasket seemed a bit small and water is still leaking out. ...


it's tight to turn because spider gasket is not correct size , if correct new old stock gasket cant be found then entire body of muliport valve needs to be replaced with modern equivelent
this will involve draining down water from entire filter section as glue needed to install doesnt like wet pipes too much and wont stick well leading to leaks , if your not 100%comfortable in doing this your self then a trusted pool service co needs be contacted ,plus who knows maybe they got the org gasket you need?

May 27, 2014 | Pentair Pac-Fab 2" DE Filter Multiport...

3 Answers

Oil leak 2000 alero, just replaced plug, not it, leaked out all the oil after I drove it 20 miles, please help, could it be a gasket or what


Check the oil filter. The old gasket might be stuck on the engine (two gaskets stuck together), or the new gasket might be defective, misaligned or missing.

Nov 05, 2011 | 2000 Oldsmobile Alero

3 Answers

Oil leak from oil filter i thimk or its from very close to the filter


Your leak could be the result of a missing oil filter gasket or an improperly sealed oil filter gasket. Remove and inspect. either way, the fix should be easy.

Please remember to rate this solution.

The FixYa Team.

Feb 04, 2011 | 2000 Pontiac Grand Am GT

1 Answer

I installed a complete hayward filter with a new multiport valve. i can see DE in my pool. what would cause this? Thanks for your help.


If these Hayward pool filters are leaking DE back into the pool, there are a couple things that you will want to check. Check for loose bolts on tube nest plates and tighten them if necessary. Make sure that you don't have a worn or loose fitting diaphragm gasket and that there are no rips and holes in it. Replace the gasket if any of these is the problem. Check for openings or tears in one or more Flex-
Tubes and replace them if necessary.

Dec 19, 2010 | Pentair Clean & Clear Filter and Dynamo...

1 Answer

Waste line leaking


When you had the unit apart, did you note the correct alignment of the handle to the diverter? You may have put the handle on 180 degrees away from the correct orientation and therefore flipped all the settings, making filter=backwash, etc...

If thats not it, any chance it has freeze damage inside from not draining completely and therefore needs a new valve?

May 28, 2009 | Hayward SAND FILTER, PRO SERIES

2 Answers

Eng oil leak/3.8 Ltr. eng.


ok who ever installed the oil filter didnt put oil on the seal and tighted oil filter down properly this lead to seal on oil filter burning up and cracking replace oil filter and put oil on the seal all the way around

May 17, 2008 | 1996 Ford Windstar

Not finding what you are looking for?
Hayward EC75 HAYWARD PERFLEX FILTER SYSTEM W/1HP PUMP Logo

Related Topics:

369 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hayward Pool & Spa Experts

Jay Finke
Jay Finke

Level 3 Expert

1343 Answers

Bill Jordan

Level 2 Expert

372 Answers

john h

Level 3 Expert

12650 Answers

Are you a Hayward Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...