Question about Aqua Flo Aquaflo Flo Master Xp2 Spa Pump 1.5 Hp Two Speed

1 Answer

My aquaflowmaster 3hp xp2 pump runs for a short while at low speed. Then I hear a click and it runs slower for about 30 seconds - then another click and returns to normal and this repeats several times untill it stops completely. If I unplug and wait a while, turn it back on, the whole process repeats. If Iturn it on hi, it shuts down almost immediately. The pump is about 6 years old

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 10,319 Answers

The capacitor on top of the motor is at fault. It isn't holding a well amount of voltage to operate this motor correctly. The higher speeds needs more voltage to give a surge to the motor to run faster and cn't provide that power with a weak capacitor

Posted on Jul 04, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Error after short prime cycle


AIR LEAK IN SUCTION LINE. PUT A GARDEN HOSE WITH A RAG AROUND IT TO BACKFEED FROM INTAKE IN POOL. WITH PUMP "OFF" TO LOCATE BREECH IN LINE.

Apr 21, 2014 | Pentair IntelliFlo VF High Performance 3HP...

1 Answer

My new flo-master xp2 spa pump will not engage the low speed. The hi speed (jets) works fine but the low speed doesn't engage. I just hear a clicking and nothing comes on.


if you had ice in it and it was powererd up.. you may have burned out the start capacitor or even the start windings..why was it iced up while working on it..it should have been freewheeled by hand before startup..I just got a tub in here.. had to wait 6 days for it to thaw out..(sign of good insulation) we just ran it for the first time yesterday..got some seals to replace and some switches to repair..

Jan 08, 2014 | Aqua Flo Aquaflo Flo Master Xp2 Spa Pump...

1 Answer

My flo-Master XP2 06620397-2 has large leak when the jets are turned on. Do I need a new one or can the leak be repaired?


sounds like you need a new seal kit if it is leaking between the plastic pump housing and the motor. this seal kit is a model PS-200 and will run you about $30

US Parts Center

Aug 23, 2011 | Aqua Flo Aquaflo Flo Master Xp2 Spa Pump...

1 Answer

I have a flo master xp2 / 48 frame / 230V / 2.5 hp / 2 speed spa pump. I accidentally hooked switched the high and common lines when wiring the electricity. The low line was done correctly, because they...


You shorted the 230 lines at the motor terminal board. If you are certain you have reset any and all breakers feeding the spa and that the 230V is getting back to the pump motor then you blew the winding leads as you shorted the motor. While it is possible a motor shop could repair the leads it is far more likely the damage caused will cause the price to be that or more of a replacement motor.

John

Sep 21, 2010 | Aqua Flo Aquaflo Flo - Master Xp2 2 Speed...

1 Answer

What do i replace my 4hp Flo Master XP2 wet end with? Everything now is for 3hp or less


Thank you for posting your question here on Fixya.com.

Your wet end was most likely the 3HP version all along. Most pump manufacturers use the motor service factor to exaggerate the HP rating to try and sell the unit as 'better' than the competitors. You are best off using the part number molded into the original impeller as a means of identifying what pump you really have and ordering the wet end based on that information. If you can get the 8 digit number please post it in a comment to this message and we can verify the correct wet end for you. Another alternative will be to use a Waterway Executive model wet end if yours is indeed a discontinued 4HP rating.

If this answer does not fix your problem, please comment with additional details prior to rating the answer. Positive feedback is appreciated once your problem is solved!

John

Aug 18, 2010 | Aqua Flo Aquaflo Flo Master Xp2 Spa Pump...

1 Answer

Wiring diagram for flo-master 56 frame xp2. I have a new pump that was improperly wired from the factory.It is a two speed pump only running one speed. If I knew where the factory wiring should be...


The side of the motor will have a wiring diagram for how to connect the common, low and high speed leads. Your wire harness should have a white (common), black (usually low), red (usually high) and green (ground) wire. If high and low are backwards, switch the black and red leads.

Nov 23, 2009 | Aqua Flo Aquaflo Flo - Master Xp2 2 Speed...

1 Answer

When I turn on the jets at the first setting it brrrr's but does not start. The second setting works fine and when the second cycle is finished the first continues fine. It is just when it first started...


Sounds like you may have a bad start capacitor that is not kicking the motor when it's set to run the low speed. If it just humms, it's usually a capacitor. It can also be the bearings but if it runs quietly normally, then it's probably a start capacitor. Hope this helps.

Nov 01, 2009 | Aqua Flo Aquaflo Flo Master Xp2 Spa Pump...

1 Answer

Hot tub pump will not run. Pump makes a click noise and hums but will not run, could this be a start capacitor gone bad


This can be one of three issues.
1.  Starting capacitor as you have suggested.  You can take the capacitor to a motor shop and have it tested or test it yourself if you have a meter that will check capacitance. 2.  Low/High voltage.  If the voltage is not at the proper levels (10% up or down) then the unit may have a hard time starting. 3.  Something might be binding up the impeller.  Disconnect the power and carefully check to see if the shaft of the motor spins freely. 4.  A short in the windings.  If none of these seem to be the problem, then you will probably need to replace the motor.

Dec 11, 2008 | Aqua Flo Aquaflo Flo Master Xp2 Spa Pump...

Not finding what you are looking for?
Aqua Flo Aquaflo Flo Master Xp2 Spa Pump 1.5 Hp Two Speed  Logo

Related Topics:

76 people viewed this question

Ask a Question

Usually answered in minutes!

Top Aqua Flo Pool & Spa Experts

Ian Kime
Ian Kime

Level 2 Expert

77 Answers

Bill Jordan

Level 2 Expert

372 Answers

Jay Finke
Jay Finke

Level 3 Expert

1338 Answers

Are you an Aqua Flo Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...